just installed Advanced - how do I confirm it is working

phpBB3 SEO Advanced mod Rewrite support forum.
This mods performs URL rewriting for phpBB, injecting forums and topic titles in their URLs.

Moderator: Moderators

just installed Advanced - how do I confirm it is working

Postby e13o13 » Wed Sep 10, 2008 1:36 pm

As best I can tell, I did everything I needed to, I made sure all the files are changed, ran the install, generated and moved the .htaccess to the root directory and added the updated robots.txt and refreshed the theme on the ACP...

but when I dig through my forums, they still have the same old urls that they used to have - I looked that the Demo Forum and they don't look anything like that...

so, does anyone know why it might not be showing? Am I missing something?
e13o13
 
Posts: 19
Joined: Wed Sep 10, 2008 1:26 pm
Location: St. Louis

Advertisement

Postby frold » Wed Sep 10, 2008 2:55 pm

url please
frold
PR0
PR0
 
Posts: 95
Joined: Thu Apr 17, 2008 7:26 pm

Postby e13o13 » Wed Sep 10, 2008 3:11 pm

e13o13
 
Posts: 19
Joined: Wed Sep 10, 2008 1:26 pm
Location: St. Louis

Postby frold » Wed Sep 10, 2008 4:21 pm



I dont see the SEO logo in the footer - are you sure you have done it all described in the install-file??
frold
PR0
PR0
 
Posts: 95
Joined: Thu Apr 17, 2008 7:26 pm

Postby e13o13 » Wed Sep 10, 2008 6:20 pm

no, not at all... I thought I did - any idea what I missed if I did everything I mentioned earlier?

THis is from the install file

For a smooth install :
1) Backup all your files;
2) Apply the mod code changes on copies of your files;
3) Upload all files;
4) CHMOD the phpbb_seo/cache/ folder to 0777;
5) Empty the phpBB/cache/ folder : just delete all files EXCEPTS the .htaccess.
6) Go to -www.yoursite.com/phpBB/phpbb_seo/phpbb_seo_install.php and follow the install instruction
7) Go to phpBB ACP : It's now time to play with settings described bellow;
8) Generate your personalized .htaccess and upload or move it following the instructions;
9) Test a rewritten URL, such as -www.yoursite.com/phpBB/post1.html, if you end up with a 404 (not a phpBB message), go back to step 8;
10) Activate URL rewriting in phpBB ACP and allow yourself some auto-congratulation :D


and I did all of this. The exceptions were with #2, I actually uploaded the files first, then realized I needed to do this later and they all had the added code already - the SEO Toolkit stuff...

The other exception was #9 because, none of them appear to be re-written...
e13o13
 
Posts: 19
Joined: Wed Sep 10, 2008 1:26 pm
Location: St. Louis

Postby e13o13 » Wed Sep 10, 2008 7:46 pm

OK, I think I got it working - I was just getting confused between the pre-mod and the other mods... I ended up just installing the whole pre-modded SEO package and using that - everything seems to be working - thanks for your help
e13o13
 
Posts: 19
Joined: Wed Sep 10, 2008 1:26 pm
Location: St. Louis

Postby frold » Wed Sep 10, 2008 8:40 pm

e13o13 wrote:OK, I think I got it working - I was just getting confused between the pre-mod and the other mods... I ended up just installing the whole pre-modded SEO package and using that - everything seems to be working - thanks for your help


Seems to work. But I would disable SID in the settings...
frold
PR0
PR0
 
Posts: 95
Joined: Thu Apr 17, 2008 7:26 pm

Postby e13o13 » Wed Sep 10, 2008 9:07 pm

What is SID and what is the reason to disable it?
e13o13
 
Posts: 19
Joined: Wed Sep 10, 2008 1:26 pm
Location: St. Louis

Postby dcz » Sat Sep 13, 2008 1:28 pm

Well, there no real need to with the premod, make sure you activate the zero duplicate and set post redirection to at least guests and you'll be set ;)

++
Useful links :
SEO Forum || SEO Directory || SEO phpBB || Search
____________________

Liens Utiles :
Forum référencement || Annuaire référencement || Référencement phpBB || Recherche
dcz
Admin
Admin
 
Posts: 21407
Joined: Fri Apr 28, 2006 9:03 pm

Postby e13o13 » Sat Sep 13, 2008 1:50 pm

I noticed that the title tag includes the forum name before the topic, I think I would rather have the topic listed first - that seems better for SEO to me, isn't it?
e13o13
 
Posts: 19
Joined: Wed Sep 10, 2008 1:26 pm
Location: St. Louis

Postby dcz » Sun Sep 14, 2008 7:42 am

It's the case with the optimal title mod (included in the premod) :
http://phpbb3.phpbb-seo.net/demo-en/the ... um-t3.html
++
Useful links :
SEO Forum || SEO Directory || SEO phpBB || Search
____________________

Liens Utiles :
Forum référencement || Annuaire référencement || Référencement phpBB || Recherche
dcz
Admin
Admin
 
Posts: 21407
Joined: Fri Apr 28, 2006 9:03 pm

Postby e13o13 » Mon Sep 15, 2008 9:07 pm

if it is included in the premod, how do I turn it on... I didn't see anything in the SEO tab on the ACP...
e13o13
 
Posts: 19
Joined: Wed Sep 10, 2008 1:26 pm
Location: St. Louis

Postby dcz » Sat Sep 20, 2008 7:43 am

There is no ACP for this mod, it's just installed and activated directly.

In your case, it just seems that you added the {SITENAME} in your overall_header.html.

++
Useful links :
SEO Forum || SEO Directory || SEO phpBB || Search
____________________

Liens Utiles :
Forum référencement || Annuaire référencement || Référencement phpBB || Recherche
dcz
Admin
Admin
 
Posts: 21407
Joined: Fri Apr 28, 2006 9:03 pm

Postby e13o13 » Sat Sep 20, 2008 2:10 pm

great- thanks - that was an easy fix...
e13o13
 
Posts: 19
Joined: Wed Sep 10, 2008 1:26 pm
Location: St. Louis


Return to Advanced SEO URL

 


  • Related topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 6 guests