My phpBB forum is not getting indexed by Google

Discussion about the Google Search Engine. SEO, PageRank, AdSense, AdWords, Use and other Services.

Moderator: Moderators

My phpBB forum is not getting indexed by Google

Postby xmember » Mon Sep 24, 2012 11:15 am

Hi,

I have a site for sports betting tips, and one month ago I decided to change my build-in forum with phpbb one. The forum now has a lot of unique content,
a couple real users which write from time to time, and some daily traffic from the main site. The main forum was indexed immediately, but the subforums, and which is the most infportant for me - the content from the forum posts, they are not indexed at all.
There are a couple of sites with good traffic linking to the site, including the main site of the forum, the forum is added to google webmaster tools and it has sitemap. In the forum options, the permissions for the bots are open, so the google spiders are free to go in to every topic in the forum. I see daily that the google bots are visiting my forum, but still my subforums and my content is not indexed from google at all. I find a bit strange that this is happening, because with the traffic which I receive from the site, the forum should have been indexed very fast.

This is the address - http://www.bettinginfos.com/Forum

If you have any suggestions how to solve my problem, please share it with me.
xmember
 
Posts: 13
Joined: Mon Sep 24, 2012 11:04 am

Advertisement

Re: My phpBB forum is not getting indexed by Google

Postby Stephen26 » Mon Sep 24, 2012 11:43 am

Edit: That's what I see when I change my user agent to "Googlebot": http://oi50.tinypic.com/2m3jzhe.jpg - Seems to be a permission problem.

This board has no forums.

https://www.google.com/search?q=+site:p ... +no+forums
I install and configure phpBB-SEO (and other mods) for a fair price and very fast. If you are interested simply send me a private message.
Stephen26
phpBB SEO Team
phpBB SEO Team
 
Posts: 426
Joined: Mon May 03, 2010 7:06 am

Re: My phpBB forum is not getting indexed by Google

Postby xmember » Mon Sep 24, 2012 2:21 pm

Stephen26 wrote:Edit: That's what I see when I change my user agent to "Googlebot": http://oi50.tinypic.com/2m3jzhe.jpg - Seems to be a permission problem.



I think I found where is the problem. I added different permitions to the bots in the separate subforum options. Can you please tell me what you see now?
xmember
 
Posts: 13
Joined: Mon Sep 24, 2012 11:04 am

Re: My phpBB forum is not getting indexed by Google

Postby Stephen26 » Mon Sep 24, 2012 2:38 pm

Now (some) subforums are visible as Googlebot: http://i47.tinypic.com/1zxmc5v.jpg

You can check this with User Agent Switcher - Googlebot user agent = Googlebot/2.1 (+http://www.google.com/bot.html)
I install and configure phpBB-SEO (and other mods) for a fair price and very fast. If you are interested simply send me a private message.
Stephen26
phpBB SEO Team
phpBB SEO Team
 
Posts: 426
Joined: Mon May 03, 2010 7:06 am

Re: My phpBB forum is not getting indexed by Google

Postby xmember » Mon Sep 24, 2012 3:14 pm

Now all subforums should be visible. How long do you thing will take for google to index my content? I thing that the forum have enough traffic+content+links to be indexed in google in less than 24 hours ?For example, the new articles in my main site are beeing indexed for about 5 minutes.
xmember
 
Posts: 13
Joined: Mon Sep 24, 2012 11:04 am

Re: My phpBB forum is not getting indexed by Google

Postby Stephen26 » Mon Sep 24, 2012 3:21 pm

http://i50.tinypic.com/4ky338.jpg

To speed up the indexing process use the "Submit to index" feature in the Webmaster Tools (-> Diagnostics -> Fetch As Googlebot).
I install and configure phpBB-SEO (and other mods) for a fair price and very fast. If you are interested simply send me a private message.
Stephen26
phpBB SEO Team
phpBB SEO Team
 
Posts: 426
Joined: Mon May 03, 2010 7:06 am

Re: My phpBB forum is not getting indexed by Google

Postby xmember » Mon Sep 24, 2012 3:35 pm

Thanks a lot for your help stephen26!
xmember
 
Posts: 13
Joined: Mon Sep 24, 2012 11:04 am

Re: My phpBB forum is not getting indexed by Google

Postby xmember » Tue Sep 25, 2012 9:53 am

Ok, I saw that the destricribtion of some subforums is indexed now, but the content is still not indexed.
In the separete permitions for each sub forum I set up the bots group for "bot access" - the bots can see and can read forum. I suppose this is enough for indexing the content, and I just have to wait a bit longer?
xmember
 
Posts: 13
Joined: Mon Sep 24, 2012 11:04 am

Re: My phpBB forum is not getting indexed by Google

Postby Stephen26 » Tue Sep 25, 2012 11:26 am

Yes, give it some time. I can see all topics with the user agent "Googlebot" now.
I install and configure phpBB-SEO (and other mods) for a fair price and very fast. If you are interested simply send me a private message.
Stephen26
phpBB SEO Team
phpBB SEO Team
 
Posts: 426
Joined: Mon May 03, 2010 7:06 am

Re: My phpBB forum is not getting indexed by Google

Postby xmember » Sat Sep 29, 2012 8:04 am

Hi, the content is still not indexed at all. What it comes to my attention is that google and yahoo bots are visiting my forum very often, but they go only to one certain subforum - the one with the most spam in it. And even in this subforum, the original content is not indexed. May be the bots can reach all topics, but cant actually go into the topic and read the text. May be more options have to be changed?
xmember
 
Posts: 13
Joined: Mon Sep 24, 2012 11:04 am

Re: My phpBB forum is not getting indexed by Google

Postby xmember » Mon Oct 01, 2012 11:10 am

No improvement today also...
xmember
 
Posts: 13
Joined: Mon Sep 24, 2012 11:04 am

Re: My phpBB forum is not getting indexed by Google

Postby HB » Tue Oct 02, 2012 2:34 pm

Looks properly indexed to me:

http://www.google.com/search?q=site%3Aw ... 2FForum%2F

Googlebot isn't having a lot of luck finding the text of the first post; you could give it a hint by setting the meta description tag value to an excerpt of the first sentence or two (your current meta description tag value is blank).
Dan Kehn
HB
phpBB SEO Team
phpBB SEO Team
 
Posts: 1504
Joined: Mon Oct 16, 2006 2:25 am

Re: My phpBB forum is not getting indexed by Google

Postby xmember » Tue Oct 02, 2012 2:50 pm

HB wrote:Looks properly indexed to me:

http://www.google.com/search?q=site%3Aw ... 2FForum%2F

Googlebot isn't having a lot of luck finding the text of the first post; you could give it a hint by setting the meta description tag value to an excerpt of the first sentence or two (your current meta description tag value is blank).


Yes, the general forum, and the links to the subforums are indexed, but the content of the topics and forum posts are not indexed. This is what I need the most.
xmember
 
Posts: 13
Joined: Mon Sep 24, 2012 11:04 am

Re: My phpBB forum is not getting indexed by Google

Postby xmember » Wed Oct 03, 2012 7:10 am

All of my forum links are being indexed BUT none of the content so far. If I copy text from http://www.bettinginfos.com/Forum/viewt ... ?f=17&t=32 which is more than one month old and I paste it in google with quotes like this "This is may be the simplest strategy for sports bets, which is at the same time quite reliable" the text doesn't appear in the results.

May be some more forum options need to be changed and more permissions have to be given?
xmember
 
Posts: 13
Joined: Mon Sep 24, 2012 11:04 am

Re: My phpBB forum is not getting indexed by Google

Postby HB » Fri Oct 05, 2012 7:18 pm

It may be that your site is ranked too low. You can add the site: tag to your Google queries to confirm an item is (or isn't) indexed. One thing that might help is driving the invalid (spam) posts out of Google's index more quickly by returning a redirect instead of not found. For example:

http://www.bettinginfos.com/Forum/viewt ... =13&t=3588

Judging from what's left in Google's cache, this was a spam thread you deleted. It's returning 404; I recommend instead redirecting to your index. Google processes redirects very quickly, but waits a long, long time on "not found" since they assume (?) that 404's might be a website error while redirects aren't.
Dan Kehn
HB
phpBB SEO Team
phpBB SEO Team
 
Posts: 1504
Joined: Mon Oct 16, 2006 2:25 am


Return to Google Forums

 


  • Related topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 72 guests