Loss of attachment after the copy of the database

Discussions about the phpBB3 Forum. How to get the best from this powerful script.
Note that there is no official support for phpBB3 here, a place to share more than to ask for.

Moderator: Moderators

Loss of attachment after the copy of the database

Postby yogi3 » Wed Mar 27, 2013 12:32 pm

I am using phpbb 3.0.11 and I find out that after the copy of the database missing some attachments on forum. Is this normal when forum is big ? Below you can see link to the topic that lost all attachments after backup database.

http://pronas.pl/poczta-wiele-domen-jed ... t2009.html

I did backup for two ways, from phpMyAdmin and direct from forum and both ways cause attachments lost. It would be great if you can help me.

I asked for help on www.phpbb.com but they redirect me here.
yogi3
 
Posts: 26
Joined: Thu Oct 08, 2009 9:43 am

Advertisement

Re: Loss of attachment after the copy of the database

Postby dcz » Thu Mar 28, 2013 7:23 am

Attachments are not stored in the db, you need to make sure you also put back online the content of the phpBB/file directory (and while you're at it, the content of phpBB/donwload, phpbb/store and phpBB/images/avatars).
Useful links :
SEO Forum || SEO Directory || SEO phpBB || Search
____________________

Liens Utiles :
Forum référencement || Annuaire référencement || Référencement phpBB || Recherche
dcz
Admin
Admin
 
Posts: 21407
Joined: Fri Apr 28, 2006 9:03 pm

Re: Loss of attachment after the copy of the database

Postby yogi3 » Thu Mar 28, 2013 7:37 am

I didn`t move phpBB/file directory, so how can I put the content back online if I never move it?
yogi3
 
Posts: 26
Joined: Thu Oct 08, 2009 9:43 am

Re: Loss of attachment after the copy of the database

Postby dcz » Thu Mar 28, 2013 2:24 pm

from a backup maybe ?

Are these folders empty ?

Have you checked orphan attachment in acp ?
Useful links :
SEO Forum || SEO Directory || SEO phpBB || Search
____________________

Liens Utiles :
Forum référencement || Annuaire référencement || Référencement phpBB || Recherche
dcz
Admin
Admin
 
Posts: 21407
Joined: Fri Apr 28, 2006 9:03 pm

Re: Loss of attachment after the copy of the database

Postby yogi3 » Thu Mar 28, 2013 7:15 pm

Where in ACP can I check it ?
yogi3
 
Posts: 26
Joined: Thu Oct 08, 2009 9:43 am

Re: Loss of attachment after the copy of the database

Postby easylee23 » Fri Mar 29, 2013 10:25 pm

I hope that you can get this back up and running, I need a fresh copy install of this also.
easylee23
 
Posts: 1
Joined: Fri Mar 29, 2013 10:23 pm

Re: Loss of attachment after the copy of the database

Postby yogi3 » Fri Apr 05, 2013 1:16 pm

Should I sent you back up files or run it on my own web server and give you remote access to it? Then you will be able to check what is going one.
yogi3
 
Posts: 26
Joined: Thu Oct 08, 2009 9:43 am

Re: Loss of attachment after the copy of the database

Postby dcz » Mon Apr 15, 2013 10:32 am

So, you mean that you have lost attachment after you did a db backup ?

Backuping the db is unrelated to the event IMO, there must have been an error (while optimizing (if you repair before you optimize it can occur) table for example) during the backup process or somewhere else.

I can't really tell much more from the topic link you posted, if you edit it, do you see attachments ? If so, check the ids, and try find them in the attachment table.
Useful links :
SEO Forum || SEO Directory || SEO phpBB || Search
____________________

Liens Utiles :
Forum référencement || Annuaire référencement || Référencement phpBB || Recherche
dcz
Admin
Admin
 
Posts: 21407
Joined: Fri Apr 28, 2006 9:03 pm

Re: Loss of attachment after the copy of the database

Postby Stephen26 » Mon Apr 15, 2013 12:39 pm

Is it possible that you've reuploaded a backup of the files (not the database) with the wrong settings in FileZilla (ASCII instead of binary)
or whatever program you use.
I install and configure phpBB-SEO (and other mods) for a fair price and very fast. If you are interested simply send me a private message.
Stephen26
phpBB SEO Team
phpBB SEO Team
 
Posts: 434
Joined: Mon May 03, 2010 7:06 am

Re: Loss of attachment after the copy of the database

Postby yogi3 » Wed Apr 17, 2013 10:25 am

I never reuploaded anything, I checked backup on my localhost and I found some of them in orphan attachment but they are corrupted. Since last issue I make backup each day using auto backup and looks like that now all is working fine. So at them moment we can close this case.
yogi3
 
Posts: 26
Joined: Thu Oct 08, 2009 9:43 am

Re: Loss of attachment after the copy of the database

Postby malliktajmahal » Sat Oct 18, 2014 6:17 am

hi Yogi ... are you able to resolve the issue?
malliktajmahal
 
Posts: 5
Joined: Mon Jul 07, 2014 7:16 am

Re: Loss of attachment after the copy of the database

Postby yogi3 » Tue Oct 21, 2014 7:28 am

Since I wrote this topic everything working fine
yogi3
 
Posts: 26
Joined: Thu Oct 08, 2009 9:43 am


Return to phpBB Forum

 


  • Related topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 13 guests