Problem with PHPBB3 Adv Rewrite Mod and FAQ page

Discussions and support about the different URL Rewriting techniques for phpBB.

Moderator: Moderators

Problem with PHPBB3 Adv Rewrite Mod and FAQ page

Postby pvchat1 » Sun Jul 15, 2007 3:24 pm

I'm testing the SEO mods and there seems to be a problem with the relative links on the faq page not working anymore because of the added base href. Removing that will allow the faq page to work correctly but then all the relative links (style, etc) on the forum pages no longer work.

Thanks,
Jeff
pvchat1
 
Posts: 13
Joined: Sun Jul 15, 2007 3:08 pm
Location: California

Advertisement

Postby dcz » Thu Jul 19, 2007 9:22 am

Hum, interesting.

This bug will be fixed for the RC3.

Thanks for reporting.

++
Useful links :
SEO Forum || SEO Directory || SEO phpBB || Search
____________________

Liens Utiles :
Forum référencement || Annuaire référencement || Référencement phpBB || Recherche
dcz
Admin
Admin
 
Posts: 21382
Joined: Fri Apr 28, 2006 9:03 pm

Postby thedolphinboy » Fri Jul 27, 2007 4:22 pm

I have same problem, links inside faq.php doesnt work and jump to index again...
any quick fix until arrive RC3, please??? thanks...
thedolphinboy
 
Posts: 8
Joined: Tue Jul 24, 2007 6:35 pm

Postby pvchat1 » Fri Jul 27, 2007 9:21 pm

I fixed it for now by creating a template variable that gets set in faq.php and gets checked in overall_header.html to skip adding the href.

Basically like this

Code: Select all
<!-- IF not S_HIDE_HREFBASE --><base href="{PHPBB_FULL_URL}"><!-- ENDIF -->
pvchat1
 
Posts: 13
Joined: Sun Jul 15, 2007 3:08 pm
Location: California

Postby thedolphinboy » Fri Jul 27, 2007 10:38 pm

sorry about question, but where i must copy it, in faq.php or in overall_header.html???? and where in it??? can i put it where i wanna??
thanks anyway, sounds perfect ;)
thedolphinboy
 
Posts: 8
Joined: Tue Jul 24, 2007 6:35 pm

Postby pvchat1 » Fri Jul 27, 2007 10:51 pm

ok - here are the changes in context.

in overall_header.html
Code: Select all
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" dir="{S_CONTENT_DIRECTION}" lang="{S_USER_LANG}" xml:lang="{S_USER_LANG}">
<head>
<!-- IF not S_HIDE_HREFBASE --><base href="{PHPBB_FULL_URL}"><!-- ENDIF -->


and in faq.php (and any other non-forum content type page)
Code: Select all
// Lets build a page ...
$template->assign_vars(array(
        'S_HIDE_HREFBASE' => true,
   'L_FAQ_TITLE'   => $l_title,
   'L_BACK_TO_TOP'   => $user->lang['BACK_TO_TOP'])
);

pvchat1
 
Posts: 13
Joined: Sun Jul 15, 2007 3:08 pm
Location: California

Postby thedolphinboy » Fri Jul 27, 2007 10:59 pm

yeahhhhhhhhh it works PERFECT!!!!! thanks a lot, you are really a genius!!!! :lol:
thedolphinboy
 
Posts: 8
Joined: Tue Jul 24, 2007 6:35 pm

Postby dcz » Fri Aug 03, 2007 1:54 pm

This one went fixed in the RC3.

++
Useful links :
SEO Forum || SEO Directory || SEO phpBB || Search
____________________

Liens Utiles :
Forum référencement || Annuaire référencement || Référencement phpBB || Recherche
dcz
Admin
Admin
 
Posts: 21382
Joined: Fri Apr 28, 2006 9:03 pm

Postby pvchat1 » Mon Aug 06, 2007 12:16 am

Yes - tried this latest RC out and that problem along with a few others is now fixed. Good job.
pvchat1
 
Posts: 13
Joined: Sun Jul 15, 2007 3:08 pm
Location: California

Postby dcz » Sun Aug 12, 2007 8:46 am

The next version is currently being tested internally, will be 0.4.0RC1 with many new features ;)

++
Useful links :
SEO Forum || SEO Directory || SEO phpBB || Search
____________________

Liens Utiles :
Forum référencement || Annuaire référencement || Référencement phpBB || Recherche
dcz
Admin
Admin
 
Posts: 21382
Joined: Fri Apr 28, 2006 9:03 pm


Return to phpBB mod Rewrite

 


  • Related topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: VoilaBot [Bot] and 8 guests