My topic links show up as topic123.html..

Discussions and support about the different URL Rewriting techniques for phpBB.

Moderator: Moderators

My topic links show up as topic123.html..

Postby MitchLeBlanc » Wed Jun 10, 2009 9:00 am

I'd like them to show up with their titles, so instead of topic123.html, moocowpig.html

I am using the advanced seo mod, thanks!
MitchLeBlanc
 
Posts: 2
Joined: Wed Jun 10, 2009 8:59 am

Advertisement

Re: My topic links show up as topic123.html..

Postby SeO » Wed Jun 10, 2009 3:34 pm

Do you mean the Ultimate SEO URL mod in advanced mode ?
Make sure you did select the advanced mode, and not the simple or mixed in acp. If the url do not change, then you need to run the syn_url.php script again to update your stored urls.
SeO
Admin
Admin
 
Posts: 6334
Joined: Wed Mar 15, 2006 9:41 pm

Re: My topic links show up as topic123.html..

Postby MitchLeBlanc » Wed Jun 10, 2009 4:01 pm

Worked! Thanks!
MitchLeBlanc
 
Posts: 2
Joined: Wed Jun 10, 2009 8:59 am

Re: My topic links show up as topic123.html..

Postby anandharaj » Mon Jul 06, 2009 1:17 am

Hi,

Im using Advance mode, but my topics still shows as topic123.html.
I already re-generate and replace .htaccess file but still no luck. What else im missing?
anandharaj
 
Posts: 26
Joined: Sat Jul 04, 2009 2:42 pm

Re: My topic links show up as topic123.html..

Postby ACE8018 » Mon Jul 06, 2009 2:05 am

i as well just installed it today and getting same problem. how do i fix this?
ACE8018
 
Posts: 7
Joined: Mon Jul 06, 2009 2:00 am

Re: My topic links show up as topic123.html..

Postby anandharaj » Mon Jul 06, 2009 2:17 am

Ok, i manage to get it... Now sure whether its a bug or not. What i did, delete the .htaccess* files from phpbb_seo/cache folder and re-generate the .htaccess file from ACP - than put it in forum's root folder. After that, went to phpbb_seo/sync_url.php and reset first the url and then create/sync the URL.

Hope this help you as well.
anandharaj
 
Posts: 26
Joined: Sat Jul 04, 2009 2:42 pm

Re: My topic links show up as topic123.html..

Postby ACE8018 » Mon Jul 06, 2009 2:47 am

i just tried it... it didnt work? can u show me screenshots of ur settings in acp for the seomod?
ACE8018
 
Posts: 7
Joined: Mon Jul 06, 2009 2:00 am

Re: My topic links show up as topic123.html..

Postby anandharaj » Mon Jul 06, 2009 2:57 am

OK, below is my config that i took from the cache folder:

$this->cache_config['settings'] = array ( 'url_rewrite' => true, 'modrtype' => 3, 'sql_rewrite' => true, 'profile_inj' => true, 'profile_vfolder' => true, 'profile_noids' => true, 'rewrite_usermsg' => true, 'rewrite_files' => true, 'rem_sid' => true, 'rem_hilit' => true, 'rem_small_words' => true, 'virtual_folder' => true, 'virtual_root' => false, 'cache_layer' => true, 'rem_ids' => true, 'copyrights' => array ( 'img' => true, 'txt' => '', 'title' => '', ), 'no_dupe' => array ( 'on' => true, ), );
anandharaj
 
Posts: 26
Joined: Sat Jul 04, 2009 2:42 pm

Re: My topic links show up as topic123.html..

Postby Typo » Mon Jul 06, 2009 4:44 am

A lot of the options require a new .htaccess be generated if you change them. The options that require you to do this are labeled with a warning saying so but to be safe you can just always generate a new one whenever you change some settings.

Always clear your caches after making setting adjustments. To properly do this you need to have the "Clear GYM Sitemap Cache' set to ALL and 'Clear GYM Sitemap ACP' set to no, if you try and clear the ACP cache, it will not clear the normal cache at the same time, you have to do them seperately. It is also a good idea to clear phpbb's cache as well by purging it from the General tab in the ACP as an extra measure.

Good luck.

Typo
User avatar
Typo
phpBB SEO Team
phpBB SEO Team
 
Posts: 346
Joined: Sun Jan 18, 2009 11:33 am

Re: My topic links show up as topic123.html..

Postby ACE8018 » Tue Jul 07, 2009 3:11 am

its still not working for me.
ACE8018
 
Posts: 7
Joined: Mon Jul 06, 2009 2:00 am

Re: My topic links show up as topic123.html..

Postby dcz » Wed Jul 08, 2009 3:16 pm

@anandharaj you must have synchronized your topic urls before you actually selected the advanced mode, so you where in MitchLeBlanc's case.

@ACE8018 are you actually using the advanced mode ? Did you re sync your urls after you had cleared them all ?
Useful links :
SEO Forum || SEO Directory || SEO phpBB || Search
____________________

Liens Utiles :
Forum référencement || Annuaire référencement || Référencement phpBB || Recherche
dcz
Admin
Admin
 
Posts: 21325
Joined: Fri Apr 28, 2006 9:03 pm


Return to phpBB mod Rewrite

 


  • Related topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 14 guests