Problem with last topic link

Discussions and support about the different URL Rewriting techniques for phpBB.

Moderator: Moderators

Problem with last topic link

Postby ondrej » Thu Oct 22, 2009 2:29 pm

Hello!

I just installed Ultimate SEO URL 0.6.0 and Zero duplicate. All works really nice, I just have problems with the links from viewforum to the last topic. The link has a ..&p=XXXX#p=XXX at the end and leads to an 404 error. From the index page all is fine.

Demo: http://www.chemiestudent.de/forum/schwarzes-brett-f12

Can you give me a hint where the problem can be?

Thanks a lot!

Ondrej
ondrej
 
Posts: 2
Joined: Thu Oct 22, 2009 8:10 am

Advertisement

Re: Problem with last topic link

Postby dcz » Sat Oct 31, 2009 12:34 pm

This most likely means that you're not using phpBB3.0.5, because this version started to build post links as we needed to (eg passing them to append_sid instead of adding an extra p variable statically).
If so, have a look at the 0.4.8 to 0.6.0 update files of the ultimate SEO URL mod, you will have to add the U_NEWEST_POST and U_LAST_POST links modification in viewforum.php (as you can see in the update, we are just removing the phpBB SEO modification for these, since phpBB3.0.5 uses the exact same code as we need).

Of course, updating phpBB would be wise too at this point.

++
Useful links :
SEO Forum || SEO Directory || SEO phpBB || Search
____________________

Liens Utiles :
Forum référencement || Annuaire référencement || Référencement phpBB || Recherche
dcz
Admin
Admin
 
Posts: 21428
Joined: Fri Apr 28, 2006 9:03 pm

Re: Problem with last topic link

Postby ondrej » Mon Nov 02, 2009 9:36 am

Thanks a lot! This helped. Actually I am using 3.0.4 as you correctly observed.
ondrej
 
Posts: 2
Joined: Thu Oct 22, 2009 8:10 am


Return to phpBB mod Rewrite

 


  • Related topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 8 guests