Post url problem - www.domain.com/#p237

Discussions and support about the different URL Rewriting techniques for phpBB.

Moderator: Moderators

Post url problem - www.domain.com/#p237

Postby zvunks » Wed Jan 15, 2014 9:05 am

I tried to find this problem on forum but no succes. My problem is that post url in topics are like this: www.domain.com/#p237
After installed phpbb seo a resyncrinozied topic url, i purged the cache, i cleared browser cookie...
I have another forum and used phpbb seo, works great, never deal with this kind of trouble.

Thank you for any help! (excuse if this problem was already discussed)

(and my bad english)
zvunks
 
Posts: 20
Joined: Thu Oct 11, 2012 6:25 am

Advertisement

Re: Post url problem - www.domain.com/#p237

Postby zvunks » Wed Jan 15, 2014 9:40 am

I've looked into prosilve template (viewtopic_body.html) and there is:
<a href="{U_VIEW_TOPIC}#p{postrow.POST_ID}">{postrow.POST_SUBJECT}</a>

it seems that {U_VIEW_TOPIC} has no value from database...

LE: it's strange, because here:
<h2><a href="{U_VIEW_TOPIC}">{TOPIC_TITLE}</a></h2>

i got value and the correct URL...


Deleted template cache... no result


LE2: same problem to "Go Top" icons... It seems to me that str_replace doesn't replace all {U_VIEW_TOPIC} apearences...

Some ideas? THANK YOU!
zvunks
 
Posts: 20
Joined: Thu Oct 11, 2012 6:25 am

Re: Post url problem - www.domain.com/#p237

Postby zvunks » Wed Jan 15, 2014 10:23 am

There is something wrong with update...
If i did like this: "Upload all files from the root/ directory of the premod package to where your phpBB is installed, EXCEPT config.php and install/*.*" ... doesn't work

If i used all files from premoded package, it's ok.

But i had already have latest version oh phpbb3, so i don't know where is the difference.


LE: Maybe some files wasn't overwrited when unpacking zip... :oops:
zvunks
 
Posts: 20
Joined: Thu Oct 11, 2012 6:25 am

Re: Post url problem - www.domain.com/#p237

Postby zvunks » Wed Jan 15, 2014 1:15 pm

What i'm doing wrong?!
- i have an updated database (with data)
- using premoded phpbb3 (copy all files and folder)
- delete install folder and replace config.php, to connect to existing database
- login as admin, access ACP
- install phpbb seo
- setup phpbb seo (parameters)
- when i first submit changes to phpbb seo, i'm asked for topic sync. In database, topics table, topic_url field is set to "topic". It's ok
- Then i check, write and replace the .htaccess file. Change to permission 644
- Detele template cache...

My posts URL is like in the title. TOPIC URL MISSING! :evil:

I trided like 20 times... One time it worked but i don't know what a .... i'm doing wrong...

Anyone know what is the problem?!
zvunks
 
Posts: 20
Joined: Thu Oct 11, 2012 6:25 am

Re: Post url problem - www.domain.com/#p237

Postby HB » Wed Jan 15, 2014 6:07 pm

zvunks wrote:If i used all files from premoded package, it's ok.

Maybe you should try merging your mods with the premod rather than the opposite direction. WinMerge or Beyond Compare or pick-your-favorite source merge tool makes it a fairly easy job (albeit not a lot of fun).
Dan Kehn
HB
phpBB SEO Team
phpBB SEO Team
 
Posts: 1509
Joined: Mon Oct 16, 2006 2:25 am

Re: Post url problem - www.domain.com/#p237

Postby zvunks » Thu Jan 16, 2014 9:44 am

Thanks for your suggestion HB.
Finally i've changed forum theme and manually insert seo changes.
It's ok now.

I don't know why viewtopic_body.html had this line: <a href="{U_VIEW_TOPIC}#p{postrow.POST_ID}">{postrow.POST_SUBJECT}</a>, when i downloaded from theme folder, but when i wanted to edit in ACP interface, there was only: <a href="#p{postrow.POST_ID}">{postrow.POST_SUBJECT}</a>, so {U_VIEW_TOPIC} was mising.
That's because i tried several themes?
I don't know, i'm pretty sure that i had the right theme selected, and i know viewtopic_body was from prosilver2... and beside that, other links were ok.
zvunks
 
Posts: 20
Joined: Thu Oct 11, 2012 6:25 am


Return to phpBB mod Rewrite

 


  • Related topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 11 guests