How to fix this error?

Support for the phpBB3 SEO mods released in the phpBB3 SEO Toolikt forum.

Moderator: Moderators

How to fix this error?

Postby Albay » Sat Sep 22, 2007 1:42 am

First of all I apologize for my insufficent english.

I created phpseo3 premod forum and advanced seo mod... created categories forums etc...

after posting more than 25 topic in any forum, it creates secont page for older topics but secont page cannot be opened.

this is the first page of the forum
Code: Select all
http://forum.bedavasiteyapmak.com/tema-f16/


this one is the second which cause 404 not found error
Code: Select all
http://forum.bedavasiteyapmak.com/tema-f16/page25.html


i think it should not be end with .html but i do not know how to fix this error.
Albay
 
Posts: 2
Joined: Thu Sep 20, 2007 10:48 pm

Advertisement

Postby SeO » Sat Sep 22, 2007 1:23 pm

You most likely altered some settings after you generated your last .htaccess.

Try generating an new one and install it. Should work.

In case it does not, post it here.

With virtual folder you'll get forum-url-fxx/pageyy.html for pagination.
Without, you'll get forum-url-fxx-yy.html.
SeO
Admin
Admin
 
Posts: 6334
Joined: Wed Mar 15, 2006 9:41 pm

Postby Albay » Sat Sep 22, 2007 10:47 pm

Thanks for your reply... i tried some other commands. it doesnt give 404 not found error any more but

Image

I want to make underlined url for both links.. but I do not know how to do :( if it will take long time to fix, i will try to install a new one..

I used this htaccess file..
Code: Select all
# Lines That should already be in your .htacess
<Files "config.php">
Order Allow,Deny
Deny from All
</Files>
<Files "common.php">
Order Allow,Deny
Deny from All
</Files>

# You could need to un-comment the following line
# Options +FollowSymlinks
RewriteEngine On
# ALEXIS pasif yap dedi :P
RewriteBase /

#########################################################
# PHPBB SEO REWRITE RULES            #
#########################################################
# AUTHOR : dcz http://www.phpbb-seo.com/
# STARTED : 01/2006
#####################################################
# FORUMS PAGES
########################
# FORUM INDEX (un-comment if used)
# RewriteRule ^index\.html$ /index.php [QSA,L]
# FORUM
RewriteRule ^[a-z0-9_-]*-f([0-9]+)(-([0-9]+))?/?$ /viewforum.php?f=$1&start=$3 [QSA,L,NC]
# TOPIC
RewriteRule ^[a-z0-9_-]*-f([0-9]+)/[a-z0-9_-]*-t([0-9]+)(-([0-9]+))?\.html$ /viewtopic.php?f=$1&t=$2&start=$4 [QSA,L,NC]
# GLOBAL ANNOUNCES && TOPIC WITHOUT FORUM URLS
RewriteRule ^(annonces/)?[a-z0-9_-]*-t([0-9]+)(-([0-9]+))?\.html$ /viewtopic.php?t=$2&start=$4 [QSA,L,NC]
# POST
RewriteRule ^post([0-9]+)\.html$ /viewtopic.php?p=$1 [QSA,L]
#PROFILES
RewriteRule ^member([0-9]+)\.html$ /memberlist.php?mode=viewprofile&u=$1 [QSA,L]
# THE TEAM
RewriteRule ^the-team\.html$ /memberlist.php?mode=leaders [QSA,L,NC]

# FORUM WITHOUT ID & DELIM
# THESE FOUR LINES MUST BE LOCATED AT THE END OF YOUR HTACCESS TO WORK PROPERLY
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l
RewriteRule ^[a-z0-9_-]+/?(page([0-9]+)\.html)?$ viewforum.php?start=$2 [QSA,L,NC]
# END PHPBB PAGES
#####################################################
Albay
 
Posts: 2
Joined: Thu Sep 20, 2007 10:48 pm

Postby dcz » Mon Sep 24, 2007 11:39 am

Oh, this is a bug, the JS need to be updated to work with the new pagination standards.

About pagination standards, forum-url/pagexx.html really is better than forum-url-xx/ because you will put all the weight on the virtual folder instead of generating one per forum page.

This way, all the content from one forum will appear in the forum's virtual folder.

++
Useful links :
SEO Forum || SEO Directory || SEO phpBB || Search
____________________

Liens Utiles :
Forum référencement || Annuaire référencement || Référencement phpBB || Recherche
dcz
Admin
Admin
 
Posts: 21383
Joined: Fri Apr 28, 2006 9:03 pm

Postby MewsicLovr » Sat Nov 24, 2007 1:57 am

Bump. Is this a phpBB3 bug or an SEO bug? Can you post a fix?

Thanks!
MewsicLovr
 
Posts: 4
Joined: Tue Nov 20, 2007 2:44 am

Postby SeO » Sat Nov 24, 2007 2:22 am

It used to be a bug in the previous phpBB SEO mod rewrite versions, not phpBB3, latest ones does not have it anymore.
SeO
Admin
Admin
 
Posts: 6334
Joined: Wed Mar 15, 2006 9:41 pm

Postby MewsicLovr » Sat Nov 24, 2007 5:06 am

Alright, I discovered my problem was because I was using an extension of "/" for all pages (virtual folders for single pages). I put it back to .html and all is good.
MewsicLovr
 
Posts: 4
Joined: Tue Nov 20, 2007 2:44 am

Postby dcz » Sun Nov 25, 2007 2:11 pm

We'll add a better handling for the / suffix case without virtual folder in the next releases, but, it's not the most obvious to use slashes as suffix if you don't simulate directories IMHO.

++
Useful links :
SEO Forum || SEO Directory || SEO phpBB || Search
____________________

Liens Utiles :
Forum référencement || Annuaire référencement || Référencement phpBB || Recherche
dcz
Admin
Admin
 
Posts: 21383
Joined: Fri Apr 28, 2006 9:03 pm


Return to phpBB SEO MODS

 


  • Related topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 2 guests