Update to 3.0.4: Updating Database Error

phpBB SEO Premod for phpBB3 support forum.
This premodded version of phpBB3 includes the three different type of URL rewriting for phpBB3 by phpBB SEO. It comes with several other Search Engine Optimization mods installed.

Moderator: Moderators

Update to 3.0.4: Updating Database Error

Postby Spippolo » Sun Jan 18, 2009 1:10 am

Hi there,
sorry at begin for my bad English :oops:

I would like to update from 3.0.0 to 3.0.4 and I had download Auto update package 3.0.3 to 3.0.4.
I had begin the update but while the system was updating dabase this is the error:
Code: Select all
Aggiornamento dati

Avanzamento :: . . . . . . . . . . . . . . . . . . . .
Notice: Undefined index: id in /home/forumdia/public_html/install/database_update.php on line 1909

Notice: Undefined index: id in /home/forumdia/public_html/install/database_update.php on line 1910
. . . . . . . Fatto
Risultato :: Alcune query non sono riuscite. Le istruzioni e gli errori sono elencati qui sotto.

    * Errore :: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 3
      SQL :: SELECT * FROM phpbb_acl_groups WHERE auth_option_id =

    * Errore :: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 3
      SQL :: SELECT * FROM phpbb_acl_roles_data WHERE auth_option_id =

    * Errore :: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 3
      SQL :: SELECT * FROM phpbb_acl_users WHERE auth_option_id =


To start the updating I had must replace the file /include/functions.php with my old /include/function.php file not modded; otherwise I did can't start update.

Before updating "by hand" my 33 files with conflict I would like fix database's problem.
Can you help me?

Thank you very much,
Spippolo
Spippolo
 
Posts: 9
Joined: Sun Jan 18, 2009 12:45 am

Advertisement

Postby SeO » Mon Jan 19, 2009 1:08 pm

Well, you cannot update from 3.0.0 to 3.0.4 using the 3.0.3 to 3.0.4 update package.

The easiest in your case would probably be to massively merge, using winmerge, your 3.0.0 with the latest premod's files.
Once done, eg when your file are up to date, just run the install/database_update.php from the latest update package.
SeO
Admin
Admin
 
Posts: 6334
Joined: Wed Mar 15, 2006 9:41 pm

Postby Spippolo » Mon Jan 19, 2009 8:56 pm

Great! Thank you! Now I've update to 3.0.4 without problem ;)
Could you tell me how to activate Zero Duplicate? If I set "on" the zero duplicate from control panel it restore all default setting of Url Rewriting and the link of my pages come back normally!

Thank you very much,
Spippolo
 
Posts: 9
Joined: Sun Jan 18, 2009 12:45 am

Postby SeO » Wed Jan 21, 2009 8:15 am

Have you kept your old phpbb_seo/cache/ files ?

I'm not sure to get it exactly, do you mean that option are not kept in SEO acp ?
If so, it's likely to be a CHMOD issue on this dir and the files in it.
SeO
Admin
Admin
 
Posts: 6334
Joined: Wed Mar 15, 2006 9:41 pm

Postby Spippolo » Wed Jan 21, 2009 10:21 am

Yes, this is the problem.

phpbb_seo/cache/ CHMOD dir was set to 777 and inside I can see 3 files:
- phpbb_cache.php
- phpbb_cache.php.current
- phpbb_cache.php.old

What can I do?
Thank you very much,
Spippolo
Spippolo
 
Posts: 9
Joined: Sun Jan 18, 2009 12:45 am

Postby SeO » Wed Jan 21, 2009 1:35 pm

You may need to CHMOD the files themselves to 0777 (if you uploaded them for example), have you tried ?
SeO
Admin
Admin
 
Posts: 6334
Joined: Wed Mar 15, 2006 9:41 pm

Postby Spippolo » Wed Jan 21, 2009 9:30 pm

Oh, I think you misunderstood me; surely I don't explain you very well. I'm so sorry.

The problem isn't the "forgot" of SEO acp of option, but is the "forgot" of SEO acp option after upgrading.

I have upgrading PhpBB to the version 3.0.4 and was all right. I tried to activate the zero duplicate trough SEO acp and all link of forum was come back normally (like -www.example.com/forum-t77/ instead -www.example.com/forum-title-t77/ ); I thought the reason was the "forgot" of SEO acp of the old option. I don't remember it and I couldn't re-set again all my option... I could do a mistake and all linking of my forum couldn't work! :(

I don't know if I'm explain good, sorry please my bad english :roll:
Thank you again,
Spippolo
 
Posts: 9
Joined: Sun Jan 18, 2009 12:45 am

Postby Spippolo » Wed Jan 21, 2009 9:43 pm

However "php_cache.php" and "phpbb_cache.php.current" are set to 777. "phpbb_cache.php.old" is set to 644.
Thank you
Spippolo
 
Posts: 9
Joined: Sun Jan 18, 2009 12:45 am

Postby SeO » Fri Jan 23, 2009 2:17 pm

I'm not sure to get it fully, but make sure you kept the file you had in phpbb_seo/cache/ when you updated.

What's happening with your urls, have you lost the custom forum urls you had ?
SeO
Admin
Admin
 
Posts: 6334
Joined: Wed Mar 15, 2006 9:41 pm

Postby Spippolo » Fri Jan 23, 2009 2:31 pm

Exactly.
Then I did upload the old phpbb_seo cache file to restore the right custom forum link.

How could I to set "on" the Zero Duplicate? Could I set manually in the phpbb_seo cache file?
Spippolo
 
Posts: 9
Joined: Sun Jan 18, 2009 12:45 am

Postby Spippolo » Fri Jan 30, 2009 9:24 am

No idea? :cry:
Spippolo
 
Posts: 9
Joined: Sun Jan 18, 2009 12:45 am

Postby SeO » Sun Feb 01, 2009 9:04 am

So, let's make this simpler :
a) can you save any setting in the phpBB SEO acp ?
b) do you have any custom forum url configured in acp, can you actually see them ?
c) how does your urls looks like on your forum ?
SeO
Admin
Admin
 
Posts: 6334
Joined: Wed Mar 15, 2006 9:41 pm

Postby Spippolo » Mon Feb 02, 2009 9:34 am

Reply: :)
a) Yes I can, sure!
b) I have custom forum url configured, but I can't see them in ACP.
c) In my forum now the urls are: /forum-name-fXX/topic-name-tXXX.html
Thank you again!
Spippolo
 
Posts: 9
Joined: Sun Jan 18, 2009 12:45 am

Postby SeO » Mon Feb 02, 2009 11:27 am

So, b) means that you can't see anything in the forum url menu of the phpBB SEO ACP cat ?
Nothing or empty forum urls ?

Custom forum urls are stored in the same file as the config, so if you can save settings, you should be able to save custom url.
SeO
Admin
Admin
 
Posts: 6334
Joined: Wed Mar 15, 2006 9:41 pm

Postby Spippolo » Mon Feb 02, 2009 2:24 pm

Hi,
I resolved adding

'zero_dupe'=>array('on'=>true,)

into cache file /phpbb_seo/cache/phpbb_cache.php :)
Can it be enough?
Thank you,
Spippolo
 
Posts: 9
Joined: Sun Jan 18, 2009 12:45 am


Return to phpBB SEO Premod

 


  • Related topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 19 guests