Custom links href error

phpBB SEO Premod for phpBB3 support forum.
This premodded version of phpBB3 includes the three different type of URL rewriting for phpBB3 by phpBB SEO. It comes with several other Search Engine Optimization mods installed.

Moderator: Moderators

Custom links href error

Postby lund » Fri May 31, 2013 7:58 am

Hi all,

Thanks for providing this free upgraded phpBB forum.

Everything standard is working great but the custom links I place in my menus, isn't working quite as they should.
I'm using a custom style and everything displays correctly, except the custom links.

In my overall_header.html, my menu looks as this:
Code: Select all
         <ul id="navigation-top">
               <!-- IF S_BOARD_RULES --><li class="icon-rules"><a href="{U_BOARD_RULES}" title="{L_BOARD_RULES}">{L_RULES}</a></li><!-- ENDIF -->
                <!-- IF U_INFO_BOX_ALLOWED --><li class="info_box_icon"><a href="{U_INFO_BOXES}" title="{L_INFO_BOXES}">{L_INFO_BOXES}</a></li><!-- ENDIF -->
            <li><a href="{U_FAQ}" title="{L_FAQ_EXPLAIN}">{L_FAQ}</a></li>
            <!-- IF S_DISPLAY_SEARCH --><li><a href="{U_SEARCH}" title="{L_SEARCH_ADV_EXPLAIN}">{L_SEARCH}</a></li> <!-- ENDIF -->
            <!-- IF U_TEAM --><li><a href="{U_TEAM}" title="{L_THE_TEAM}">{L_THE_TEAM}</a></li> <!-- ENDIF -->
            <!-- IF not S_IS_BOT -->
               <!-- IF S_DISPLAY_MEMBERLIST --><li><a href="{U_MEMBERLIST}" title="{L_MEMBERLIST_EXPLAIN}">{L_MEMBERLIST}</a></li> <!-- ENDIF -->
                    <li><a href="{U_DOWNLOADS}" title="List all downloads">Downloads</a></li>
               <!-- IF not S_USER_LOGGED_IN and S_REGISTER_ENABLED --><li><a href="{U_REGISTER}" title="{L_REGISTER}">{L_REGISTER}</a></li><!-- ENDIF -->
               <li><a href="{U_LOGIN_LOGOUT}" title="{L_LOGIN_LOGOUT}" accesskey="l">{L_LOGIN_LOGOUT}</a></li>
            <!-- ENDIF -->
         </ul>

The "Rules" and "Downloads" links are the custom ones.

In my functions.php file, I set the vars as such:
Code: Select all
   $template->assign_vars(array(
      'S_BOARD_RULES'   => (isset($config['enable_board_rules']) && $config['enable_board_rules']) ? true : false,
      'U_BOARD_RULES'   => append_sid("{$phpbb_root_path}rules.$phpEx"),
      'U_DOWNLOADS'      => append_sid("{$phpbb_root_path}downloads.$phpEx")
   ));


When I navigate to a forum category, the custom links href is "/forum-name/rules.php" instead of "/rules.php" where the standard links works fine, like "/search.php", "/memberlist.php" and so on.
Any idea to why it does this?
Do I have to change more to make custom links work properly?

Forum link: http://dev.pixibin.net/forum/

Thanks in advance.

//lund
lund
 
Posts: 6
Joined: Fri May 31, 2013 7:43 am

Advertisement

Re: Custom links href error

Postby lund » Fri May 31, 2013 10:36 am

It was me who didn't do things correctly.
Problem has been solved.
lund
 
Posts: 6
Joined: Fri May 31, 2013 7:43 am


Return to phpBB SEO Premod

 


  • Related topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 24 guests