[SEO URL] Board3 portal

phpBB SEO mods by phpBB SEO.

Moderator: Moderators

Re: [SEO URL] Board3 portal

Postby Alorse » Sun Jul 17, 2011 11:53 pm

Anyone know how to make this change for version Board3 Portal 2.0.0?
Alorse
 
Posts: 10
Joined: Fri May 01, 2009 8:02 pm
Location: Colombia

Advertisement

Re: [SEO URL] Board3 portal

Postby superfigjam » Sat Jul 23, 2011 2:25 pm

I was looking for something like that as well.

thanks.
superfigjam
 
Posts: 2
Joined: Sat Jul 23, 2011 2:22 pm

Re: [SEO URL] Board3 portal

Postby Wizzy » Fri Jan 06, 2012 11:27 pm

Does the SEO mod for viewtopicxxx => topic-name for portal based on 2.0.0.1b works as well?
Wizzy
 
Posts: 6
Joined: Tue Dec 13, 2011 6:56 pm

Re: [SEO URL] Board3 portal

Postby esson » Fri Feb 24, 2012 3:49 am

my forum messed up with Board3 portal with SEO URL Ultimate w/ Zero Dup & No Dup :shock:
esson
 
Posts: 3
Joined: Sat Feb 04, 2012 9:20 am

Re: [SEO URL] Board3 portal

Postby metalmaster » Sat Mar 17, 2012 1:08 am

what are the changes to make to the version 2.0.0 of the board3 Portal?
User avatar
metalmaster
 
Posts: 5
Joined: Tue Feb 14, 2012 2:46 pm
Location: Torre del Greco

Re: [SEO URL] Board3 portal

Postby Alorse » Sat Mar 17, 2012 1:17 am

metalmaster wrote:what are the changes to make to the version 2.0.0 of the board3 Portal?
http://phpbb.alorse.net/viewtopic.php?f=13&t=95#p294
Alorse
 
Posts: 10
Joined: Fri May 01, 2009 8:02 pm
Location: Colombia

Re: [SEO URL] Board3 portal

Postby ceds » Thu Apr 19, 2012 9:14 am

hello
i ha a probleme with the forum index
when i put in .htaccess portal.php, impossible to access to forum index
when i delete portal.php in .htaccess, forum index is OK but defaut portail not show in direct site access
my forum is on root of the website, no /forum directory

Any idea ??

Thx
ceds
 
Posts: 26
Joined: Wed Jul 04, 2007 12:46 pm

Re: [SEO URL] Board3 portal

Postby techno-com » Mon May 14, 2012 12:31 pm

Hi.. i try to explain in "my" english, hope you understand !

I added all the changes.

But i become an failture "Fatal error: Call to a member function prepare_iurl() on a non-object in /www/htdocs/w00e1c1f/Forum/portal/modules/portal_recent.php on line 139" after adding.

Annother thing is that the file "recent.php" is told to find in portal/block. That directory is empty at my page, i found that one (same data in the file) on portal/modules/portal_recent.php !

More details:
----
Board3 Portal ist auf dem neuesten Stand => Installierte Version 2.0.0b1
----
phpBB SEO Class settings
Here you can set up various options of the phpBB SEO Ultimate SEO URL mod (Support Forum).
The various default settings such as the delimiters and suffixes still must be set up in phpbb_seo/includes/setup_phpbb_seo.php, since changing these implies an .htaccess update and most likely appropriate redirections.
Mode : Advanced - 0.7.0 ( Support Forum )
techno-com
 
Posts: 10
Joined: Tue Sep 21, 2010 3:04 pm
Location: 74076 Heilbronn/ Germany

Re: [SEO URL] Board3 portal

Postby metalmaster » Mon May 14, 2012 12:56 pm

Alorse wrote:
metalmaster wrote:what are the changes to make to the version 2.0.0 of the board3 Portal?
http://phpbb.alorse.net/viewtopic.php?f=13&t=95#p294


thank you! :wink:
I now believe that all is well (http://www.napolifans.it)
User avatar
metalmaster
 
Posts: 5
Joined: Tue Feb 14, 2012 2:46 pm
Location: Torre del Greco

Re: [SEO URL] Board3 portal

Postby techno-com » Tue May 15, 2012 1:23 pm

Yesterday i updated to "Board3-Portal Version 2.0.0" (thats no longer "Beta")... now even in the files there are no longer the Data-Inputs that are descriped to change.

Mod needs an Update for Version 2.0.0 of Board3-Portal. :idea:
techno-com
 
Posts: 10
Joined: Tue Sep 21, 2010 3:04 pm
Location: 74076 Heilbronn/ Germany

Re: [SEO URL] Board3 portal

Postby eoinzy » Fri Jun 01, 2012 2:03 am

I also looking for help with getting this to work on board3 portal v2.0.0

Thanks.
eoinzy
 
Posts: 28
Joined: Thu Jan 22, 2009 2:07 am
Location: Perth, Australia

Re: [SEO URL] Board3 portal

Postby techno-com » Wed Jun 06, 2012 4:45 am

Did anybody find something about that else in the net ? Like we see here isnt´t much wishes about a soultion for it....
techno-com
 
Posts: 10
Joined: Tue Sep 21, 2010 3:04 pm
Location: 74076 Heilbronn/ Germany

Re: [SEO URL] Board3 portal

Postby eoinzy » Wed Jun 06, 2012 1:44 pm

Ye its a pity that there is no feedback.

It would be cool if someone could learn how phpbbseo works and come up with a solution. I'm a beginner java developer with very little PHP experience, but if I get time I might try have a look and see how the code works. I'd guess its just a matter of replacing a few variables.
eoinzy
 
Posts: 28
Joined: Thu Jan 22, 2009 2:07 am
Location: Perth, Australia

Re: [SEO URL] Board3 portal

Postby techno-com » Wed Jun 06, 2012 4:28 pm

OK, i try to "help"... just integrated "Related Topics" MOD, this works with SEO rewrite.

My example is taken from my site: http://www.techno-com.de/Forum/2-receiv ... t7579.html

The Code for this SEO-working Tool is:
Code: Select all
<!-- BEGIN related -->
   <li class="row bg1<!-- IF related.S_POST_ANNOUNCE --> announce<!-- ENDIF --><!-- IF related.S_POST_STICKY --> sticky<!-- ENDIF --><!-- IF related.S_TOPIC_REPORTED --> reported<!-- ENDIF -->">
      <dl class="icon" style="background-image: url({related.TOPIC_FOLDER_IMG_SRC}); background-repeat: no-repeat;">
         <dt <!-- IF related.TOPIC_ICON_IMG and S_TOPIC_ICONS --> style="background-image: url({T_ICONS_PATH}{related.TOPIC_ICON_IMG}); background-repeat: no-repeat;"<!-- ENDIF -->><!-- IF related.S_UNREAD_TOPIC --><a href="{related.U_NEWEST_POST}">{NEWEST_POST_IMG}</a> <!-- ENDIF --><a class="topictitle" href="{related.U_TOPIC}" title="{related.TOPIC_TITLE} : {related.FORUM}">{related.TOPIC_TITLE}</a>
         <!-- IF related.S_TOPIC_UNAPPROVED --><a href="{related.U_MCP_QUEUE}">{UNAPPROVED_IMG}</a> <!-- ENDIF -->
         <!-- IF related.S_TOPIC_REPORTED --><a href="{related.U_MCP_REPORT}">{REPORTED_IMG}</a><!-- ENDIF --><br />
         <!-- IF related.PAGINATION --><strong class="pagination"><span>{related.PAGINATION}</span></strong><!-- ENDIF -->
         <!-- IF related.ATTACH_ICON_IMG -->{related.ATTACH_ICON_IMG} <!-- ENDIF -->{L_POST_BY_AUTHOR} {related.TOPIC_AUTHOR_FULL} &raquo; {related.FIRST_POST_TIME}
         </dt>
         <dd class="posts">{related.REPLIES} <dfn>{L_REPLIES}</dfn></dd>
         <dd class="views">{related.VIEWS} <dfn>{L_VIEWS}</dfn></dd>
         <dd class="lastpost"><span><dfn>{L_LAST_POST} </dfn>{L_POST_BY_AUTHOR} {related.LAST_POST_AUTHOR_FULL}
         <a href="{related.U_LAST_POST}">{LAST_POST_IMG}</a> &raquo; {related.LAST_POST_TIME}
            <!-- IF related.U_FORUM and not related.S_POST_GLOBAL --><br /><a class="topictitle" href="{related.U_FORUM}" title="{related.FORUM}">{related.FORUM}</a><!-- ENDIF --></span></dd>
      </dl>
   </li>
   <!-- END related -->


The output in Source-Code from the site told above looks like:
Code: Select all
<ul class="topiclist forums">
   
   <li class="row bg1">
      <dl class="icon" style="background-image: url(http://www.techno-com.de/Forum/styles/prosilver/imageset/topic_read.gif); background-repeat: no-repeat;">
         <dt ><a class="topictitle" href="http://www.techno-com.de/Forum/anschluss-unicable-lnb-an-lemon-042-ci-t3337.html" title="Anschluss Unicable-LNB an Lemon 042 CI : Unicable- / Einkabel- LNB´s">Anschluss Unicable-LNB an Lemon 042 CI</a>
         <br />
         von <a href="http://www.techno-com.de/Forum/member/Laubaer/">Laubaer</a> &raquo; 27. Oktober 2006 16:25
         </dt>
         <dd class="posts">6 <dfn>Antworten</dfn></dd>
         <dd class="views">1844 <dfn>Zugriffe</dfn></dd>
         <dd class="lastpost"><span><dfn>Letzter Beitrag </dfn>von <a href="http://www.techno-com.de/Forum/member/techno-com/" style="color: #FF0000;" class="username-coloured">techno-com</a>
         <a href="http://www.techno-com.de/Forum/post10426.html#p10426"><img src="http://www.techno-com.de/Forum/styles/prosilver/imageset/icon_topic_latest.gif" width="11" height="9" alt="Neuester Beitrag" title="Neuester Beitrag" /></a> &raquo; 18. Dezember 2009 13:27
            <br /><a class="topictitle" href="http://www.techno-com.de/Forum/unicable-einkabel-lnb-s.html" title="Unicable- / Einkabel- LNB´s">Unicable- / Einkabel- LNB´s</a></span></dd>
      </dl>
   </li>
   
   <li class="row bg1">
      <dl class="icon" style="background-image: url(http://www.techno-com.de/Forum/styles/prosilver/imageset/topic_read.gif); background-repeat: no-repeat;">
         <dt ><a class="topictitle" href="http://www.techno-com.de/Forum/anschlusz-unicable-lnb-an-inverto-idl-7000m-pvr-t3292.html" title="Anschluß Unicable LNB an Inverto IDL-7000m PVR : Unicable- / Einkabel- LNB´s">Anschluß Unicable LNB an Inverto IDL-7000m PVR</a>
         <br />
         von <a href="http://www.techno-com.de/Forum/member/pewi641/">pewi641</a> &raquo; 30. September 2006 21:40
         </dt>
         <dd class="posts">1 <dfn>Antworten</dfn></dd>
         <dd class="views">805 <dfn>Zugriffe</dfn></dd>
         <dd class="lastpost"><span><dfn>Letzter Beitrag </dfn>von <a href="http://www.techno-com.de/Forum/member/joeben/">joeben</a>
         <a href="http://www.techno-com.de/Forum/post4353.html#p4353"><img src="http://www.techno-com.de/Forum/styles/prosilver/imageset/icon_topic_latest.gif" width="11" height="9" alt="Neuester Beitrag" title="Neuester Beitrag" /></a> &raquo; 1. Oktober 2006 09:01
            <br /><a class="topictitle" href="http://www.techno-com.de/Forum/unicable-einkabel-lnb-s.html" title="Unicable- / Einkabel- LNB´s">Unicable- / Einkabel- LNB´s</a></span></dd>
      </dl>
   </li>
   
   <li class="row bg1">
      <dl class="icon" style="background-image: url(http://www.techno-com.de/Forum/styles/prosilver/imageset/topic_read.gif); background-repeat: no-repeat;">
         <dt ><a class="topictitle" href="http://www.techno-com.de/Forum/nach-anschlusz-von-receiver-kein-bild-oder-nur-5-programme-t4962.html" title="Nach Anschluß von Receiver kein Bild oder nur 5 Programme : Fragen zu digitalen SAT- Einkabelsystemen">Nach Anschluß von Receiver kein Bild oder nur 5 Programme</a>
         <br />
         von <a href="http://www.techno-com.de/Forum/member/bodenseeandy/">bodenseeandy</a> &raquo; 14. November 2008 12:35
         </dt>
         <dd class="posts">1 <dfn>Antworten</dfn></dd>
         <dd class="views">730 <dfn>Zugriffe</dfn></dd>
         <dd class="lastpost"><span><dfn>Letzter Beitrag </dfn>von <a href="http://www.techno-com.de/Forum/member/techno-com/" style="color: #FF0000;" class="username-coloured">techno-com</a>
         <a href="http://www.techno-com.de/Forum/post7762.html#p7762"><img src="http://www.techno-com.de/Forum/styles/prosilver/imageset/icon_topic_latest.gif" width="11" height="9" alt="Neuester Beitrag" title="Neuester Beitrag" /></a> &raquo; 17. November 2008 09:15
            <br /><a class="topictitle" href="http://www.techno-com.de/Forum/fragen-zu-digitalen-sat-einkabelsystemen.html" title="Fragen zu digitalen SAT- Einkabelsystemen">Fragen zu digitalen SAT- Einkabelsystemen</a></span></dd>
      </dl>
   </li>


Output is rewritten then !

MAYBE thats a help for you ?! I don´t know much about that stuff, but think thats a bit for a first look :?:


Can you please tell me about you Email-Notification Email, is that rewritten at you site ? At my site it comes via email not rewritten, such as -http://www.site.com/postxxxxx- !
Same problem when i answer to a question , save the answer and go back to the topic.... then the url ist unrewritten too, same with txxxx/postxxx...
techno-com
 
Posts: 10
Joined: Tue Sep 21, 2010 3:04 pm
Location: 74076 Heilbronn/ Germany

Re: [SEO URL] Board3 portal

Postby eoinzy » Thu Jun 07, 2012 10:01 pm

I think the problem is that the $phpbb_seo global object isn't declared until AFTER the recent block has been generated.

There's a line of code that checks to see if the "seo_url['forum'][$row['forum_id']]" value is empty or not. Since its not declared yet, it will always be empty.

Code: Select all
if (!empty($row['topic_url']) || $row['topic_type'] == POST_GLOBAL || !empty($phpbb_seo->seo_url['forum'][$row['forum_id']])) {


So, the simple solution is just to declare this global variable in the first block that you are using, in my case, the recent block. (NOTE: You will have to also follow the instrctions from POST 1).


Open :
Code: Select all
portal/modules/portal_recent.php

Find :
Code: Select all
   public function get_template_center($module_id)
   {
      global $config, $template, $db, $auth, $phpbb_root_path, $phpEx;

After add :
Code: Select all
   // www.phpBB-SEO.com SEO TOOLKIT BEGIN
   global $phpbb_seo;
   // www.phpBB-SEO.com SEO TOOLKIT END


Like I said, once you add this, follow the instructions from page 1 and it MIGHT work for you.

It initially looks like it is currently working for my site: board3 portal with phpbb seo example

I will have to test every web page now to see if it causes any other problems, for example, with re-declaring the $phpbbseo global variable, since it might overwrite some values that it retrieved from earlier.
eoinzy
 
Posts: 28
Joined: Thu Jan 22, 2009 2:07 am
Location: Perth, Australia

PreviousNext

Return to phpBB SEO TooLKit

 


  • Related topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: ADmantX [Bot], Google Adsense [Bot] and 5 guests