Going back to first page after posting

phpBB2 SEO Advanced mod Rewrite support forum.
This mods performs URL rewriting for phpBB, injecting categories, forums and topic titles in their URLs.

Moderator: Moderators

Going back to first page after posting

Postby JanMarques » Thu May 01, 2008 1:54 pm

Hi there,
I've installed the Advanced phpBB SEO installed. Only 1 problem:
when posting a reply to a topic with already more then 1 page, you will be redirected to the first page, instead of the last page (where you just posted).

Does anyone know how to solve?
JanMarques
 
Posts: 6
Joined: Sun Jul 29, 2007 9:55 am

Advertisement

Postby HB » Thu May 01, 2008 4:07 pm

Dan Kehn
HB
phpBB SEO Team
phpBB SEO Team
 
Posts: 1515
Joined: Mon Oct 16, 2006 2:25 am

Postby JanMarques » Thu May 01, 2008 4:14 pm

No, it's about phpBB2
JanMarques
 
Posts: 6
Joined: Sun Jul 29, 2007 9:55 am

Postby JanMarques » Fri May 02, 2008 5:43 pm

Can someone help me/give me a tip please
JanMarques
 
Posts: 6
Joined: Sun Jul 29, 2007 9:55 am

Postby dcz » Tue May 06, 2008 11:42 am

mm, this should not happen, unless you're using IE which does not always keep the html anchors in redirections.

Could you post here both the url of the click here to see your post link and the ending one (the one you see once you actually see the page) ?

++
Useful links :
SEO Forum || SEO Directory || SEO phpBB || Search
____________________

Liens Utiles :
Forum référencement || Annuaire référencement || Référencement phpBB || Recherche
dcz
Admin
Admin
 
Posts: 21406
Joined: Fri Apr 28, 2006 9:03 pm

Postby JanMarques » Tue May 06, 2008 1:00 pm

You are redirected to http://[[n/a]]/post58.html#58 instead of showing http://[[n/a]]/stijlen-t22-15.html

The same problem with single posts, goes back to first page.
Last edited by JanMarques on Tue May 06, 2008 2:37 pm, edited 1 time in total.
JanMarques
 
Posts: 6
Joined: Sun Jul 29, 2007 9:55 am

Postby dcz » Tue May 06, 2008 1:36 pm

Ho I see, actually the 58th post is in page's two, but, the page is not loaded, what's broken here is not the return link but rather the post link themselves.

Double check your code changes in viewtopic.php, you may did something wrong upon install, because the mod of course does not break post links.

++
Useful links :
SEO Forum || SEO Directory || SEO phpBB || Search
____________________

Liens Utiles :
Forum référencement || Annuaire référencement || Référencement phpBB || Recherche
dcz
Admin
Admin
 
Posts: 21406
Joined: Fri Apr 28, 2006 9:03 pm

Postby JanMarques » Tue May 06, 2008 2:37 pm

Hmm, you were right.
I did double check it and that didn't solve it, but afterwoods I started again from a Vanilla viewtopic and it works!

Thanks!
JanMarques
 
Posts: 6
Joined: Sun Jul 29, 2007 9:55 am


Return to phpBB2 Advanced mod Rewrite

 


  • Related topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 1 guest