GYM Sitemaps and able2know mod

The GYM Sitemaps and RSS module and it's plug-ins.
Google Yahoo MSN Sitemaps (United 0.9).
RSS 2.0 Feeds and Yahoo! urllist.txt.

Moderator: Moderators

GYM Sitemaps and able2know mod

Postby ronyeli » Tue Feb 27, 2007 3:46 pm

Dear forum members,
I have installed this mod and it looks very good,
The problem I'm havening is the migration with the able3know mod that i have installed.

1. when i activate "URL rewriting type" on the cp to "on", i see the URL in the sitemaps forums like that:
/topic1216.html
instead of that:
about1216.html
(i have replaced the file "sitemap_forum.php" with the one you included in the contrib folder for able2know.

2. when i activate "URL Rewriting" to yes, it is giving me inside sitemaps.xml this strange url's: "/forum-gf1.xml"
when i go to this url I'm getting a forum message "The forum you selected does not exist."

I will appreciate any help with this issues greatly...
Thanks!
ronyeli
 
Posts: 18
Joined: Tue Feb 27, 2007 3:11 pm

Advertisement

Postby dcz » Tue Feb 27, 2007 4:22 pm

And welcome :D

Actually, it seems you confused a bit between the older and the up to date version of the sitemap module.

sitemap_forum.php is used by the mx Google sitemaps module 1.0.x and the forum-gf1.xml uri is used by the GYM sitemaps (aka mx Google sitemaps), eg 1.2.0RC.

So make sure you deleted all the mx Google sitemaps files before you start using the update.

Then, thing are different with the new method, you can of course migrate for many reasons, but if you prefer, you can keep the able2know mod as is, you'll stay with the duplicate that's all ;)

To have the mod output the correct url, you just need to open :
Code: Select all
mx_ggsitemaps/includes/ggs_functions.php


Find :

Code: Select all
         $this->seo_url = array( 'cat' => 'cat',
            'forum' => 'forum',
            'topic' => 'topic',
            'user' => 'member'
         );


Replace with :

Code: Select all
         $this->seo_url = array( 'cat' => 'cat',
            'forum' => 'forum-',
            'topic' => 'about',
            'user' => 'member'
         );


Go acp, set mod rewrite on and mod rewrite type to simple, you should be done.

You'll have to clear cache before you see any change and implement the module's rewriterules if you want to use the rewritten sitemaps and rss links.

++
Useful links :
SEO Forum || SEO Directory || SEO phpBB || Search
____________________

Liens Utiles :
Forum référencement || Annuaire référencement || Référencement phpBB || Recherche
dcz
Admin
Admin
 
Posts: 21428
Joined: Fri Apr 28, 2006 9:03 pm

Postby ronyeli » Tue Feb 27, 2007 5:00 pm

Thank you dcz
unfortunately it didn't work for me...i even tried to install and replace the able2know with your mod_rewrite but it didn't work (i have a different index.php code and couldn't find the code to be replaced)

you can see it here: http://www.xxx.com/sitemaps.xml

http://www.xxx.com/sitemap.php?forum=1

it is still using "topicxxx.html

I was wondering if maybe you can install it for me....i am willing to pay you if you want.
Last edited by ronyeli on Thu Mar 13, 2014 11:26 am, edited 1 time in total.
ronyeli
 
Posts: 18
Joined: Tue Feb 27, 2007 3:11 pm

Postby dcz » Tue Feb 27, 2007 5:17 pm

oups, forgot this part, you need as well to change :
Code: Select all
         $this->seo_static = array('cat' => 'cat',
            'forum' => 'forum',
            'topic' => 'topic',


with:

Code: Select all
         $this->seo_static = array('cat' => 'cat',
            'forum' => 'forum-',
            'topic' => 'about',


as well ;)

++
Useful links :
SEO Forum || SEO Directory || SEO phpBB || Search
____________________

Liens Utiles :
Forum référencement || Annuaire référencement || Référencement phpBB || Recherche
dcz
Admin
Admin
 
Posts: 21428
Joined: Fri Apr 28, 2006 9:03 pm

Postby ronyeli » Tue Feb 27, 2007 6:29 pm

Thank you, it worked! , i really appreciate your help :D

I stil have this problem tho:

Code: Select all
when i activate "URL Rewriting" to yes, it is giving me inside sitemaps.xml this strange url's: "/forum-gf1.xml"
when i go to this url I'm getting a forum message "The forum you selected does not exist."


Do you know what is causing this? when i submitted the sitemap to google it also see this "/forum-gf1.xml" as an error....

Thanks
ronyeli
 
Posts: 18
Joined: Tue Feb 27, 2007 3:11 pm

Postby dcz » Tue Feb 27, 2007 6:35 pm

This is probably because of the able2know rewriterules, even if one matches, all of them are tried.

So there could be confusion with a forum url.

Try put the GYM rewriterule before the able2know ones, should do it.

++
Useful links :
SEO Forum || SEO Directory || SEO phpBB || Search
____________________

Liens Utiles :
Forum référencement || Annuaire référencement || Référencement phpBB || Recherche
dcz
Admin
Admin
 
Posts: 21428
Joined: Fri Apr 28, 2006 9:03 pm

Postby ronyeli » Tue Feb 27, 2007 6:54 pm

awesome!!!

that did it...thanks!
ronyeli
 
Posts: 18
Joined: Tue Feb 27, 2007 3:11 pm


Return to GYM Sitemaps phpBB2

 


  • Related topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 2 guests