[Archive][SEO URL] Topics Anywhere

Support for the phpBB2 SEO mods released in the phpBB2 SEO Toolikt forum.

Moderator: Moderators

[Archive][SEO URL] Topics Anywhere

Postby dcz » Mon Jul 31, 2006 11:31 pm

WARNING
    0.0.2 is out : To update please read this thread.

    What follows is kept for archive.

    0.0.1 support will continue for some time for 0.0.1 user, until they update.

    Do not use this version if you are first installing this mod.

---------------------------------------------------------------------------------------

[SEO URL] Topic Anywhere


We've all been once teased by Topic Anywhere because it makes it simple to output last active topic listings and RSS Feeds.

But this mod is still quite limited.

First, links to output last active topic listing are build up using JavaScript, and thus won't be seen by Search engine Bots, they'll only see :

Code: Select all
<script language="JavaScript" type="text/javascript" src= "http://www.example.com/topics_anywhere.php?mode=show&f=a&n=10&sfn=y&fnl=y&r=y&sr=y&b=non&lpb=0&lpd=0&lpi=y"> </script>


Second, if the RSS Feeds are all right to be spidered, their URLs are not very bot friendly :

Code: Select all
http://www.example.com/topics_anywhere.php?mode=show&out=rss2.0&f=a&n=10&sfn=y&r=y&sr=y&b=non&lpb=0&lpd=0



And last but not least, it's a lot easier for you to paste few JavaScript lines of code in a page than for the server to constantly output last active topic listing.

Advise : do not use the "Jump to last post" option, this would output posts links, and it's the topic ones we want to optimize.

As well, not outputting the last message image link will save some resources while preventing another post link output ;)

Those limitation being stated, it's till an handy mod, so here :

Download :

Installation is very easy, updating even more, you'll just have to upload / overwrite files.

The corresponding phpBB SEO mod Rewrite is required.

Package contains French and English language pack.

French-Speacking Support
Last edited by dcz on Mon Apr 16, 2007 5:01 pm, edited 2 times in total.
Useful links :
SEO Forum || SEO Directory || SEO phpBB || Search
____________________

Liens Utiles :
Forum référencement || Annuaire référencement || Référencement phpBB || Recherche
dcz
Admin
Admin
 
Posts: 21428
Joined: Fri Apr 28, 2006 9:03 pm

Advertisement

Postby Silverado05 » Tue Aug 01, 2006 4:00 am

dcz wrote:Well, you need to fully install one of the phpBB SEO mod rewrite before those links will work.
++


I do have it installed, unless I am just not understanding your question.

I have created a guest account so you can see the index.

Username: Guest
Password: 123456


My pages are still getting index with the login mod. I had taken it off but my registration dropped to 0. When I put it back on, it jumped my registeration triple.
Silverado05
PR0
PR0
 
Posts: 51
Joined: Sat Jul 01, 2006 8:38 pm
Location: Texas

Postby dcz » Tue Aug 01, 2006 9:41 am

Ok, so it seems you did not install the mod completely .htaccess wise (as postxx.html is not working yet) and that there is something strange as your topic and post urls are not rewritten yet.

So I guess we'd first need to end up installing this one using it's support thread ;)

Then, you'll need to turn mod rewrite on in mx Sitemaps, but one thing at a time ;)

++
Useful links :
SEO Forum || SEO Directory || SEO phpBB || Search
____________________

Liens Utiles :
Forum référencement || Annuaire référencement || Référencement phpBB || Recherche
dcz
Admin
Admin
 
Posts: 21428
Joined: Fri Apr 28, 2006 9:03 pm

Postby AmirAbbas » Tue Aug 01, 2006 10:18 am

excuse me

what about advance rewrite mod UTF-8 version

adding format_url() to topic any where advance is enough :roll:
User avatar
AmirAbbas
phpBB SEO Team
phpBB SEO Team
 
Posts: 534
Joined: Thu May 11, 2006 3:30 pm
Location: IRAN

Postby dcz » Tue Aug 01, 2006 10:45 am

amir abbas wrote:excuse me

what about advance rewrite mod UTF-8 version

adding format_url() to topic any where advance is enough :roll:


Yes, just as per the mx sitemaps module, just add the format_url function to the $seo_ ... vars.

;)
Useful links :
SEO Forum || SEO Directory || SEO phpBB || Search
____________________

Liens Utiles :
Forum référencement || Annuaire référencement || Référencement phpBB || Recherche
dcz
Admin
Admin
 
Posts: 21428
Joined: Fri Apr 28, 2006 9:03 pm

Postby AmirAbbas » Tue Aug 01, 2006 11:48 am

i searched
i found three line

first one

$seo_topic = $seo_forum = array();

when i add format_url to this one it cause probem

and i two other line

$seo_topic[$i] = format_url($data[$i]['topic_title']);
$seo_forum[$i] = format_url($data[$i]['forum_name']);

as you can see both of them have format_url in default form
it works without probem and persian word filtered but if a topic doesn't have english word the shape of link are like this

-http://localhost/testpersia/empty-vt8.html

we must have word topic or forum instead of empty
this problem is similar to google site map problem that you fixed that
User avatar
AmirAbbas
phpBB SEO Team
phpBB SEO Team
 
Posts: 534
Joined: Thu May 11, 2006 3:30 pm
Location: IRAN

Postby dcz » Tue Aug 01, 2006 1:03 pm

lol I should read my coding's more cautiously some times :D

So the problem you have is linked to the UTF-8 dev version. I am thinking those should be filtered in append_sid instead in order not to have to mod every mod the way we did with mx Google sitemaps.

Let's go back to the utf-8 thread to solve this, as I am thinking we won't need to change anything with this mod after the patch I am thinking of.

++
Useful links :
SEO Forum || SEO Directory || SEO phpBB || Search
____________________

Liens Utiles :
Forum référencement || Annuaire référencement || Référencement phpBB || Recherche
dcz
Admin
Admin
 
Posts: 21428
Joined: Fri Apr 28, 2006 9:03 pm

Postby Silverado05 » Tue Aug 01, 2006 9:53 pm

dcz wrote:Ok, so it seems you did not install the mod completely .htaccess wise (as postxx.html is not working yet) and that there is something strange as your topic and post urls are not rewritten yet.

So I guess we'd first need to end up installing this one using it's support thread ;)

Then, you'll need to turn mod rewrite on in mx Sitemaps, but one thing at a time ;)

++



I am using a different SEO URL code that came with my phpBB installation. I am using phpbb2 plus. Not the regular phpBB. Now while the code from the simple mod rewrite install without a problem. I am getting 404 when I click on any catagory.

here is my .htaccess

Code: Select all
Options +FollowSymlinks
RewriteEngine On
RewriteBase /

#########################################################
# PHPBB SEO REWRITE RULES            #
#########################################################
# AUTHOR : DCZ http://www.phpbb-seo.com/
# STARTED : 01/2006
#####################################################
# FORUMS PAGES
########################
# CATEGORIES
RewriteRule ^forum/cat([0-9]+)\.html$ /forum/index.php?c=$1 [QSA,L]
# PAGINATED FORUM
RewriteRule ^forum/forum([0-9]+)-([0-9]+)\.html$ /forum/viewforum.php?f=$1&start=$2 [QSA,L]
# FORUM
RewriteRule ^forum/forum([0-9]+)\.html$ /forum/viewforum.php?f=$1 [QSA,L]
# PAGINATED TOPIC
RewriteRule ^forum/topic([0-9]+)-([0-9]+)\.html$ /forum/viewtopic.php?t=$1&start=$2 [QSA,L]
# TOPIC
RewriteRule ^forum/topic([0-9]+)\.html$ /forum/viewtopic.php?t=$1 [QSA,L]
# POST
RewriteRule ^forum/post([0-9]+)\.html$ /forum/viewtopic.php?p=$1 [QSA,L]
#PROFILES
RewriteRule ^forum/member([0-9]+)\.html$ /forum/profile.php?mode=viewprofile&u=$1 [QSA,L]
# END PHPBB PAGES
#####################################################


RewriteRule ^sitemaps([0-9]+)\.html$ /sitemaps.php?c=$1 [QSA,L]
RewriteRule ^sitemaps\.html$ /sitemaps.php [QSA,L]
RewriteRule ^forum-m\ap\.html$ /sitemaps.php?fim [QSA,L]
RewriteRule ^forum-m\ap-([0-9]+)-([0-9]+)\.html$ /sitemaps.php?fmp=$1&start=$2 [QSA,L]
RewriteRule ^forum-m\ap-([0-9]+)\.html$ /sitemaps.php?fmp=$1 [QSA,L]

# rewrite for blog mod

Options +FollowSymLinks
RewriteEngine on
RewriteRule blog/(.*)$ /forum/weblog.php?u=$1
RewriteRule blog/(.*)/$ /forum/weblog.php?u=$1
Silverado05
PR0
PR0
 
Posts: 51
Joined: Sat Jul 01, 2006 8:38 pm
Location: Texas

Postby dcz » Tue Aug 01, 2006 10:04 pm

First you don't need to start twice the rewrite engine. As well, the mx sitemaps rules need the full path for this .htaccess located on level above in the root folder. And there should not be any rewriterules in the forum/ folder any more.

So your .htaccess should look like :

Code: Select all
Options +FollowSymlinks
RewriteEngine On
RewriteBase /

#########################################################
# PHPBB SEO REWRITE RULES            #
#########################################################
# AUTHOR : DCZ http://www.phpbb-seo.com/
# STARTED : 01/2006
#####################################################
# FORUMS PAGES
########################
# CATEGORIES
RewriteRule ^forum/cat([0-9]+)\.html$ /forum/index.php?c=$1 [QSA,L]
# PAGINATED FORUM
RewriteRule ^forum/forum([0-9]+)-([0-9]+)\.html$ /forum/viewforum.php?f=$1&start=$2 [QSA,L]
# FORUM
RewriteRule ^forum/forum([0-9]+)\.html$ /forum/viewforum.php?f=$1 [QSA,L]
# PAGINATED TOPIC
RewriteRule ^forum/topic([0-9]+)-([0-9]+)\.html$ /forum/viewtopic.php?t=$1&start=$2 [QSA,L]
# TOPIC
RewriteRule ^forum/topic([0-9]+)\.html$ /forum/viewtopic.php?t=$1 [QSA,L]
# POST
RewriteRule ^forum/post([0-9]+)\.html$ /forum/viewtopic.php?p=$1 [QSA,L]
#PROFILES
RewriteRule ^forum/member([0-9]+)\.html$ /forum/profile.php?mode=viewprofile&u=$1 [QSA,L]
# END PHPBB PAGES
#####################################################


RewriteRule ^forum/sitemaps([0-9]+)\.html$ /forum/sitemaps.php?c=$1 [QSA,L]
RewriteRule ^forum/sitemaps\.html$ /forum/sitemaps.php [QSA,L]
RewriteRule ^forum/forum-m\ap\.html$ /forum/sitemaps.php?fim [QSA,L]
RewriteRule ^forum/forum-m\ap-([0-9]+)-([0-9]+)\.html$ /forum/sitemaps.php?fmp=$1&start=$2 [QSA,L]
RewriteRule ^forum/forum-m\ap-([0-9]+)\.html$ /forum/sitemaps.php?fmp=$1 [QSA,L]

# rewrite for blog mod
RewriteRule ^blog/(.*)$ /forum/weblog.php?u=$1
RewriteRule ^blog/(.*)/$ /forum/weblog.php?u=$1


Then, on your index, the link to forums is broken as it leads to -http://www.texascampingforum.com/forum/forums.html

All of this need to be taken care of, but please let's do it in the support thread ;)

++
Useful links :
SEO Forum || SEO Directory || SEO phpBB || Search
____________________

Liens Utiles :
Forum référencement || Annuaire référencement || Référencement phpBB || Recherche
dcz
Admin
Admin
 
Posts: 21428
Joined: Fri Apr 28, 2006 9:03 pm

Postby Peter77 » Thu Aug 03, 2006 6:52 am

This is great. downloaded it last week... thank you. :)
Peter77
phpBB SEO Team
phpBB SEO Team
 
Posts: 532
Joined: Wed May 10, 2006 9:46 am

Postby Serj » Sat Sep 23, 2006 2:20 pm

Can anyone help me out with this mod.

Basically I have SEO on my forum and want to use this mod to putput the urls such as:

topicid.html#postid

I downloaded the mod and saw it working on other peoples forums but upon installing it on mine my links look like:

forumurl.com/topic513710.html
forumurl.com/post513710.html#513710

I want it to link to topics only but in the topic url's it puts the post number/id instead of the topic ID so everytime I click on the topic it gives a topic does not exist.

Is there something wrong with my setup or the mod?

Thanks for your help.
Serj
 
Posts: 2
Joined: Sat Sep 23, 2006 2:16 pm

Postby dcz » Sat Sep 23, 2006 10:15 pm

And welcome :D

Actually, I checked both simple and mixed mod rewrite version again and did not find anything wrong in it.

I guess a link and more clues about which version are you using would help out here to help you out ;)

++
Useful links :
SEO Forum || SEO Directory || SEO phpBB || Search
____________________

Liens Utiles :
Forum référencement || Annuaire référencement || Référencement phpBB || Recherche
dcz
Admin
Admin
 
Posts: 21428
Joined: Fri Apr 28, 2006 9:03 pm

Postby Serj » Sun Sep 24, 2006 4:40 pm

It must be some setting on my forum as just installed a test phpbb installtion on my server and installed the SEO mod again and this mod and it worked 100% fine so must be something with my other forum.

THanks for your reply
Serj
 
Posts: 2
Joined: Sat Sep 23, 2006 2:16 pm

Postby euroman » Wed Feb 07, 2007 3:52 pm

I have simple mod rewrite latest version and have install the corrosponding add-on with danish language file. I get the following when I run topics_anywhere.php

Parse error: syntax error, unexpected T_STRING in /customers/mysite.dk/mysite.dk/httpd.www/language/lang_danish/lang_topics_anywhere.php on line 99


EDIT: english languagefile works...
Last edited by euroman on Mon Mar 19, 2007 6:49 pm, edited 1 time in total.
euroman
PR0
PR0
 
Posts: 81
Joined: Sat Oct 21, 2006 10:18 pm

Postby euroman » Wed Feb 07, 2007 4:49 pm

Is it possible to paste Adsense code in topics_anywhere.php so that the output javascript shows Adsense?

Anybody got hints how do I implement the code?

I have tried to place include('includes/adsense.php'); different places in topics_anywhere.php with no luck.

adsense.php beeing <center> Adsense code </center>

Also I have Adsense code as java
Code: Select all
google_ad_client = "pub-7104991257238878";
google_alternate_color = "FFFFFF";
google_ad_width = 728;
google_ad_height = 90;
google_ad_format = "728x90_as";
google_ad_type = "text_image";
google_ad_channel ="4778566908";
google_color_border = "EFEFEF";
google_color_bg = "EFEFEF";
google_color_link = "006598";
google_color_text = "000000";
google_color_url = "006598";

document.write('<script src="http://pagead2.googlesyndication.com/pagead/show_ads.js" type="text/JavaScript"><\/script>');


if that helps

EDIIT: Found an alternative solutions. http://www.mydomain.dk/10seneste.php
Last edited by euroman on Sun Aug 19, 2007 3:15 pm, edited 1 time in total.
euroman
PR0
PR0
 
Posts: 81
Joined: Sat Oct 21, 2006 10:18 pm

Next

Return to phpBB2 SEO MODS

 


  • Related topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 2 guests