mx sitemaps

Support for the phpBB2 SEO mods released in the phpBB2 SEO Toolikt forum.

Moderator: Moderators

mx sitemaps

Postby macnack » Fri Jun 30, 2006 8:41 am

Hello
I´ve a question :)
I include Sitemap Detektoreninfo.de but in Portal sitemap there are 2 Pages (Metalldetektor Beschreibungen) I won´t show because they only work correct with parameters after url (&Hersteller=C-Scope for example)
I want to show them in Site sitemap.
What must I do ?
macnack
PR1
PR1
 
Posts: 101
Joined: Tue Jun 20, 2006 7:01 am
Location: Germany

Advertisement

Postby dcz » Fri Jun 30, 2006 9:29 am

Nice install.

Have you noticed you can as well run it outside of mxBB with the standalone mode ?

The main interest of doing such is that you'll be able to mod rewrite the sitemaps links.

Then, the easiest for your pages with param, if there are not that much would be to just add them in the configurable site map Index as you did.

you can as well install the module both on portal and phpBB to provide more links ;)

They won't be dupes if under different domains with different settings ;)

More links.

As well, the auto links add ons are very useful.

You could use the mxBB part for the mxBB sitemap module and the phpBB one for the phpBB site map if you go for double install, or could link back everything top your mxBB one.

My advise is either to install it with mxBB standalone, or both embed in portal, and installed in phpBB with mod rewrite on.

++
Useful links :
SEO Forum || SEO Directory || SEO phpBB || Search
____________________

Liens Utiles :
Forum référencement || Annuaire référencement || Référencement phpBB || Recherche
dcz
Admin
Admin
 
Posts: 21379
Joined: Fri Apr 28, 2006 9:03 pm

Postby macnack » Fri Jun 30, 2006 10:15 am

I chance to standalone mode and install auto link but the link domain.de/mx-map.html doesn´t work (404) :?
forum-map.html and sitemap.html works

Can you have a look at the google_sitemap if the install is correct before I send it to google?
macnack
PR1
PR1
 
Posts: 101
Joined: Tue Jun 20, 2006 7:01 am
Location: Germany

Postby dcz » Fri Jun 30, 2006 10:30 am

macnack wrote:I chance to standalone mode and install auto link but the link domain.de/mx-map.html doesn´t work (404) :?
forum-map.html and sitemap.html works

Can you have a look at the google_sitemap if the install is correct before I send it to google?


Here we started talking about mx Sitemaps, please use the mx Google Sitemaps thread to talk about install issues with it ;)

Then, there is an additional thing to do to go for mod rewrite, I know this should be more clear, and will in 0.0.2, but this is required and worth it ;)

Pleas apply those changes in the .htaccess and phpBB files : http://boards.phpbb-seo.com/phpbb-seo-mods/site-map-auto-link-phpbb-vt5.html#317

The mx rewrite rule should as well be added :

Code: Select all
RewriteRule ^mx-map([0-9]+)\.html$ /sitemaps.php?mx&start=$2 [L]
RewriteRule ^mx-sitemap.xml$ /sitemaps.php?mx [L]


As well, since http://www.detektoreninfo.de/sitemaps.php?mx gives us a nice 404, I think you need to upload the MxSitemaps.php file located in the mxBB install folder ;)

Then, last thing you'll need to do for the mod rewrite to work nicely with the site maps link, is to open sessions.php and to look at the comment in append_sid() (the code the mod rewrite changed) and un-comment the sitemaps lines of code ;)

++
Useful links :
SEO Forum || SEO Directory || SEO phpBB || Search
____________________

Liens Utiles :
Forum référencement || Annuaire référencement || Référencement phpBB || Recherche
dcz
Admin
Admin
 
Posts: 21379
Joined: Fri Apr 28, 2006 9:03 pm

Postby macnack » Fri Jun 30, 2006 11:19 am

Hello dcz
I think I edit what you said
but the link domain.de/mx-map.html doesn´t work (404)
macnack
PR1
PR1
 
Posts: 101
Joined: Tue Jun 20, 2006 7:01 am
Location: Germany

Postby dcz » Fri Jun 30, 2006 11:50 am

Ok, you just need to use these rewriterules for mx Sitemaps :

Code: Select all
#########################################################
# MX SITEMAPS REWRITE RULES   ADVANCED                              #
#########################################################
# AUTHOR : dcz http://www.phpbb-seo.com/
# STARTED : 2006/04/28
########################################################
RewriteRule ^sitemaps([0-9]+)\.html$ /sitemaps.php?c=$1 [QSA,L]
RewriteRule ^sitemaps\.html$ /sitemaps.php [QSA,L]
RewriteRule ^forum-m\ap\.html$ /sitemaps.php?fim [QSA,L]
RewriteRule ^mx-map([0-9]+)\.html$ /sitemaps.php?mx&start=$2 [L]
RewriteRule ^mx-map.htmll$ /sitemaps.php?mx [L]
RewriteRule ^.+-fmp([0-9]+)-([0-9]+)\.html$ /sitemaps.php?fmp=$1&start=$2 [QSA,L]
RewriteRule ^.+-fmp([0-9]+)\.html$ /sitemaps.php?fmp=$1 [QSA,L]
RewriteRule ^.+-sc([0-9]+)\.html$ /sitemaps.php?c=$1 [QSA,L]
#########################################################
# END SITEMAPS REWRITE RULES            #
#########################################################


Use them instead of the ones you ad implemented for mx sitemaps (not mx Google sitemaps !)

++
Useful links :
SEO Forum || SEO Directory || SEO phpBB || Search
____________________

Liens Utiles :
Forum référencement || Annuaire référencement || Référencement phpBB || Recherche
dcz
Admin
Admin
 
Posts: 21379
Joined: Fri Apr 28, 2006 9:03 pm

Postby macnack » Fri Jun 30, 2006 5:47 pm

I use it but the mx-map.html doesn´t work :cry:
macnack
PR1
PR1
 
Posts: 101
Joined: Tue Jun 20, 2006 7:01 am
Location: Germany

Postby dcz » Fri Jun 30, 2006 11:58 pm

Try these :
Code: Select all
RewriteRule ^mx-m\ap([0-9]+)\.html$ /sitemaps.php?mx&start=$2 [L]
RewriteRule ^mx-m\ap.html$ /sitemaps.php?mx [L]


Instead of these :

Code: Select all
RewriteRule ^mx-map([0-9]+)\.html$ /sitemaps.php?mx&start=$2 [L]
RewriteRule ^mx-map.html$ /sitemaps.php?mx [L]


If not enough, please send me you full .htaccess ;)

++
Last edited by dcz on Sat Jul 01, 2006 10:16 am, edited 2 times in total.
Useful links :
SEO Forum || SEO Directory || SEO phpBB || Search
____________________

Liens Utiles :
Forum référencement || Annuaire référencement || Référencement phpBB || Recherche
dcz
Admin
Admin
 
Posts: 21379
Joined: Fri Apr 28, 2006 9:03 pm

Postby macnack » Sat Jul 01, 2006 9:37 am

Hello dcz

are you already repent that you´r welcome me first time I post here :twisted:

I chance the .htacces like you told me,
but mx-map.html doesn´t work.... :cry:
macnack
PR1
PR1
 
Posts: 101
Joined: Tue Jun 20, 2006 7:01 am
Location: Germany

Postby dcz » Sat Jul 01, 2006 9:41 am

Lol this was for sure:

RewriteRule ^mx-m\ap.htmll$ /sitemaps.php?mx [L]


Lol, we had missed it.

Get rid of this extra L ;)

++
Useful links :
SEO Forum || SEO Directory || SEO phpBB || Search
____________________

Liens Utiles :
Forum référencement || Annuaire référencement || Référencement phpBB || Recherche
dcz
Admin
Admin
 
Posts: 21379
Joined: Fri Apr 28, 2006 9:03 pm

Postby dcz » Sat Jul 01, 2006 10:39 am

So have you tried :

Code: Select all
RewriteRule ^mx-m\ap([0-9]+)\.html$ /sitemaps.php?mx&start=$2 [L]
RewriteRule ^mx-m\ap\.html$ /sitemaps.php?mx [L]


?
Useful links :
SEO Forum || SEO Directory || SEO phpBB || Search
____________________

Liens Utiles :
Forum référencement || Annuaire référencement || Référencement phpBB || Recherche
dcz
Admin
Admin
 
Posts: 21379
Joined: Fri Apr 28, 2006 9:03 pm

Postby macnack » Sat Jul 01, 2006 10:40 am

Doesn´t work...
But I see something interesting.
On mx-map.html I get a 404,
if I want to use google toolbar to go one folder higher it will redirect me to http://www.de-map.html/ not to http://www.detektoreninfo.de/ like in forum-map
macnack
PR1
PR1
 
Posts: 101
Joined: Tue Jun 20, 2006 7:01 am
Location: Germany

Postby dcz » Sat Jul 01, 2006 10:47 am

I had noticed.

That's the reason for the \ in "map".

Have you tried exacly these :
Code: Select all
RewriteRule ^mx-m\ap([0-9]+)\.html$ /sitemaps.php?mx&start=$2 [L]
RewriteRule ^mx-m\ap\.html$ /sitemaps.php?mx [L]


we'll do it ;)
Useful links :
SEO Forum || SEO Directory || SEO phpBB || Search
____________________

Liens Utiles :
Forum référencement || Annuaire référencement || Référencement phpBB || Recherche
dcz
Admin
Admin
 
Posts: 21379
Joined: Fri Apr 28, 2006 9:03 pm

Postby macnack » Sat Jul 01, 2006 10:56 am

:cry: :cry: :cry:
htaccess at this time in portal:
Code: Select all
#########################################################
# MX SITEMAPS REWRITE RULES   ADVANCED                              #
#########################################################
# AUTHOR : dcz http://www.phpbb-seo.com/
# STARTED : 2006/04/28
########################################################
RewriteRule ^sitemaps([0-9]+)\.html$ /sitemaps.php?c=$1 [QSA,L]
RewriteRule ^sitemaps\.html$ /sitemaps.php [QSA,L]
RewriteRule ^forum-m\ap\.html$ /sitemaps.php?fim [QSA,L]
RewriteRule ^mx-m\ap([0-9]+)\.html$ /sitemaps.php?mx&start=$2 [L]
RewriteRule ^mx-m\ap\.html$ /sitemaps.php?mx [L]
RewriteRule ^.+-fmp([0-9]+)-([0-9]+)\.html$ /sitemaps.php?fmp=$1&start=$2 [QSA,L]
RewriteRule ^.+-fmp([0-9]+)\.html$ /sitemaps.php?fmp=$1 [QSA,L]
RewriteRule ^.+-sc([0-9]+)\.html$ /sitemaps.php?c=$1 [QSA,L]
#########################################################
# END SITEMAPS REWRITE RULES            #
#########################################################
macnack
PR1
PR1
 
Posts: 101
Joined: Tue Jun 20, 2006 7:01 am
Location: Germany

Postby dcz » Sat Jul 01, 2006 10:59 am

Actually, this is strange that http://www.detektoreninfo.de/forum-map.html works if /mx-map.html doesn't.

Let's give a last try with these :

Code: Select all
RewriteRule ^mx-\m\a\p([0-9]+)\.html$ /sitemaps.php?mx&start=$2 [L]
RewriteRule ^mx-\m\a\p\.html$ /sitemaps.php?mx [L]


If still not enough, I guess we'll have to customise those for you, using portal-map, or whatever else.

++
Useful links :
SEO Forum || SEO Directory || SEO phpBB || Search
____________________

Liens Utiles :
Forum référencement || Annuaire référencement || Référencement phpBB || Recherche
dcz
Admin
Admin
 
Posts: 21379
Joined: Fri Apr 28, 2006 9:03 pm

Next

Return to phpBB2 SEO MODS

 


  • Related topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 2 guests