Problème avec SEO URL Smartor

Le forum de support des mods d'optimisation du référencement de l'album photo Smartor et du Full Album Pack.

Modérateur: Modérateurs

Problème avec SEO URL Smartor

Messagede Grilom » Sam Oct 13, 2007 12:21 pm

Bonjour Bonjour...

Alors voilà...

La redirection d'URLs marchent à MERVEILLE! ...

Mais j'ai un autre problème:

On ne voit plus les images! :S

Par contre, lorsque j'up le fichier d'origine, on voit à nouveau les images dans ce fichier en question...

par exemple:
J'ai remis "album.php" d'origine (c'est à dire sans SEO URL smartor) et on voit les images en bas de la page (les images récentes) voici:
http://www.culture-pour-tous.com/album.html


Par contre, j'ai laissé "album_cat.php" avec les modifications faites avec le mod SEO URL smartor... Et l'on voit bien qu'il ne trouve plus les images... Voici pour un exemple pour une catégorie:
http://www.culture-pour-tous.com/paysage-ac2.html


C'est comme si il ne trouvait plus l'adresse l'image :?:

Pouvez vous m'aider SVP?

Merci d'avance!!!!

Bonne journée à tous et à toutes!
Grilom
PR0
PR0
 
Messages: 64
Inscription: Mar Fév 20, 2007 3:56 pm

Publicité

Messagede dcz » Dim Oct 21, 2007 11:38 am

Les liens sont pourtant bien là :
Code: Tout sélectionner
<img src="virgin-gorda-islands-iles-vierges-britanniques-thumb39.jpg" alt="" title="" border="0" vspace="10">


Tu n'aurais pas oublié une petite rewriterule dans le .htaccess ?

Poste le ici en cas.

++
Useful links :
SEO Forum || SEO Directory || SEO phpBB || Search
____________________

Liens Utiles :
Forum référencement || Annuaire référencement || Référencement phpBB || Recherche
dcz
Admin
Admin
 
Messages: 21325
Inscription: Ven Avr 28, 2006 9:03 pm

Messagede Grilom » Sam Oct 27, 2007 12:40 pm

J'ai tout refait.... j'ai repris de 0 ... Et ça ne change rien! :(

Les liens sont bien présents mais les images ne sont pas là! (comme si l'accès aux images n'étaient pas possible...

Voici mon .htaccess:

Code: Tout sélectionner
RewriteEngine On
RewriteCond %{HTTP_HOST} ^culture-pour-tous\.com$ [NC]
RewriteRule ^(.*) http://www.culture-pour-tous.com/$1 [QSA,L,R=301] RewriteBase /

#########################################################
# PHPBB SEO REWRITE RULES            #
#########################################################
# AUTHOR : dcz http://www.phpbb-seo.com/
# STARTED : 01/2006
#####################################################
# FORUMS PAGES
########################
# FORUM INDEX (un-comment if used)
# RewriteRule ^index\.html$ /index.php [QSA,L,NC]
# FORUM PROTECTION RULE
# RewriteRule ^[a-z0-9_-]+/([^/]+\.html)$ /index.php [R=301,L,NC]
# CATEGORIES
RewriteRule ^[a-z0-9_-]*-c([0-9]+)\.html$ /index.php?c=$1 [QSA,L,NC]
# PAGINATED FORUM
RewriteRule ^[a-z0-9_-]*-f([0-9]+)-([0-9]+)\.html$ /viewforum.php?f=$1&start=$2 [QSA,L,NC]
# FORUM
RewriteRule ^[a-z0-9_-]*-f([0-9]+)\.html$ /viewforum.php?f=$1 [QSA,L,NC]
# PAGINATED TOPIC
RewriteRule ^topic([0-9]+)-([0-9]+)\.html$ /viewtopic.php?t=$1&start=$2 [QSA,L,NC]
# TOPIC
RewriteRule ^topic([0-9]+)\.html$ /viewtopic.php?t=$1 [QSA,L,NC]
# POST
RewriteRule ^post([0-9]+)\.html$ /viewtopic.php?p=$1 [QSA,L,NC]
#PROFILES
RewriteRule ^membre([0-9]+)\.html$ /profile.php?mode=viewprofile&u=$1 [QSA,L,NC]
# END PHPBB PAGES
#####################################################

#########################################################
# SMARTOR ALBUM REWRITE RULES            #
#########################################################
# AUTHOR : dcz http://www.phpbb-seo.com/
# STARTED : 2007/02/22
########################
# ALBUM INDEX
RewriteRule ^album\.html$ /album.php [QSA,L,NC]
# ALBUM PAGINATED CAT
RewriteRule ^[a-z0-9_-]+-ac([0-9]+)-([0-9]+)\.html$ /album_cat.php?cat_id=$1&start=$2 [QSA,L,NC]
# ALBUM CAT
RewriteRule ^[a-z0-9_-]+-ac([0-9]+)\.html$ /album_cat.php?cat_id=$1 [QSA,L,NC]
# ALBUM PIC
RewriteRule ^[a-z0-9_-]+-sp([0-9]+)\.html$ /album_page.php?pic_id=$1 [QSA,L,NC]
# PERSONAL USER CAT PAGINATED
RewriteRule ^[a-z0-9_-]+-ap([0-9]+)-([0-9]+)\.html$ /album_personal.php?user_id=$1&start=$2 [QSA,L,NC]
# PERSONAL USER CAT
RewriteRule ^[a-z0-9_-]+-ap([0-9]+)\.html$ /album_personal.php?user_id=$1 [QSA,L,NC]
# PAGINATED COMMENT
RewriteRule ^[a-z0-9_-]+-sr([0-9]+)-([0-9]+)\.html$ /album_comment.php?pic_id=$1&start=$2 [QSA,L,NC]
# COMMENT
RewriteRule ^[a-z0-9_-]+-sr([0-9]+)\.html$ /album_comment.php?pic_id=$1 [QSA,L,NC]
# PERSONAL CAT PAGINATED
RewriteRule ^galeries-membre-([0-9]+)\.html$ /album_personal_index.php?start=$1 [QSA,L,NC]
# PERSONAL CAT
RewriteRule ^galeries-membre\.html$ /album_personal_index.php [QSA,L,NC]
# THUMBNAILS
RewriteRule ^[a-z0-9_-]+-thumb([0-9]+)\.jpg$ album_thumbnail.php?pic_id=$1 [QSA,L,NC]
# FULL
RewriteRule ^[a-z0-9_-]+-pic([0-9]+)\.jpg$ album_pic.php?pic_id=$1 [QSA,L,NC]
#########################################################

#########################################################
# GYM SITEMAPS AND RSS REWRITE RULES         #
#########################################################
# AUTHOR : dcz http://www.phpbb-seo.com/
# STARTED : 2006/02/22
########################
# RSS main
RewriteRule ^rss-?(l|s)?-?(m)?\.(xml(\.gz)?)$ /rss.php?$1&$2 [L]
# RSS forums
RewriteRule ^forums-rss-?(l|s)?-?(m)?\.(xml(\.gz)?)$ /rss.php?forum&c&$1&$2 [L]
# RSS all
RewriteRule ^([a-zA-Z0-9]+)-rss([0-9]*)-?(l|s)?-?(m)?\.(xml(\.gz)?)$ /rss.php?$1=$2&$3&$4 [L]
# RSS forum topics
RewriteRule ^.+-rf([0-9]+)-?(l|s)?-?(m)?\.(xml(\.gz)?)$ /rss.php?forum=$1&$2&$3 [L]
# SitemapIndex
RewriteRule ^sitemaps\.(xml(\.gz)?)$ /sitemap.php [L]
# Sitemap modules
RewriteRule ^([a-zA-Z0-9]+)-sitemap\.(xml(\.gz)?)$ /sitemap.php?$1 [L]
# Forum Sitemaps
RewriteRule ^.+-gf([0-9]+)\.(xml(\.gz)?)$ /sitemap.php?forum=$1 [L]
# Yahoo! urllist.txt
RewriteRule ^urllist\.(txt(\.gz)?)$ /urllist.php [L]
#########################################################
# END GYM SITEMAPS AND RSS REWRITE RULES      #
#########################################################



J'espère que vous pourrez m'aider :(

P.S: j'utilise smartor 2.0.53 (mais je ne pense pas que ça change quelque chose vu les autres posts du forum) et j'ai mis à jour le mod rewrite de phpbb seo...

Merci d'avance!!! Bon W-E à tous et à toutes!

P.S: pour le moment j'ai tout remis d'origine pour que la section "Album" soit tout de même accessible...
Grilom
PR0
PR0
 
Messages: 64
Inscription: Mar Fév 20, 2007 3:56 pm

Messagede dcz » Dim Oct 28, 2007 1:22 pm

C'est étrange, et en tous cas, c'est certainement une histoire de .htaccess vu que le lien est bien présent dans le code.
Tu as pourtant bien :
Code: Tout sélectionner
# THUMBNAILS
RewriteRule ^[a-z0-9_-]+-thumb([0-9]+)\.jpg$ album_thumbnail.php?pic_id=$1 [QSA,L,NC]


C'est le dernier .htaccess en ligne ?

Comme tu as tout retiré, difficile de tester.

Tu as essayé en local ?

Tu pourrais aussi laisser le .htaccess, sans les changement de code dans les fichiers php, les liens ne seront pas réécrit, mais on pourra essayer des liens pour voir.

++
Useful links :
SEO Forum || SEO Directory || SEO phpBB || Search
____________________

Liens Utiles :
Forum référencement || Annuaire référencement || Référencement phpBB || Recherche
dcz
Admin
Admin
 
Messages: 21325
Inscription: Ven Avr 28, 2006 9:03 pm

Messagede Grilom » Dim Oct 28, 2007 10:56 pm

Je vais m'absenter pendant un moment et après je vais pas trop trop trop avoir le temps (pas mal de travaux à faire ;) )

Pour le moment l'essentiel c'est que le forum soit bien "fait" ... Après la galerie photo c'est juste un petit "bonus" ^^

Mais dès que je pourrais j'essayerai de faire comme tu m'as dit et on regardera ça ensemble ^^
Je continuerai à la suite de ce post ^^ :D

Merci d'avance de tous l'intérêt que tu portes à mon problème!

Bonne nuit à tous et à toutes!
Grilom
PR0
PR0
 
Messages: 64
Inscription: Mar Fév 20, 2007 3:56 pm

Messagede Grilom » Dim Oct 28, 2007 11:51 pm

ON STOP TOUT... J'ai trouvé l'erreur ^^

Elle se situe dans ton mod...

Dans le .htaccess, il manque le "/" avant le fichier en .php de ces deux dernières lignes:

Code: Tout sélectionner
RewriteRule ^[a-z0-9_-]+-thumb([0-9]+)\.jpg$ album_thumbnail.php?pic_id=$1 [QSA,L,NC]
# FULL
RewriteRule ^[a-z0-9_-]+-pic([0-9]+)\.jpg$ album_pic.php?pic_id=$1 [QSA,L,NC]


Donc si on modifie ces lignes comme ceci:

Code: Tout sélectionner
RewriteRule ^[a-z0-9_-]+-thumb([0-9]+)\.jpg$ /album_thumbnail.php?pic_id=$1 [QSA,L,NC]
# FULL
RewriteRule ^[a-z0-9_-]+-pic([0-9]+)\.jpg$ /album_pic.php?pic_id=$1 [QSA,L,NC]


C'est parfait, cela fonctionne ^^

C'est juste?

Voilou VOilou
Grilom
PR0
PR0
 
Messages: 64
Inscription: Mar Fév 20, 2007 3:56 pm

Messagede dcz » Lun Oct 29, 2007 8:40 am

Grilom a écrit:ON STOP TOUT... J'ai trouvé l'erreur ^^

Elle se situe dans ton mod...


Il "manque" en effet un slash sur cette rewriterule en comparaison des autres dans l'installe, mais, il n'est pas toujours nécessaire. C'est le slash à mettre ou ne pas mettre en fonction de ton serveur.
installe a écrit:________________
NOTE : .htaccess
________________

Si votre forum est installé à la racine du domaine, utilisez les Rewriterules
appropriées sans les modifier.
S'il est installé dans un sous-dossier, vous devrez remplacer dans les lignes "RewriteRule"
toutes les occurrences de 'phpbb' par le nom du dossier dans lequel phpBB est installé.
En fonction de votre hébergeur, il se peut que vous ayez à retirer les "/" se trouvant devant les noms de fichier.php
Exemple : RewriteRule ^album\.html$ album.php [QSA,L,NC]


++
Useful links :
SEO Forum || SEO Directory || SEO phpBB || Search
____________________

Liens Utiles :
Forum référencement || Annuaire référencement || Référencement phpBB || Recherche
dcz
Admin
Admin
 
Messages: 21325
Inscription: Ven Avr 28, 2006 9:03 pm

Messagede Grilom » Lun Oct 29, 2007 10:01 am

Oui mais là c'est les supprimer mais ajouter 2 "/" par rapport au code de départ ;)

Mais l'essentiel c'est que ça fonctionne ^^ :D

Merci à toi dcz :) ^^
Grilom
PR0
PR0
 
Messages: 64
Inscription: Mar Fév 20, 2007 3:56 pm


Retourner vers Album Smartor

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Alexa [Bot] et 9 invités