Warning: Cannot modify header information - headers already

Forum consacré à phpBB2. Comment tirer le meilleur de ce puissant forum.

Modérateur: Modérateurs

Warning: Cannot modify header information - headers already

Messagede haffouff » Lun Oct 15, 2007 9:38 pm

salut a tous,

J'ai un forum phpbb 2 hebergé sur un herbegeur et qui fonctionnais de facon tout a fait normal. Seulement voila, en essayant de le transeférer chez un autre hebergeur, j'ai fait un backup de la base mysql et recopié tout les fichier du forum sur le nouveau herbergeur.
Mais la surprise.
En ouvrant le forum je recois les messages suivant :

Code: Tout sélectionner
Warning: Cannot modify header information - headers already sent by (output started at /lesite/public_html/forum/index.php:6) in /lesite/public_html/forum/includes/page_header.php on line 529

Warning: Cannot modify header information - headers already sent by (output started at /lesite/public_html/forum/index.php:6) in /lesite/public_html/forum/includes/page_header.php on line 531

Warning: Cannot modify header information - headers already sent by (output started at /lesite/tuninfo4u.com/public_html/forum/index.php:6) in /lesite/public_html/forum/includes/page_header.php on line 532


Avez vous une solution svp ??

:( :( :(
haffouff
 
Messages: 35
Inscription: Mer Juin 06, 2007 4:19 pm

Publicité

Messagede R1_Bzh » Mar Oct 16, 2007 11:22 am

L'erreur indique que tu as une erreur php qui modifie l'entête. plusieurs solutions possible:
- tu as oublié de modifé ton config.php pour le mot de passe de base de donnée
- la base de donnée n'a pas le même nom
- un fichier n'est pas lisible (problème de droit ?)
- la config de ton ancien forum, dans la base de donnée, donne un chemin désormais inexistant. Exemple: dossier du forum /forum/

Dans tous les cas c'est php qui ne trouve pas quelque chose ou n'arrive pas à se connecter à la base de donnée, ou tu as oublié de transférer un fichier.
[ Phea ]: Développement PHP/MySQL/Ajax , hébergement de site & services mail et administration de serveur Unix
[ Coda-Cola ]: Solution de gestion de projets (subversion SVN / Redmine)
[ Rechercher ]
R1_Bzh
phpBB SEO Team
phpBB SEO Team
 
Messages: 214
Inscription: Mer Juil 04, 2007 3:29 pm
Localisation: Toulouse

Messagede haffouff » Mar Oct 16, 2007 3:05 pm

R1_Bzh a écrit:- tu as oublié de modifé ton config.php pour le mot de passe de base de donnée
- la base de donnée n'a pas le même nom
- un fichier n'est pas lisible (problème de droit ?)
- la config de ton ancien forum, dans la base de donnée, donne un chemin désormais inexistant. Exemple: dossier du forum /forum/


Si je me suis trouver de configuration dans le fichier config.php alors comment est ce possible que j'arrive a avoir mon forum ??
je peut tout faire, me connecter, ajouter supprimer modifier des messages ...
Mais il y a seulement ces warning qui s'affichent au dessus de la page.

Et puis je pense pas avoir oublié de precopier un fichier car j'ai transférer le dossier forum tout entier. :(
haffouff
 
Messages: 35
Inscription: Mer Juin 06, 2007 4:19 pm

Messagede Arf » Mar Oct 16, 2007 4:24 pm

Tu as quoi comme ligne de code pour le fichier page_header au lignes indiqués ?
Arf
PR1
PR1
 
Messages: 188
Inscription: Ven Jan 19, 2007 10:12 am

Messagede haffouff » Mar Oct 16, 2007 5:17 pm

voila les lignes de mon fichier page_header.php

-http://www.imagup.info/images/06/1192558030_warning.JPG
[mod]L'image ne marche pas[/mod]


les warning sont aux lignes 526, 532,533 ( eh oui !! je sais que c vide mais c un warning a la ligne 533 !!!)
haffouff
 
Messages: 35
Inscription: Mer Juin 06, 2007 4:19 pm

Messagede dcz » Dim Oct 21, 2007 1:25 pm

Donc, ça pourrait venir d'espaces après "?>" dans overall_header.php, que ton ancien hebergeur tolérait par exemple.

Mais il est possible qu'il y ait un autre problème, autour de la ligne 6 de index.php.

Tu pourrais nous poster le code de quelques ligne autour de la n°6 de ton index.php ?

++
Useful links :
SEO Forum || SEO Directory || SEO phpBB || Search
____________________

Liens Utiles :
Forum référencement || Annuaire référencement || Référencement phpBB || Recherche
dcz
Admin
Admin
 
Messages: 21429
Inscription: Ven Avr 28, 2006 9:03 pm

Messagede haffouff » Dim Oct 21, 2007 6:00 pm

Merci pour ta reponse mais finalement je viens de trouver la solution.

J'ai tout simplement remplacer dans mon forum le fichier index.php par un nouveau index.php (celui qu'on trouve dans le fichier d'installaion de phpbb et qui ne contient aucune modif)
Et la tout marche sans aucun probleme.
Ensuite j'ai appliqué les modifs de mes mods dans index.php et voila :lol: :lol: :lol:

Ca marche a merveil.
haffouff
 
Messages: 35
Inscription: Mer Juin 06, 2007 4:19 pm

Messagede dcz » Lun Oct 22, 2007 6:41 am

Excellente initiative :D

Il faut parfois comprendre que la vrai économie d'efforts, c'est de repartir à zéro ;)

++
Useful links :
SEO Forum || SEO Directory || SEO phpBB || Search
____________________

Liens Utiles :
Forum référencement || Annuaire référencement || Référencement phpBB || Recherche
dcz
Admin
Admin
 
Messages: 21429
Inscription: Ven Avr 28, 2006 9:03 pm


Retourner vers Le Forum phpBB2

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 1 invité


 
cron