[Réglé] Problème lors de changement de domaine

Forum consacré à phpBB2. Comment tirer le meilleur de ce puissant forum.

Modérateur: Modérateurs

[Réglé] Problème lors de changement de domaine

Messagede Gabe_Logan » Ven Juin 20, 2008 2:26 am

Bonjour,
J'ai un léger problème avec phpBB3.
J'ai un site sur un hébergeur gratuit, et je viens de m'acheter un nom de domaine sur un autre fournisseur.
Mon site est donc toujours hébergé au même endroit, mais l'URL vient de changer (mais les 2 adresses fonctionnent toujours, aussi bien l'ancienne que la nouvelle). Jusque là pas de problème.
Je peux accéder à toutes mes pages sans problème, y compris au forum via l'adresse mondomaine.com/phpBB3.
Seulement voilà, quand je me connecte au forum, la page chargée revient toujours à l'ancienne adresse (nomdusite.serveur.com/phpBB3). Et si je tente de recharger la page avec le nom de domaine (mondomaine.com/phpBB3), je me retrouve déconnecté.

Comment dire à phpBB que la racine du domaine à changé ? Est-ce que de lancer le fichier d'installation (sans faire une vrai réinstallation) pourrait aider ? Merci d'avance !
Dernière édition par Gabe_Logan le Dim Juin 22, 2008 8:52 pm, édité 1 fois.
Avatar de l’utilisateur
Gabe_Logan
 
Messages: 45
Inscription: Jeu Mai 08, 2008 5:38 pm
Localisation: Québec, Canada

Publicité

Messagede R1_Bzh » Ven Juin 20, 2008 9:23 am

Non, il suffit de regarder dans les configurations de ton forum
Acp => Général => Paramètres du serveur
Tu configure le nom de domaine et le chemin du script
[ Phea ]: Développement PHP/MySQL/Ajax , hébergement de site & services mail et administration de serveur Unix
[ Coda-Cola ]: Solution de gestion de projets (subversion SVN / Redmine)
[ Rechercher ]
R1_Bzh
phpBB SEO Team
phpBB SEO Team
 
Messages: 214
Inscription: Mer Juil 04, 2007 3:29 pm
Localisation: Toulouse

Messagede Gabe_Logan » Ven Juin 20, 2008 8:15 pm

Génial, merci !
Avatar de l’utilisateur
Gabe_Logan
 
Messages: 45
Inscription: Jeu Mai 08, 2008 5:38 pm
Localisation: Québec, Canada

Messagede Gabe_Logan » Sam Juin 21, 2008 2:22 am

Bon, ça semblait trop beau : un nouveu problème à l'horizon...

PhpBB ne semble plus retenir les sessions. Tant que je reste sur le forum, tout baigne. Mais si je passe sur une page autre et que je reviens, ma session est terminée. Et j'ai bien sélectionné l'option "Me connecter automatiquement", j'ai réessayé plusieurs fois. Quelqu'un connaît la cause ?
Avatar de l’utilisateur
Gabe_Logan
 
Messages: 45
Inscription: Jeu Mai 08, 2008 5:38 pm
Localisation: Québec, Canada

Messagede skieur » Sam Juin 21, 2008 6:21 am

Hum cela ressemble à un problèmes de cookies. Je rechercherai de ce coté la en tout cas. Dans l'admin tu a paramètres des cookies, vérifie que firefox les a bien.


A plus.
skieur
PR2
PR2
 
Messages: 228
Inscription: Dim Aoû 19, 2007 6:26 pm

Messagede SeO » Sam Juin 21, 2008 9:06 am

Ouaip, mets bien ".example.com" pour le domaine du cookie (avec le point ".") ;)
SeO
Admin
Admin
 
Messages: 6334
Inscription: Mer Mar 15, 2006 9:41 pm

Messagede Gabe_Logan » Sam Juin 21, 2008 4:49 pm

Ça fonctionne, merci !
Avatar de l’utilisateur
Gabe_Logan
 
Messages: 45
Inscription: Jeu Mai 08, 2008 5:38 pm
Localisation: Québec, Canada


Retourner vers Le Forum phpBB2

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 2 invités