Yahoo indexe d'anciennes url

Forums spécifiques au moteur de recherche Yahoo, Référencement, Marketing Tools, Small Business, Services, utilisation ...

Modérateur: Modérateurs

Yahoo indexe d'anciennes url

Messagede Marie » Dim Nov 26, 2006 3:26 pm

Bonjour à tous :wink:

Il y a 3-4 jours, le nombre de pages de mon site référencées sur Yahoo est passé de 350 à plus de 800. :shock:
J'ai donc regardé par la commande site: d'où venaient ces url supplémentaires et j'ai constaté un truc curieux.
Il y a un bon nombre d'url du type -http://www.micro-astuce.com/Forum/sutra723.php qui partent toutes en 404 et d'autres du type -http://www.micro-astuce.com/Forum/ftopic97.html (ancienne méthode url rewriting).

Exemple

Comme si Yahoo avait remonté un index vieux de plusieurs mois. :shock:

J'ai attendu quelques jours pensant qu'il allait se ressaisir mais visiblement il s'obstine. :lol:

Avez vous aussi constaté ce phénomène sur vos sites?
Avatar de l’utilisateur
Marie
PR1
PR1
 
Messages: 159
Inscription: Mar Juin 27, 2006 7:05 pm

Publicité

Messagede dcz » Dim Nov 26, 2006 3:40 pm

Ah oui tiens c'est marrant, il fait comme Google des fois.

Un hd qui meure et hop panique dans les backups. Ce qui m'impressionne dans ce genre de cas, c'est de constaté qu'ils conservent des backups assez longtemps.

Dans le cas de Google il m'est arrivé de le voir carrément sortir des cache de huit mois en arrières ...

Par contre, il faudrait qu'elles soient redirigées ces URLs pour bien faire.

Comme tu as le zéro dupe, l'opération consiste simplement à ajouter les anciennes rewriterules des ces URLs à la toute fin du .htaccess de ton forum (avec les bon chemins) et après hop a pu ;)

Encore une utilité supplémentaire à ces redirections, ne pas souffrir des erreurs des moteurs de recherche.
Parce que sur un coup comme ça, se retrouver avec autant de 404, c'est pas génial. Et puis il faut s'en rendre compte, enfin ...

++
Useful links :
SEO Forum || SEO Directory || SEO phpBB || Search
____________________

Liens Utiles :
Forum référencement || Annuaire référencement || Référencement phpBB || Recherche
dcz
Admin
Admin
 
Messages: 21379
Inscription: Ven Avr 28, 2006 9:03 pm

Messagede Marie » Dim Nov 26, 2006 4:49 pm

Salut dcz :wink:

Par contre, il faudrait qu'elles soient redirigées ces URLs pour bien faire.


Les ftopic sont déjà redirigés.
(Je me suis trompée dans l'url que je donne en exemple: C'est pas -http://www.micro-astuce.com/Forum/ftopic97.html mais -http://www.micro-astuce.com/Forum/ftopic97.php)


Pour les sutra est ce qu'une règle comme celle ci irait bien? :oops:

Code: Tout sélectionner
RewriteRule ^Forum/sutra([0-9]+)\.php /Forum/post$1.html [R=301,L]
Avatar de l’utilisateur
Marie
PR1
PR1
 
Messages: 159
Inscription: Mar Juin 27, 2006 7:05 pm

Messagede dcz » Dim Nov 26, 2006 5:18 pm

Plus besoin de se prendre la tête avec le zéro dupe, les rewriterules originales le font très bien, la redirection à lieux après, au niveau de viewtopic.php.

Met simplement les anciennes rewriterules de DLP avec les bon chemins à la fin du .htaccess de ton forum ;)

++
Useful links :
SEO Forum || SEO Directory || SEO phpBB || Search
____________________

Liens Utiles :
Forum référencement || Annuaire référencement || Référencement phpBB || Recherche
dcz
Admin
Admin
 
Messages: 21379
Inscription: Ven Avr 28, 2006 9:03 pm

Messagede Marie » Lun Nov 27, 2006 10:07 am

C'est bon!
Plus de 404 sur les url fantaisistes de Yahoo. :D



Par contre, lorsque je poste un message, j'ai maintenant une erreur:

Failed sending email :: PHP ::
DEBUG MODE
Line : 234
File : emailer.php


Je vois pas bien le rapport avec le .htaccess, mais bon... :?

J'ai rajouté cette règle dans le .htaccess.
Code: Tout sélectionner
# SUTRA
RewriteRule ^Forum/sutra([0-9]+)\.php$ /Forum/viewtopic.php?p=$1 [QSA,L]
# END PHPBB PAGES


[Edit] Finalement, après lecture de ce document, je pense que la solution est chez mon hébergeur. :oops:
Avatar de l’utilisateur
Marie
PR1
PR1
 
Messages: 159
Inscription: Mar Juin 27, 2006 7:05 pm

Messagede dcz » Lun Nov 27, 2006 6:18 pm

En effet, je vois pas trop comment une rewriterule pourrait gêner l'envoi de mail, surtout celle là.

T'as pas activé le smtp dans la config de phpBB, comme ça sans t'en rendre compte ?

++
Useful links :
SEO Forum || SEO Directory || SEO phpBB || Search
____________________

Liens Utiles :
Forum référencement || Annuaire référencement || Référencement phpBB || Recherche
dcz
Admin
Admin
 
Messages: 21379
Inscription: Ven Avr 28, 2006 9:03 pm

Messagede Marie » Lun Nov 27, 2006 9:47 pm

Non... Rien touché dans l'ACP.
Mais en fin d'après midi, tout est rentré dans l'ordre sans qu'on ne modifie rien. :?
En fait, hier soir les membres ont reçu des notifications de réponse datant ( pour les plus vieilles) de 1 mois en arrière.
Donc, je suppose que l'hébergeur a eu un souci et que ce matin il y a eu quelques cafouillages.
(Fonction d'envoi de mails, désactivée temporairement par l'hébergeur, peut-être...)

Maintenant, tout va bien: plus de 404 et une fonction mail qui marche bien. :wink:
Avatar de l’utilisateur
Marie
PR1
PR1
 
Messages: 159
Inscription: Mar Juin 27, 2006 7:05 pm


Retourner vers Forums Yahoo!

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 3 invités