probleme installation GYM sitemaps

Le module GYM Sitemaps and RSS et ses plug-ins.
Plans de site Google Yahoo et MSN Sitemaps (0.9 United Sitemaps).
Flux RSS 2.0.
Yahoo! urllist.txt.

Modérateur: Modérateurs

Messagede zalf » Sam Juil 14, 2007 3:29 pm

Merci,

J'essaye d'installer GMY sitemaps

Je l'ai bien dans le menu administration mais j'ai quelque doute.
Où doit être le fichier sitemap.php?
Dans la racine, j'ai le message que le ficher sitemaps.xml n'existe pas
Code: Tout sélectionner
The requested URL /sitemaps.xml was not found on this server.

si j'en fait un, pas de message mais rien d'autre
Code: Tout sélectionner
Erreur d'analyse XML : aucun élément trouvé
Emplacement : http://portailvacances.com/sitemaps.xml
Numéro de ligne 1, Colonne 44 :<?xml version="1.0" encoding="iso-8859-1"?>
-------------------------------------------^

Dans le répertoire de mon forum /phpBB, j'ai pas mal de message d'erreur
Code: Tout sélectionner
Warning: main(./phpBB/extension.inc) [function.main]: failed to open stream: No such file or directory in /home.10.3/portailv/www/phpBB/sitemap.php on line 37

Warning: main() [function.include]: Failed opening './phpBB/extension.inc' for inclusion (include_path='.:/usr/local/lib/php') in /home.10.3/portailv/www/phpBB/sitemap.php on line 37

Warning: main(./phpBB/common.php) [function.main]: failed to open stream: No such file or directory in /home.10.3/portailv/www/phpBB/sitemap.php on line 38

Warning: main() [function.include]: Failed opening './phpBB/common.php' for inclusion (include_path='.:/usr/local/lib/php') in /home.10.3/portailv/www/phpBB/sitemap.php on line 38

Fatal error: Call to undefined function: session_pagestart() in /home.10.3/portailv/www/phpBB/sitemap.php on line 43


J'ai vu que le mode crée un sitemapindex.xml, comment faire?
zalf
 
Messages: 26
Inscription: Ven Juil 13, 2007 8:53 pm

Publicité

Messagede zalf » Sam Juil 14, 2007 3:36 pm

Et comment fait on pour avoir un fichier comme ca?
http://www.phpbb-seo.com/forums/sitemaps.xml
zalf
 
Messages: 26
Inscription: Ven Juil 13, 2007 8:53 pm

Messagede gowap » Sam Juil 14, 2007 10:53 pm

Relis lentement et calmement le fichier d'installation du mod.

sitemap.php doit etre mis dans le dossier de ton forum (a priori dans /phpBB dans ton cas).
Ensuite, le fichier sitemap.xml n'est pas un fichier qui existera physiquement sur ton serveur. Il ne faut pas en créer un vide.
Un appel a ce fichier sera redirigé (via les regles rajoutées dan le fichier htaccess) vers sitemap.php qui générera dynamiquement un fichier xml.
Gravure-News : la communauté francophone de la gravure de CD/DVD et son forum d'entraide.
Avatar de l’utilisateur
gowap
phpBB SEO Team
phpBB SEO Team
 
Messages: 1510
Inscription: Dim Mai 07, 2006 10:56 pm

Messagede zalf » Sam Juil 14, 2007 11:14 pm

Merci de ta réponse
Je pense avoir tout fait correctement. Mon fichier sitemap.php est bien dans le répertoire de mon forum
Voici mon .htaccess qui est lui sur la racine de mon site
    # You could need to un-comment the following line
    # Options +FollowSymlinks
    RewriteEngine On
    RewriteBase /


    #########################################################

    # PHPBB SEO REWRITE RULES #
    #########################################################

    # AUTHOR : DCZ http://www.phpbb-seo.com/
    # STARTED : 01/2006

    #####################################################
    # FORUMS PAGES
    ########################
    # FORUM INDEX (un-comment if used)
    # RewriteRule ^phpBB/index\.html$ /phpBB/index.php [QSA,L,NC]
    # FORUM PROTECTION RULE
    # RewriteRule ^phpBB/[a-z0-9_-]+/([^/]+\.html)$ /phpBB/index.php [R=301,L,NC]
    # CATEGORIES
    RewriteRule ^phpBB/[a-z0-9_-]*-c([0-9]+)\.html$ /phpBB/index.php?c=$1 [QSA,L,NC]
    # PAGINATED FORUM
    RewriteRule ^phpBB/[a-z0-9_-]*-f([0-9]+)-([0-9]+)\.html$ /phpBB/viewforum.php?f=$1&start=$2 [QSA,L,NC]
    # FORUM
    RewriteRule ^phpBB/[a-z0-9_-]*-f([0-9]+)\.html$ /phpBB/viewforum.php?f=$1 [QSA,L,NC]
    # PAGINATED TOPIC
    RewriteRule ^phpBB/[a-z0-9_-]*-t([0-9]+)-([0-9]+)\.html$ /phpBB/viewtopic.php?t=$1&start=$2 [QSA,L,NC]
    # TOPIC
    RewriteRule ^phpBB/[a-z0-9_-]*-t([0-9]+)\.html$ /phpBB/viewtopic.php?t=$1 [QSA,L,NC]
    # POST
    RewriteRule ^phpBB/post([0-9]+)\.html$ /phpBB/viewtopic.php?p=$1 [QSA,L,NC]
    #PROFILES
    RewriteRule ^phpBB/membre([0-9]+)\.html$ /phpBB/profile.php?mode=viewprofile&u=$1 [QSA,L,NC]
    # END PHPBB PAGES
    #####################################################

    #########################################################
    # GYM SITEMAPS AND RSS REWRITE RULES #
    #########################################################
    # AUTHOR : dcz http://www.phpbb-seo.com/
    # STARTED : 2006/02/22
    ########################
    # RSS main
    RewriteRule ^phpBB/rss-?(l|s)?-?(m)?\.(xml(\.gz)?)$ /phpBB/rss.php?$1&$2 [L]
    # RSS forums
    RewriteRule ^phpBB/forums-rss-?(l|s)?-?(m)?\.(xml(\.gz)?)$ /phpBB/rss.php?forum&c&$1&$2 [L]
    # RSS all
    RewriteRule ^phpBB/([a-zA-Z0-9_-]+)-rss([0-9]*)-?(l|s)?-?(m)?\.(xml(\.gz)?)$ /phpBB/rss.php?$1=$2&$3&$4 [L]
    # RSS forum topics
    RewriteRule ^phpBB/.+-rf([0-9]+)-?(l|s)?-?(m)?\.(xml(\.gz)?)$ /phpBB/rss.php?forum=$1&$2&$3 [L]
    # SitemapIndex
    RewriteRule ^phpBB/sitemaps\.(xml(\.gz)?)$ /phpBB/sitemap.php [L]
    # Sitemap modules
    RewriteRule ^phpBB/([a-zA-Z0-9_-]+)-sitemap\.(xml(\.gz)?)$ /phpBB/sitemap.php?$1 [L]
    # Forum Sitemaps
    RewriteRule ^phpBB/.+-gf([0-9]+)\.(xml(\.gz)?)$ /phpBB/sitemap.php?forum=$1 [L]
    # Yahoo! urllist.txt
    RewriteRule ^phpBB/urllist\.(txt(\.gz)?)$ /phpBB/urllist.php [L]
    #########################################################
    # END GYM SITEMAPS AND RSS REWRITE RULES #
    #########################################################
    # SITEMAP SITE XML
    RewriteRule ^phpBB/([a-zA-Z0-9_-]+)-gx\.(xml(\.gz)?)$ /phpbb/sitemap.php?xml=$1&$2&$3 [L]


Comment peut on vérifier que cela fonctionne? Comment faire appel à sitemap.php?
Pour info, mon site c'est : Par ici la détente!
zalf
 
Messages: 26
Inscription: Ven Juil 13, 2007 8:53 pm

Messagede zalf » Sam Juil 14, 2007 11:39 pm

Bon j'ai progressé. J'avais mis dans sitemap.php :
Code: Tout sélectionner
$phpbb_root_path = './phpBB/';
à la place de
Code: Tout sélectionner
$phpbb_root_path = './';


Maintenant, j'ai le message :
Code: Tout sélectionner
Erreur lors du chargement de la feuille de style : Une erreur réseau s'est produite lors du chargement d'une feuille de style XSLT :http://portailvacances.com/phpBB/ggs_style/mxgss.xsl


il va sur
Code: Tout sélectionner
http://portailvacances.com/....
sans les www

Par contre, avec urllist.php et rss.php ca marche bien
zalf
 
Messages: 26
Inscription: Ven Juil 13, 2007 8:53 pm

Messagede zalf » Dim Juil 15, 2007 12:05 am

en fait, il me manque les www partout
Code: Tout sélectionner
<?xml version='1.0' encoding='UTF-8'?>
<?xml-stylesheet type="text/xsl" href="http://portailvacances.com/phpBB/ggs_style/mxgss.xsl"?>
<sitemapindex xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
   xsi:schemaLocation="http://www.sitemaps.org/schemas/sitemap/0.9
   http://www.sitemaps.org/schemas/sitemap/0.9/siteindex.xsd"
   xmlns="http://www.sitemaps.org/schemas/sitemap/0.9">
<!--   Generated by Google Yahoo MSN Sitemaps and RSS v1.2.0RC4 - (C) 2006 dcz - http://www.phpbb-seo.com/ -->

   <sitemap>
      <loc>http://portailvacances.com/phpBB/forum-sitemap.xml</loc>
      <lastmod>2007-07-14T23:33:59+00:00</lastmod>
   </sitemap>
   <sitemap>

      <loc>http://portailvacances.com/phpBB/referencement-gf13.xml</loc>
      <lastmod>2007-07-13T22:19:11+00:00</lastmod>
   </sitemap>
   <sitemap>
      <loc>http://portailvacances.com/phpBB/outils-webmaster-gf4.xml</loc>
      <lastmod>2007-07-07T16:34:05+00:00</lastmod>
   </sitemap>

   <sitemap>
      <loc>http://portailvacances.com/phpBB/google-gf14.xml</loc>
      <lastmod>2007-07-06T20:18:26+00:00</lastmod>
   </sitemap>
   <sitemap>
      <loc>http://portailvacances.com/phpBB/messages-webmaster-gf1.xml</loc>
      <lastmod>2007-07-06T20:04:27+00:00</lastmod>

   </sitemap>
</sitemapindex>
<!-- URL list generated in  0.03064 s  - 5 sql - 5 URLs listed -->
<!--  Output started from cache after 0.00249 s -  sql -->
<!--  Output from cache ended up after 0.00306 s -  sql -->
zalf
 
Messages: 26
Inscription: Ven Juil 13, 2007 8:53 pm

Messagede SeO » Dim Juil 15, 2007 8:14 am

C'est qu'il manque à la config de ton forum, dans l'acp => nom du serveur :www.example.com et pas example.com.
SeO
Admin
Admin
 
Messages: 6334
Inscription: Mer Mar 15, 2006 9:41 pm

Messagede zalf » Dim Juil 15, 2007 8:29 am

C'est fait, maintenant j'ai :
http://portailvacances.com/phpBB/forum-sitemap.xml
2007-07-14T23:33:59+00:00


http://portailvacances.com/phpBB/referencement-gf13.xml
2007-07-13T22:19:11+00:00


http://portailvacances.com/phpBB/outils ... er-gf4.xml
2007-07-07T16:34:05+00:00


http://portailvacances.com/phpBB/google-gf14.xml
2007-07-06T20:18:26+00:00


http://portailvacances.com/phpBB/messag ... er-gf1.xml
2007-07-06T20:04:27+00:00
zalf
 
Messages: 26
Inscription: Ven Juil 13, 2007 8:53 pm

Messagede zalf » Dim Juil 15, 2007 8:45 am

J'ai supprimé le cache et maintenant j'ai ca :

Par contre le style gss_style ne s'applique pas
zalf
 
Messages: 26
Inscription: Ven Juil 13, 2007 8:53 pm

Messagede gowap » Dim Juil 15, 2007 2:50 pm

le fichier actuel n'inclue aucune indication de style vers une feuille xsl. Tu as désactivé l'option dans le panneau de controle du mod ?
Apres chaque modificatio ndes reglages, penses a vider le cache pour etre sur que ce que tu constates correspondent a la derniere version souhaitée des réglages.
Vérifie aussi que le dossier ggstyle a bien été uploadé sur ton serveur
Gravure-News : la communauté francophone de la gravure de CD/DVD et son forum d'entraide.
Avatar de l’utilisateur
gowap
phpBB SEO Team
phpBB SEO Team
 
Messages: 1510
Inscription: Dim Mai 07, 2006 10:56 pm

Messagede zalf » Dim Juil 15, 2007 3:09 pm

tout ca est ok. je comprend pas trop
zalf
 
Messages: 26
Inscription: Ven Juil 13, 2007 8:53 pm

Messagede biloute » Dim Juil 15, 2007 3:31 pm

Il me semble aussi qu'il faut moddé le dossier ggstyle en 777. Tu l'as fais?
Avatar de l’utilisateur
biloute
PR3
PR3
 
Messages: 399
Inscription: Mer Avr 25, 2007 7:18 am

Messagede zalf » Dim Juil 15, 2007 3:40 pm

je viens d'essayer. Après avoir vidé le cache, pareil
zalf
 
Messages: 26
Inscription: Ven Juil 13, 2007 8:53 pm

Messagede dcz » Jeu Juil 19, 2007 9:31 am

Useful links :
SEO Forum || SEO Directory || SEO phpBB || Search
____________________

Liens Utiles :
Forum référencement || Annuaire référencement || Référencement phpBB || Recherche
dcz
Admin
Admin
 
Messages: 21376
Inscription: Ven Avr 28, 2006 9:03 pm

Messagede zalf » Jeu Juil 19, 2007 5:26 pm

Effectivement! je ne comprend pas tout! Il fallait peut être attendre un peu!

Merci en tout cas de m'avoir aidé!

Sinon, je rame pour lancer mon forum, quelqu'un à des conseils?

Bonne soirée
zalf
 
Messages: 26
Inscription: Ven Juil 13, 2007 8:53 pm

Suivante

Retourner vers GYM Sitemaps phpBB2

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Exabot [Bot] et 2 invités