Etrangeté de référencement...

Support et discussions sur les différentes téchniques de réécriture d'url (url rewriting) pour phpBB3 - Olympus.

Modérateur: Modérateurs

Etrangeté de référencement...

Messagede yann.d2 » Jeu Jan 03, 2008 12:36 am

Bonjour à tous,
g installé le mod rewrite sur phpBB3 et ca marche très bien, par contre après plusieurs dances de google je constate que certains sujets qui étaient indexés avant ne le sont plus maintenant et que d'autres qui auraient dus etre indexés ne le sont pas encore...
Je trouve cela très bizarre et ca me fait un peu peur car si seulement quelques sujets sont indexés sur la totalité ca ne va pas attirer grand monde!
Merci pour votre aide !
Voici l'adresse : www.galaxium.fr
yann.d2
 
Messages: 13
Inscription: Jeu Nov 22, 2007 11:36 pm

Publicité

Re: Etrangeté de référencement...

Messagede SeO » Jeu Jan 03, 2008 10:03 am

yann.d2 a écrit:Je trouve cela très bizarre et ca me fait un peu peur car si seulement quelques sujets sont indexés sur la totalité ca ne va pas attirer grand monde!
Merci pour votre aide !


Franchement, ce genre de remarques ...
53 message(s) • 24 sujet(s) • 10 membre(s)


En dit beaucoup plus sur l'intérêt que peu susciter ton forum dans les moteurs de recherche.

On ne parle que d'optimisation du référencement, et donc d'optimisation de quelque chose, en l'occurrence de l'impact de ton contenu.
Le truc le plus important reste et restera le contenu et de la rapidité avec laquelle il est mis à jour.
SeO
Admin
Admin
 
Messages: 6334
Inscription: Mer Mar 15, 2006 9:41 pm

Messagede yann.d2 » Jeu Jan 03, 2008 10:31 am

Je ne comprend pas vraiment ta réponse, je n'ai aucune prétention avec mon forum et je sais qu'avec encore si peu de message et de contenu je n'ai pas a en avoir. Ce n'était pas le sujet de mon message, je voulais juste savoir pourquoi il y a deux semaines certains sujets étaient déjà référencé alors qu'aujourd'hui ils ont disparus. Mais encore une fois ce n'est qu'une question purement technique et je ne voulais choquer personne :?
yann.d2
 
Messages: 13
Inscription: Jeu Nov 22, 2007 11:36 pm

Messagede SeO » Jeu Jan 03, 2008 11:13 am

ca ne va pas attirer grand monde!

Je te disais juste que c'est du contenu dont tu as besoin, le reste suivra ;)
SeO
Admin
Admin
 
Messages: 6334
Inscription: Mer Mar 15, 2006 9:41 pm

Messagede yann.d2 » Ven Jan 04, 2008 2:54 pm

Pour ca c'est indéniable, je suis entièrement d'accord, je me demandais juste si d'autres avaient eu le même problème que moi. Apparement ca viendrait de google car je ne vois pas pourquoi certains sujets seraient indexés et pas d'autres... M'enfin si quelqu'un a eu le même problème que moi et qu'il a trouvé une solution qu'il parle maintenant ou qu'il se taise à tout jamais :lol:
yann.d2
 
Messages: 13
Inscription: Jeu Nov 22, 2007 11:36 pm

Messagede SeO » Sam Jan 05, 2008 11:58 am

Donc, je viens de voir un truc qui aide pas, tu n'as pas mis en place le robots.txt comme expliqué dans l'installe et le sujet de mise à disposition, et du coup, il y a plein de postxx.html dans l'index de google :

http://www.google.fr/search?q=site%3Awww.galaxium.fr

Comme les url de messages sont des duplicates des url de sujet, les moteurs de recherche n'aiment pas.

Du coup, il faut que tu installes /actives le zéro duplicate, et que tu mettes la redirection des messages au moins sur "Invités" pour rétablir la situation.

Attend environ un mois avant de mettre en place le robots.txt, histoire de rediriger avant d'interdire.
SeO
Admin
Admin
 
Messages: 6334
Inscription: Mer Mar 15, 2006 9:41 pm

Messagede yann.d2 » Sam Jan 05, 2008 12:59 pm

Merci beaucoup pour ta réponse :D
Je me disais bien que c'était bizarre ces url en postxxx.html mais je ne savais pas quoi faire pour les enlever.
Donc si j'ai bien compris j'installe le mod zero duplicate et ensuite je fais la redirection des url en post vers les vrais titre, je suppose que cette redirection est possible après l'installation de zero duplicate ?
Merci encore pour ton aide !!!!
yann.d2
 
Messages: 13
Inscription: Jeu Nov 22, 2007 11:36 pm

Messagede yann.d2 » Sam Jan 05, 2008 1:15 pm

Je suis en train d'installer le mod zero dupe et je butte sur la modif du fichier search.php, je ne trouve pas la ligne
$author = empty($author) ? $author_name : $author;
et du coup je ne sais pas ou ajouter la modif.
Peut-être cela vient il du fait que j'ai phpbb3 final et non pas une version test....
yann.d2
 
Messages: 13
Inscription: Jeu Nov 22, 2007 11:36 pm

Messagede SeO » Sam Jan 05, 2008 1:52 pm

Ça veut dire que tu n'utilises pas la dernière version du mod de réécriture d'url, met à jour avant, c'est mieux.
SeO
Admin
Admin
 
Messages: 6334
Inscription: Mer Mar 15, 2006 9:41 pm

Messagede yann.d2 » Sam Jan 05, 2008 3:52 pm

Je suis allé voir et il me semble bien avoir la dernière, c'est la RC 0.4.0 qui est installée sur mon forum.
Sinon quel est le risque de placer le robots.txt tout de suite ? D'ailleurs j'ai un doute sur l'endroit ou le placer, c'est bien à la racine du forum ??
Désolé mais je suis vraiment un noob dans le domaine :cry:
yann.d2
 
Messages: 13
Inscription: Jeu Nov 22, 2007 11:36 pm

Messagede SeO » Sam Jan 05, 2008 4:31 pm

Si tu l'avais, tu trouverais ce code dans search.php.
Vérifie le fichier search.php avec l'installe du mod rewrite au cas ou tu as loupé quelque chose.

Il est peut être temps de poster dans le forum du zéro dupe si tu n'y arrives pas.
SeO
Admin
Admin
 
Messages: 6334
Inscription: Mer Mar 15, 2006 9:41 pm


Retourner vers mod Rewrite phpBB

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 4 invités