Problème lien "index du forum" board3

Support et discussions sur les différentes téchniques de réécriture d'url (url rewriting) pour phpBB3 - Olympus.

Modérateur: Modérateurs

Problème lien "index du forum" board3

Messagede norbert » Dim Juil 12, 2009 6:47 pm

Bonjour,

je viens de passer le mod board3 ainsi que les modifs donnés ici pour ce board3. J'ai modifié en consequence le phpbb_seo_class index =>forum et ça fonctionne, sauf sur le lien de la page du portail "index du forum" qui me met un lien vers / et non vers forum.

D'autre part, lorsque je clique sur le lien news du bas de page du portail, ça m'affiche "aucune news" alors que le forum est actif.

Merci de votre aide.

ps : pour le moment, j'ai mis le lien en dur sur le portail.

;-)

forum : http://www.francedidgeridoo.com
norbert
PR0
PR0
 
Messages: 87
Inscription: Mer Sep 20, 2006 7:12 am

Publicité

Re: Problème lien "index du forum" board3

Messagede dcz » Lun Juil 13, 2009 5:19 pm

Si tu utilises bien le mod Ultimate SEO URL, alors tu devrais modifier phpbb_seo/includes/setup_phpbb_seo.php plutôt que phpbb_seo_class.php pour régler le problème du lien vers le forum.
Cela dit, je ne vois aucun problème de lien vers celui-ci.

Concernant la page news, assure toi que l'url fournie comme source (ACP => phpBB SEO => Pages HTML => Paramètres des news) sur l'option "URL de la source rss de la page news principale" est correcte et qu'elle fonctionne.

++
Useful links :
SEO Forum || SEO Directory || SEO phpBB || Search
____________________

Liens Utiles :
Forum référencement || Annuaire référencement || Référencement phpBB || Recherche
dcz
Admin
Admin
 
Messages: 21429
Inscription: Ven Avr 28, 2006 9:03 pm

Re: Problème lien "index du forum" board3

Messagede norbert » Lun Juil 13, 2009 6:06 pm

Pour le moment ça fonctionne avec la modif dans phpbb-seo-class.php (index->forum)Si je clique sur index dans une page du forum, je suis bien renvoyé vers /forum.html. Que faut-il modifier dans le setup_phpbb_seo.php pour arriver au même resultat ?
Pour le moment sur mon portail j'ai inscrit en dur le lien index vers /forum.html c'est pour cela que ça fonctionne.

Sinon j'ai vérifié mon lien news sous mon acp : francedidgeridoo.com/gymrss.php?news&digest .Ca fonctionne.

En revanche le lien "news" que j'ai en bas de chaque page me renvoie vers http://www.francedidgeridoo.com/news/ et là je n'ai pas de news d'affiché.

Merci
norbert
PR0
PR0
 
Messages: 87
Inscription: Mer Sep 20, 2006 7:12 am

Re: Problème lien "index du forum" board3

Messagede dcz » Ven Juil 17, 2009 7:39 am

Pour la modif de setup_phpbb_seo.php, c'est expliqué dans l'installe.

Pour la page news, c'est peut être un souci de l'option allow_fopen du php.ini, car le flux est récupéré par file_get_contents. Regardes dans le phpinfo de ton acp. Et essaye aussi de vider le cache de phpBB pour voir.

++
Useful links :
SEO Forum || SEO Directory || SEO phpBB || Search
____________________

Liens Utiles :
Forum référencement || Annuaire référencement || Référencement phpBB || Recherche
dcz
Admin
Admin
 
Messages: 21429
Inscription: Ven Avr 28, 2006 9:03 pm

Re: Problème lien "index du forum" board3

Messagede norbert » Ven Juil 17, 2009 5:09 pm

Oui j'ai trouvé; comme j'ai passé de la 3.0.4 à la 3.0.5, je n'avais pas ce fichier explicatif d'install, mais je l'ai trouvé dans la version compléte.

Pour les news, j'ai jeté un coup d'oeil, on parle bien de allow_url_fopen ? si oui, il est sur off chez moi.
J'ai bien vidé le cache aussi mais pas de changement.

Merci de tes réponses en tout cas :wink:
norbert
PR0
PR0
 
Messages: 87
Inscription: Mer Sep 20, 2006 7:12 am

Re: Problème lien "index du forum" board3

Messagede dcz » Sam Juil 18, 2009 9:40 am

norbert a écrit:on parle bien de allow_url_fopen ? si oui, il est sur off chez moi.

Oui, et donc, ceci explique cela.

++
Useful links :
SEO Forum || SEO Directory || SEO phpBB || Search
____________________

Liens Utiles :
Forum référencement || Annuaire référencement || Référencement phpBB || Recherche
dcz
Admin
Admin
 
Messages: 21429
Inscription: Ven Avr 28, 2006 9:03 pm

Re: Problème lien "index du forum" board3

Messagede norbert » Sam Juil 18, 2009 10:04 am

Effectivement en mettant sur on, tout de suite ça marche mieux.

Merci beaucoup de ton aide dcz. A chaque fois, tu as répondu à mes problèmes.

Respect.

;-)
norbert
PR0
PR0
 
Messages: 87
Inscription: Mer Sep 20, 2006 7:12 am


Retourner vers mod Rewrite phpBB

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 8 invités