[Résolu] Multiples erreurs avec ultimate SEO

Support et discussions sur les différentes téchniques de réécriture d'url (url rewriting) pour phpBB3 - Olympus.

Modérateur: Modérateurs

[Résolu] Multiples erreurs avec ultimate SEO

Messagede Guenchou » Sam Oct 31, 2009 11:26 am

Bonjour à tous,

Voila, après plusieurs jours à avoir essayé des dizaines de solutions, de changements, de possibilités, et à avoir cherché la solution à mes problemes sur votre forum, google etc... je n'y arrive pas et non seulement je ne comprends pas pourquoi mais je desespere vraiment de faire marcher ce super mod...

Je vais essayer de vous donner le max d'info utile pour que vous puissiez voir là ou le bas blesse.

Tout d'abord mon hebergeur est 1and1. Mon forum est http://www.debosselagesanspeinture.net. Il est installé dans le répertoire racine/phpBB3/. Mon NDD pointant vers phpBB3/.

PhpBB est en version 3.0.5 et j'utilise la derniere version de ultimate. J'ai quelques mods d'installé : Board portal3, Hoteditor et Phoogle Map.

Voici ma configuration serveur :

Image


Voici ma configuration cookie :

Image


- Le premier problème qui se pose est que lorsque j'active le rewrite en mode intermédiaire ou avancé, je perds tous les grapisme, tout le style et je me retrouve avec un forum blanc avec des liens comme ceci :

Image

A noter que cela ne me le fait pas en mode "Simple".


Et sinon mon autre gros problème est que comme bien souvent tous mes liens passent en erreur 404. A priori si j'ai bien compris cela vient soit de la config serveur/cookie, soit de mon htaccess.

Pour ce qui est des configs, je n'y vois pas de probleme, mais avec mes copie d'ecran vous allez peut etre en deceler.

Sinon pour ce qui est du htaccess, j'a du essayé quasiement toutes les possibilités à savoir :

Un "normal" à la racine => 404, alors un "normal dans le dossier phpBB3/ => 404 aussi, alors j'ai essayé de jouer sur les slash et sur les deux possibilités. Rien ne change.
J'ai aussi essayé la derniere option le htaccess pour le dossier phpbb, mais cela n'a rien changé (cette option n'est active que dans le mode simple d'ailleurs c'est peut etre normal).

J'ai aussi essayé de faire pointé mon NDD vers la racine avec un htaccess, mais là c'etait erreur 403.

J'ai bien sur essayé aussi divers htaccess, simple, intermediaire, avancé, mais cela malheureusement en vain.

J'ai syncronisé plein de fois les url, vidé je ne sais combien de fois tous les caches etc...

Je vous mets une copie d'un des multiples htaccess que j'ai, mais celui que je voudrai mettre :

Code: Tout sélectionner

# Lines That should already be in your .htacess
<Files "config.php">
Order Allow,Deny
Deny from All
</Files>
<Files "common.php">
Order Allow,Deny
Deny from All
</Files>

# You may need to un-comment the following lines
# Options +FollowSymlinks
# To make sure that rewritten dir or file (/|.html) will not load dir.php in case it exist
# Options -MultiViews
# REMEBER YOU ONLY NEED TO STARD MOD REWRITE ONCE
RewriteEngine On
# REWRITE BASE
RewriteBase /
# HERE IS A GOOD PLACE TO FORCE CANONICAL DOMAIN
# RewriteCond %{HTTP_HOST} !^www\.debosselagesanspeinture\.net$ [NC]
# RewriteRule ^(.*)$ http://www.debosselagesanspeinture.net/$1 [QSA,L,R=301]

# DO NOT GO FURTHER IF THE REQUESTED FILE / DIR DOES EXISTS
RewriteCond %{REQUEST_FILENAME} -f
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule . - [L]
#####################################################
# PHPBB SEO REWRITE RULES ALL MODES
#####################################################
# AUTHOR : dcz www.phpbb-seo.com
# STARTED : 01/2006
#################################
# FORUMS PAGES
###############
# FORUM INDEX
RewriteRule ^forum\.html$ /phpBB3/index.php [QSA,L,NC]
# FORUM ALL MODES
RewriteRule ^(forum|[a-z0-9_-]*-f)([0-9]+)/?(page([0-9]+)\.html)?$ /phpBB3/viewforum.php?f=$2&start=$4 [QSA,L,NC]
# TOPIC WITH VIRTUAL FOLDER ALL MODES
RewriteRule ^(forum|[a-z0-9_-]*-f)([0-9]+)/(topic|[a-z0-9_-]*-t)([0-9]+)(-([0-9]+))?\.html$ /phpBB3/viewtopic.php?f=$2&t=$4&start=$6 [QSA,L,NC]
# GLOBAL ANNOUNCES WITH VIRTUAL FOLDER ALL MODES
RewriteRule ^annonces/(topic|[a-z0-9_-]*-t)([0-9]+)(-([0-9]+))?\.html$ /phpBB3/viewtopic.php?t=$2&start=$4 [QSA,L,NC]
# TOPIC WITHOUT FORUM ID & DELIM ALL MODES
RewriteRule ^([a-z0-9_-]*)/?(topic|[a-z0-9_-]*-t)([0-9]+)(-([0-9]+))?\.html$ /phpBB3/viewtopic.php?forum_uri=$1&t=$3&start=$5 [QSA,L,NC]
# PHPBB FILES ALL MODES
RewriteRule ^ressources/[a-z0-9_-]+/(thumb/)?([0-9]+)$ /phpBB3/download/file.php?id=$2&t=$1 [QSA,L,NC]
# PROFILES THROUGH USERNAME
RewriteRule ^membre/([^/]+)/?$ /phpBB3/memberlist.php?mode=viewprofile&un=$1 [QSA,L,NC]
# USER MESSAGES THROUGH USERNAME
RewriteRule ^membre/([^/]+)/(topics|posts)/?(page([0-9]+)\.html)?$ /phpBB3/search.php?author=$1&sr=$2&start=$4 [QSA,L,NC]
# GROUPS ALL MODES
RewriteRule ^(groupe|[a-z0-9_-]*-g)([0-9]+)(-([0-9]+))?\.html$ /phpBB3/memberlist.php?mode=group&g=$2&start=$4 [QSA,L,NC]
# POST
RewriteRule ^post([0-9]+)\.html$ /phpBB3/viewtopic.php?p=$1 [QSA,L,NC]
# ACTIVE TOPICS
RewriteRule ^sujets-actifs(-([0-9]+))?\.html$ /phpBB3/search.php?search_id=active_topics&start=$2&sr=topics [QSA,L,NC]
# UNANSWERED TOPICS
RewriteRule ^sans-reponses(-([0-9]+))?\.html$ /phpBB3/search.php?search_id=unanswered&start=$2&sr=topics [QSA,L,NC]
# NEW POSTS
RewriteRule ^nouveaux-messages(-([0-9]+))?\.html$ /phpBB3/search.php?search_id=newposts&start=$2&sr=topics [QSA,L,NC]
# THE TEAM
RewriteRule ^equipe\.html$ /phpBB3/memberlist.php?mode=leaders [QSA,L,NC]
# HERE IS A GOOD PLACE TO ADD OTHER PHPBB RELATED REWRITERULES

# FORUM WITHOUT ID & DELIM ALL MODES (SAME DELIM)
# THESE THREE LINES MUST BE LOCATED AT THE END OF YOUR HTACCESS TO WORK PROPERLY
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^([a-z0-9_-]+)/?(page([0-9]+)\.html)?$ /phpBB3/viewforum.php?forum_uri=$1&start=$3 [QSA,L,NC]
# END PHPBB PAGES
#####################################################



Mes deux derniers soucis (de moindre importance par rapport aux 2 premiers) :

- Comme j'utilise Board Portal3, j'ai fais la modif au fichier setup_phpb_seo.php comme expliqué dans le fichier d'install. J'ai fais aussi les modifications donnés dans un topic de ce forum, mais mon forum ne pointe plus du tout sur le portail, mais sur l'index, que le mod soit activé ou non... Comment faire pour qu'il repointe d'abord sur le portail ?

- Enfin, que le mod soit activé ou non, l'image en bas du copyright ne veut pas s'afficher, je ne sais pourquoi...

Merci enormément par avance parce que là, ca dépasse mes compétences... :oops:
Dernière édition par Guenchou le Mar Nov 03, 2009 3:15 pm, édité 1 fois.
Guenchou
 
Messages: 10
Inscription: Mar Oct 27, 2009 4:53 pm

Publicité

Re: Multiples erreurs avec ultimate SEO [mode dédespéré]

Messagede zach » Dim Nov 01, 2009 12:24 am

Ecoute je sais pas si ca va aider mais peut etre 2 choses :

si tu fait pointer le ndd directement sur phpBB3/ mais que tu dit que le chemin du script à partir du ndd doit aussi aller à phpBB3/ ca semble un peu bizarre,

Donc je ne ferais pas pointer le ndd sur le répertoire (de préférence) ou j'enleverais phpBB3/ du chemin du script

a tester

sinon pour le graphisme cassé, faudrait essayer de rafraichir le style, vider le cache forum, navigateur, si ca persiste ca doit etre une mauvaise modif d'une balise, type div, qui fait que le style css peut sauter, donc verifier les fichiers css, et templates modifiés
zach
PR4
PR4
 
Messages: 404
Inscription: Ven Oct 17, 2008 4:00 pm
Localisation: France sud est

Re: Multiples erreurs avec ultimate SEO [mode dédespéré]

Messagede dcz » Dim Nov 01, 2009 12:57 pm

Ton .htaccess est fait pour être utilisé à la racine de ton domaine avec l'option racine virtuelle, je ne sais pas si c'est ce que tu eu vraiment (tu pourrais aussi installer phpBB à la racine direct ou au moins ne pas utiliser phpBB3/ comme dossier, c'est un peu dommage comme mot clé).
M'enfin, d'après ce que je vois en ligne, phpBB est bien installé à la racine du domaine, il faut donc rien mettre dans la case chemin du script.

Et pour le style, et bien, c'est normal avec l'option dossier virtuel (et d'ailleurs, ton .htaccess à forcément marché à un moment ou un autre pour que tu vois ça) si tu n'as pas modifié convenablement tous tes styles comme expliqué dans l'installe. Si tu utilises un style autre que les deux fournit par défaut, il va falloir que tu détermine duquel il est le plus proche et que tu essayes d'y installer les modifs de celui-ci. En général, ça passe nickel, les modifs sont assez légères.

++
Useful links :
SEO Forum || SEO Directory || SEO phpBB || Search
____________________

Liens Utiles :
Forum référencement || Annuaire référencement || Référencement phpBB || Recherche
dcz
Admin
Admin
 
Messages: 21376
Inscription: Ven Avr 28, 2006 9:03 pm

Re: Multiples erreurs avec ultimate SEO [mode dédespéré]

Messagede Guenchou » Dim Nov 01, 2009 7:54 pm

Je tiens à vous remercier pour vos réponses qui m'ont permis de voir ce qui n'allait pas alors que j'en étais completement incapable.

En effet, la premiere modif que j'ai faite à été d'enlever le chemin /phpbb3 du script des parametres serveur, et ça a réglé tout les problemes de 404, mais aussi tous les problemes dûs au style, fond, et même la petite image de phpbb seo. Bref ce truc là avait reussi à mettre un bon boxon.

Chapeau Messieurs ! :D

Sinon à vrai dire il me reste un soucis, moins grave, c'est que mon portail ne sert plus à grand chose. J'aimerai en fait que l'on tombe dessus en premier lieu. Comment faire ? :oops: (je pense que cela ne doit pas etre compliqué mais un peu trop pour moi qui débute dans le domaine).

A savoir que j'ai fais la modif décrite dans l'install et les modifs données sur ce forum pour le mod portal board3.


Dcz, j'ai pas changé de place tout mon forum pour le mettre à la racine car j'ai peur que cela soit trop compliqué pour moi (j'ai peur qu'il y ait plein de code à changer surtout parmi les mods). Est-ce vraiment une grosse perte ?

Merci encore à vous ! :mrgreen:
Guenchou
 
Messages: 10
Inscription: Mar Oct 27, 2009 4:53 pm

Re: Multiples erreurs avec ultimate SEO [mode dédespéré]

Messagede Guenchou » Mar Nov 03, 2009 12:17 pm

Bon j'ai reussi à regler le probleme du portail ! :D Tous les problemes initiaux sont réglés !

Par contre maintenant j'ai un nouveau soucis (oui, désolé :oops: ).

Il s'agit d'erreur 404 lorsque j'utilise la petite icone qui permet d'aller voir les derniers messages, mais seulement lorsque l'on est deja dans la catégorie "Voir les messages sans réponses", "Voir les nouveaux messages" et "Voir les sujets récents".

Sinon sur l'index cette icone mene correctement aux derniers messages.

A savoir que mon probleme ressemble énormément à celui-ci : Lien dernier message HS seulement mon forum est à jour (3.0.5).

Si vous avez une indée d'où pourrait venir ce probleme ? (dois je creer un nouveau topic pour ce probleme differents des premiers ?)

Merci d'avance ! :oops:
Guenchou
 
Messages: 10
Inscription: Mar Oct 27, 2009 4:53 pm

Re: Multiples erreurs avec ultimate SEO [mode dédespéré]

Messagede zach » Mar Nov 03, 2009 2:51 pm

Peut etre en mettant [Résolu] au lieu de [mode désespéré] :mrgreen: , et d'ouvrir un sujet spécifique ferais gagner en lisibilité pour ce nouveau prb je pense :D
zach
PR4
PR4
 
Messages: 404
Inscription: Ven Oct 17, 2008 4:00 pm
Localisation: France sud est

Re: Multiples erreurs avec ultimate SEO [mode dédespéré]

Messagede Guenchou » Mar Nov 03, 2009 3:14 pm

Tu as raison ;)
Guenchou
 
Messages: 10
Inscription: Mar Oct 27, 2009 4:53 pm

Re: [Résolu] Multiples erreurs avec ultimate SEO

Messagede dcz » Lun Nov 09, 2009 10:38 am

Si ton forum se trouve encore physiquement dans un sous dossier, le nom de ce sous dossier devrait continuer d'apparaitre dans la config serveur.

Pour le lien dernier message, pourrais-tu poster une URL pour voir ?
Tu pourrais aussi comparer ton search.php avec le pré-modifié fournit dans contrib/, tu as peut être oublier un truc lors de l'install ou d'une précédente maj.
Useful links :
SEO Forum || SEO Directory || SEO phpBB || Search
____________________

Liens Utiles :
Forum référencement || Annuaire référencement || Référencement phpBB || Recherche
dcz
Admin
Admin
 
Messages: 21376
Inscription: Ven Avr 28, 2006 9:03 pm


Retourner vers mod Rewrite phpBB

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 15 invités


 
cron