Non validité XHTML avec Dynamic Meta Tags 0.2.0 RC

Forum consacré aux codes conseillés ou mis à disposition sur phpBB SEO dans le forum Toolkit phpBB SEO. Support, téléchargements, conseils ...

Modérateur: Modérateurs

Non validité XHTML avec Dynamic Meta Tags 0.2.0 RC

Messagede Xaphos » Jeu Aoû 02, 2007 8:40 pm

Bonjour,

Je viens d'installer les solutions SEO pour phpBB3 et tout marche parfaitement, beau travail :) !

Cependant, j'ai remarqué un petit relâchement sur la validité XHTML du MOD Meta Tags 0.2.0 RC (et Advanced MOD Rewrite 0.2.0 RC3, mais je l'ai posté dans la bonne catégorie), et c'est plutôt gênant avec phpBB3 (pour une fois que dans l'histoire de phpBB on a du valide XHTML :P ).

J'apporte le petit fix à apporter pour corriger ce petit oubli, qui n'est pas très grave en lui-même, mais qu'il est bien de corriger quand même :

Code: Tout sélectionner
#
#-----[ OPEN ]------------------------------------------
#

includes/functions.php

#
#-----[ FIND ]------------------------------------------
#

   $seo_meta['meta_tpl'] =  '<meta name="title" content="%s">' . "\n" . '<meta name="description" lang="%s" content="%s">' . "\n" . '<meta name="keywords"    content="%s">' . "\n" . '<meta name="category"    content="%s">' . "\n" . '<meta name="robots"      content="%s">'. "\n" . '<meta name="distribution" content="%s">' . "\n" . '<meta name="resource-type" content="%s" />' . "\n" . '<meta name="copyright" content="%s">';

#
#-----[ REPLACE WITH ]------------------------------------------
#

   $seo_meta['meta_tpl'] =  '<meta name="title" content="%s" />' . "\n" . '<meta name="description" lang="%s" content="%s" />' . "\n" . '<meta name="keywords"    content="%s" />' . "\n" . '<meta name="category"    content="%s" />' . "\n" . '<meta name="robots"      content="%s" />'. "\n" . '<meta name="distribution" content="%s" />' . "\n" . '<meta name="resource-type" content="%s" />' . "\n" . '<meta name="copyright" content="%s" />';

#
#-----[ SAVE/CLOSE ALL FILES ]------------------------------------------
#
# EoM


En espérant avoir pu aider :) .



Xaphos.
Avatar de l’utilisateur
Xaphos
 
Messages: 4
Inscription: Jeu Aoû 02, 2007 8:21 pm
Localisation: Lourdes, France

Publicité

Messagede dav.bo » Ven Aoû 03, 2007 9:26 am

Bonjour, merci, c'est juste un léger oubli, d'un autre coté, y a pas grand chose a changer, juste a remettre une règle élémentaire du /.
++
Avatar de l’utilisateur
dav.bo
phpBB SEO Team
phpBB SEO Team
 
Messages: 90
Inscription: Ven Nov 17, 2006 6:13 am
Localisation: 08/51 FR

Messagede Xaphos » Ven Aoû 03, 2007 12:42 pm

Oui comme je dis dis c'est juste des petits problèmes de validité XHTML, donc y'a pas grand chose à changer, mais bon, c'est à changer (comme les target dans les liens, la validité W3C n'aime pas ça :P ).
Avatar de l’utilisateur
Xaphos
 
Messages: 4
Inscription: Jeu Aoû 02, 2007 8:21 pm
Localisation: Lourdes, France

Messagede dcz » Ven Aoû 03, 2007 5:33 pm

Les target, je trouve ça discutable, et surtout, ils marchent de la façon attendu au moins avec FF, IE et Opéra.

Franchement, je vois pas vraiment le problème avec les target, surtout avec des navigateur à onglets. Mise à part de ne pas pouvoir mettre le liens Valide W3C.

Pour les métas, c'est clair qu'autant faire du valide, dans la prochaine mise à jour donc ;)

Et merci pour la remontée d'information.

++
Useful links :
SEO Forum || SEO Directory || SEO phpBB || Search
____________________

Liens Utiles :
Forum référencement || Annuaire référencement || Référencement phpBB || Recherche
dcz
Admin
Admin
 
Messages: 21407
Inscription: Ven Avr 28, 2006 9:03 pm


Retourner vers MODS phpBB SEO

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 2 invités


 
cron