(aide) phpbb gallery 0.4.0-RC1

Forum consacré aux codes conseillés ou mis à disposition sur phpBB SEO dans le forum Toolkit phpBB SEO. Support, téléchargements, conseils ...

Modérateur: Modérateurs

Messagede Eco-Citoyen » Mar Déc 16, 2008 8:52 am

jcg11290 a écrit:Il me semble qu'un patch est cours d'élaboration pour "phpbb gallery 0.4.0"..
Oui dcz en avait parlé et je l'attends avec impatience ! :wink:
jcg11290 a écrit:Si tu ne vois pas tes photos il y a 2 possibilités: soit tu ne les as pas transféré dans le dossier de "gallery" et/ou tu n'as pas activé et donné les permissions à tes albums dans l'acp.

J'ai fait un test en local en mettant tous les utilisateurs (membres, invités, modos, etc) sur "yes" au niveau des permissions et mon problème persiste !

SInon, effectivement, je n'avais pas copié les images de l'ancienne vers la nouvelle gallerie ! :oops: !
Je les ai donc copiées dans :
.../phpbb3/gallery/images/
Mais rien n'y fait, j'ai le même problème !

Après l'installation et la conversion de ce MOD gallery, la dernière page d'installation nous conseille deux choses :
- mettre les permissions
- et "cleanup" la gallery !!
Peut-être n'aurais-je pas dû la "cleanup" ou cela n'a pas d'importance ? :oops:

Merci :wink:
Ecocitoyenneté et Environnement
Eco-Citoyen.org||Forum Eco-Citoyen||Site Joomla
Avatar de l’utilisateur
Eco-Citoyen
PR2
PR2
 
Messages: 263
Inscription: Lun Oct 09, 2006 9:20 pm
Localisation: Californie

Publicité

Messagede jcg11290 » Mar Déc 16, 2008 9:45 am

Salut,

Pour le "cleanup", je n'ai pas encore testé.. je vais le faire d'ailleurs..

Par contre, j'avais eu aussi le même problème que toi "no image" et j'ai modifié une permission et elle est apparue.. le problème, c'est que je ne sais plus ce que j'ai fait.. :oops:

Je fais des essais et te tiens au courant..

:wink:
Avatar de l’utilisateur
jcg11290
phpBB SEO Team
phpBB SEO Team
 
Messages: 902
Inscription: Lun Juin 19, 2006 4:11 pm
Localisation: Carcassonne(11)

Messagede yachiro » Mar Déc 16, 2008 7:41 pm

jcg11290 :
As-tu revérifier ton install pour la page "index gallery. "..


J'ai tout refais.J'ai réinstallé le mod mais ca donne toujours un probleme d'affichage de la page index de la gallerie :cry:
Je suis persuadé que c'est un problème de rewriting :?
yachiro
 
Messages: 21
Inscription: Jeu Aoû 07, 2008 12:16 am

Messagede Eco-Citoyen » Mar Déc 16, 2008 8:06 pm

yachiro a écrit:Je suis persuadé que c'est un problème de rewriting :?
Apparemment, la premod et la gallery non-rewritée fonctionne bien ensemble ... selon LagunaPower en tout cas sur son forum !
http://www.phpbb-seo.com/forums/le-foru ... html#32811

:?
Ecocitoyenneté et Environnement
Eco-Citoyen.org||Forum Eco-Citoyen||Site Joomla
Avatar de l’utilisateur
Eco-Citoyen
PR2
PR2
 
Messages: 263
Inscription: Lun Oct 09, 2006 9:20 pm
Localisation: Californie

Messagede joebart » Mer Déc 17, 2008 12:03 am

Eco-Citoyen a écrit:
yachiro a écrit:Je suis persuadé que c'est un problème de rewriting :?
Apparemment, la premod et la gallery non-rewritée fonctionne bien ensemble ... selon LagunaPower en tout cas sur son forum !
http://www.phpbb-seo.com/forums/le-foru ... html#32811

:?


Comme qui dirait, déjà dit car ça marche chez moi aussi sans le moindre problème :

joebart a écrit:Le mod rewrite 0.4.6 et phpBB gallery 0.4.0 marchent très bien ensemble sans même qu'il ne soit nécessaire de faire le moindre correctif sur phpbb_seo_class.php.
Avatar de l’utilisateur
joebart
PR3
PR3
 
Messages: 313
Inscription: Ven Déc 22, 2006 8:30 pm

Messagede Laurent85 » Mer Déc 17, 2008 9:10 am

pour le clean up, il semble qu'il y ait encore des soucis à ce niveau , pour moi il me disait que j'avais des images sans fichiers photos alors qu'elles y étaient j'ai donc supprimé les entrées du cleanup manuellement , par phpmyadmin.
Avatar de l’utilisateur
Laurent85
PR1
PR1
 
Messages: 186
Inscription: Lun Fév 18, 2008 11:33 pm

Messagede SeO » Mer Déc 17, 2008 9:19 am

@yachiro je pense que cela viens du fait que tu utilises l'option racine virtuelle.

Ajoutes :
Code: Tout sélectionner
      if (strpos($this->seo_opt['req_self'], GALLERY_ROOT_PATH) !== false) {
         $this->seo_opt['file_hbase']['index'] = $this->seo_opt['file_hbase']['search'] = $this->seo_path['phpbb_url'] . GALLERY_ROOT_PATH;
      }


avant :
Code: Tout sélectionner
      if ( $this->seo_opt['url_rewrite'] && !defined('ADMIN_START') && isset($this->seo_opt['file_hbase'][$this->seo_opt['req_file']])) {   
         $this->seo_opt['seo_base_href'] = '<base href="' . $this->seo_opt['file_hbase'][$this->seo_opt['req_file']] . '"/>';
      }


dans phpbb_seo/phpbb_seo_class.php, ça devrait régler le problème ;)
SeO
Admin
Admin
 
Messages: 6334
Inscription: Mer Mar 15, 2006 9:41 pm

Messagede yachiro » Mer Déc 17, 2008 6:29 pm

le problème de réecriture est résolu .
J'ai néanmoins un souci d'affichage du mod qui n'as pa l'air adapté au thème de mon forum.
Merci bcp pour l'aide :wink:

:arrow: Edit : probleme d'affichage résolu.C'était un souci de permissions.
yachiro
 
Messages: 21
Inscription: Jeu Aoû 07, 2008 12:16 am

Re: (aide) phpbb gallery 0.4.0-RC1

Messagede Laurent85 » Sam Mar 28, 2009 1:05 am

Lu , juste un petit up pour savoir si votre patch est toujours d'actualité pour la gallery ?
Avatar de l’utilisateur
Laurent85
PR1
PR1
 
Messages: 186
Inscription: Lun Fév 18, 2008 11:33 pm

Re: (aide) phpbb gallery 0.4.0-RC1

Messagede Laurent85 » Mar Avr 21, 2009 5:35 pm

lu

je viens de tomber sur le site d'un membre de l'équipe phpbb-seo qui a une gallery réécrite :mrgreen: je ne sais pas si c'est ce dont veut parler dcz dans un autre topic mais rien que d'être tombé sur ce site , ma soirée va être bonne :mrgreen:

j'imagine que vous êtes en béta , s'il vous faut d'autres testeurs je suis à votre disposition :idea:
Avatar de l’utilisateur
Laurent85
PR1
PR1
 
Messages: 186
Inscription: Lun Fév 18, 2008 11:33 pm

Re: (aide) phpbb gallery 0.4.0-RC1

Messagede dcz » Lun Juil 27, 2009 5:10 pm

Useful links :
SEO Forum || SEO Directory || SEO phpBB || Search
____________________

Liens Utiles :
Forum référencement || Annuaire référencement || Référencement phpBB || Recherche
dcz
Admin
Admin
 
Messages: 21376
Inscription: Ven Avr 28, 2006 9:03 pm

Précédente

Retourner vers MODS phpBB SEO

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 11 invités


 
cron