Le thème du forum sur le portail

Forum consacré à mxBB PORTAL. lui même. Comment tirer le meilleur de ce Portail si pratique.

Modérateur: Modérateurs

Messagede olijack » Mar Mai 08, 2007 7:15 pm

salut tout le monde

Voila une solution qui avec quelques améliorations pourrait devenir une sorte de tutos dcz si tu m'entends :D :wink:

Créez un dossier dans le templates de mxBB et nommez le du même nom que le thème que vous utilisez dans le templates de phpBB

Dans ce nouveau dossier collez tous les dossiers et fichier qui ce trouve dans le templates subSilver de mxBB

Toujours dans ce nouveau dossier cherchez les fichiers subSilver.cfg et subSilver.ccs pour les renommez du nom du nouveau thème

Ouvrir le dossiers images du nouveau thème phpBB copiez tout et collez tout dans le dossier image de votre nouveau thème mxBB

Ouvrir overall_header.tpl de votre nouveau thème mxBB et cherchez
Code: Tout sélectionner
<a name="top"></a>

<table width="100%" cellspacing="0" cellpadding="1" border="0" align="center" class="mx_main_table">
   <tr>
      <td class="bodyline">

         <table width="100%" cellspacing="0" cellpadding="2" border="0" class="mx_header_table">
            <tr>
               <td class="row2" width="25%" align="left" valign="top"><a href="{U_INDEX}"><img src="{U_PORTAL_ROOT_PATH}{TEMPLATE_ROOT_PATH}images/logo.gif" border="0" alt="{L_INDEX}" vspace="1"/></a></td>
               <td class="row2" width="50%" align="center" valign="middle">{PAGE_ICON}<span class="pagetitle">{PAGE_TITLE}</span></td>
               <td class="row2" width="25%" align="right" valign="top"><span class="sitetitle"><b>{SITENAME}</b></span><br /><span class="sitetitle_desc">{SITE_DESCRIPTION}&nbsp; </span></td>
            </tr>
            <tr>
               <td class="cat" align="center" valign="middle" colspan="3">
                  <table cellspacing="1" cellpadding="1" border="0">
                     <tr>
                        <td align="center" valign="middle" nowrap >
                           <a href="{U_INDEX}" class="mainmenu"><img src="{NAV_IMAGES_HOME}" class="mx_icon" border="0" alt="" hspace="1" align="middle" /></a><span class="mainmenu"><a href="{U_INDEX}" class="mainmenu">{L_HOME}</a></span>
                        </td>
                        <td align="center" valign="middle" nowrap>
                           <a href="{U_INDEX_FORUM}" class="mainmenu"><img src="{NAV_IMAGES_FORUM}" class="mx_icon" border="0" alt="" hspace="1" align="middle" /></a><span class="mainmenu"><a href="{U_INDEX_FORUM}" class="mainmenu">{L_FORUM}</a></span>
                        </td>
                        <td align="center" valign="middle" nowrap>
                           <!-- BEGIN switch_user_logged_in -->
                           <a href="{U_PROFILE}" class="mainmenu"><img src="{NAV_IMAGES_PROFILE}" class="mx_icon" border="0" alt="" hspace="1" align="middle" /></a><span class="mainmenu"><a href="{U_PROFILE}" class="mainmenu">{L_PROFILE}</a></span>
                           <!-- END switch_user_logged_in -->
                        </td>
                        <td align="center" valign="middle" nowrap>
                           <a href="{U_FAQ}" class="mainmenu"><img src="{NAV_IMAGES_FAQ}" class="mx_icon" border="0" alt="" hspace="1" align="middle" /></a><span class="mainmenu"><a href="{U_FAQ}" class="mainmenu">{L_FAQ}</a></span>
                        </td>
                        <!--
                        <td align="center" valign="middle" nowrap>
                           <a href="{U_SEARCH}" class="mainmenu"><img src="{NAV_IMAGES_SEARCH}" class="mx_icon" border="0" alt="" hspace="1" align="middle" /></a><span class="mainmenu"><a href="{U_SEARCH}" class="mainmenu">{L_SEARCH}</a></span>
                        </td>
                        -->
                        <td align="center" valign="middle" nowrap>
                           <a href="{U_MEMBERLIST}" class="mainmenu"><img src="{NAV_IMAGES_MEMBERS}" class="mx_icon" border="0" alt="" hspace="1" align="middle" /></a><span class="mainmenu"><a href="{U_MEMBERLIST}" class="mainmenu">{L_MEMBERLIST}</a></span>
                        </td>
                        <td align="center" valign="middle" nowrap>
                           <a href="{U_GROUP_CP}" class="mainmenu"><img src="{NAV_IMAGES_GROUPS}" class="mx_icon" border="0" alt="" hspace="1" align="middle" /></a><span class="mainmenu"><a href="{U_GROUP_CP}" class="mainmenu">{L_USERGROUPS}</a></span>
                        </td>
                        <td align="center" valign="middle" nowrap>
                        <!-- BEGIN switch_user_logged_in -->
                           <a href="{U_PRIVATEMSGS}" class="mainmenu"><img src="{NAV_IMAGES_PRIVMSG}" class="mx_icon" border="0" alt="" hspace="1" align="middle" /></a><span class="mainmenu"><a href="{U_PRIVATEMSGS}" class="mainmenu">{L_PRIVATEMSGS}</a></span>
                           <!-- END switch_user_logged_in -->
                        </td>
                     </tr>

                  </table>
               </td>
            </tr>

Et remplacez tout ci-dessus par tous ce qui ce trouve après
Code: Tout sélectionner
<a name="top"></a>

du overall_header.tpl du thème de phpBB a installez
Ceci vous approcheras du thème de votre forum ,il y aura suivant les thèmes quelques améliorations à apporter ;)
olijack
 
Messages: 16
Inscription: Mer Fév 14, 2007 11:41 pm

Publicité

Messagede Globox60 » Mar Mai 08, 2007 8:38 pm

Ben je ne dois pas etre doué, j ai fait ce que tu as ecrit mais quand je change mon theme sur phpbb mon portail devient une page blanche.


Je ne pourrai pas te filer mon templates que tu me le fasse. Ca sera plus simple.

Merci d avance
Globox60
 
Messages: 22
Inscription: Lun Mai 07, 2007 9:16 pm

Messagede olijack » Mer Mai 09, 2007 4:48 pm

Au fait c'est avec le mxBB_Portal_2.8.0RC1 la mise au point du thème :oops:

Bon allez je suis dans un bon jour ,file le lien du thème :wink:
olijack
 
Messages: 16
Inscription: Mer Fév 14, 2007 11:41 pm

Messagede Globox60 » Jeu Mai 10, 2007 10:19 pm

Merci bcp voivi le liens : creamygreen
Globox60
 
Messages: 22
Inscription: Lun Mai 07, 2007 9:16 pm

Messagede olijack » Sam Mai 12, 2007 12:41 pm

Effectivement mon astuce ne marche pas avec ton thème :cry:
Les images sont dans des dossiers supplémentaires que le subSilver de base plus quelques changement de code pas catholique :D

En d'autres mots j'essaierais de trouver une solutions ,mais la :?

Biensur si tu trouve la soluce avant post la pour faire avancer le chmilblic :wink:
olijack
 
Messages: 16
Inscription: Mer Fév 14, 2007 11:41 pm

Messagede Globox60 » Sam Mai 12, 2007 4:42 pm

Oki je te remercie bcp ;)
Globox60
 
Messages: 22
Inscription: Lun Mai 07, 2007 9:16 pm


Retourner vers Le Portail mxBB2

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 2 invités