Aide au debbugage premod 3.0.6

Le forum de support de la premod phpBB SEO pour phpBB3.
La premod inclus les trois solution de réécriture d'URL de phpBB SEO ainsi que différents mods d'optimisation du référencement pré-installés.

Modérateur: Modérateurs

Aide au debbugage premod 3.0.6

Messagede cotp » Lun Nov 23, 2009 7:24 pm

Salut les amis et comme toujours, bravo pour cette mise à jour. :)

Pas facile pour moi comme d'ab de faire les mises à jours à cause de certains mods. Et comme y'a pas mal de changements avec la 3.0.6, certains ne sont juste pas compatible (exemple autogroups), donc en attendant je les ai désinstallé.

Le forum a l'air de tourner mais c'est une apparence :=), j'ai vu que mes avatars ne s'affichaient plus (une idée pourquoi et où je peux rergarder dans le code ?)
Plus non plus accès au panneau utilisateur.
Et quand je me déconnecte et que je tente une inscription http://forum.cineastes.com/ucp.php?mode=register
j'ai ce message d'erreur:
Code: Tout sélectionner
"Parse error: syntax error, unexpected $end in /home/***/***/***/public_html/forum/includes/template.php(218) : eval()'d code on line 246"


si je reessaye un coup ça devient:
Code: Tout sélectionner
Parse error: syntax error, unexpected $end in /home/***/***/***/public_html/forum/cache/tpl_cineastes-et-cinema_ucp_register.html.php on line 246


j'ai vérifié les mises à jour dans template.php et ucp.php (pas de soucis).
Y'at-il d'autres fichiers à vérifier ?

Merci par avance pour votre aide,

Cotp
Avatar de l’utilisateur
cotp
PR2
PR2
 
Messages: 298
Inscription: Dim Aoû 20, 2006 8:03 pm
Localisation: Paris

Publicité

Re: Aide au debbugage premod 3.0.6

Messagede dcz » Lun Nov 23, 2009 7:32 pm

Ton erreur vient d'un souci dans ucp_register.html, pas dans template.php.
Il doit y avoir un :
Code: Tout sélectionner
<!-- IF -->

pas fermé, un truc dans le genre.

Pour les avatars, regarde le code source de ta page, à l'endroit ou ils sont censés se mettre, et poste le ici. Ça doit pas être grand chose.

++
Useful links :
SEO Forum || SEO Directory || SEO phpBB || Search
____________________

Liens Utiles :
Forum référencement || Annuaire référencement || Référencement phpBB || Recherche
dcz
Admin
Admin
 
Messages: 21411
Inscription: Ven Avr 28, 2006 9:03 pm

Re: Aide au debbugage premod 3.0.6

Messagede cotp » Lun Nov 23, 2009 7:57 pm

Merci dcz de ta réponse rapide.

Voici le code
Code: Tout sélectionner
      <dl class="postprofile" id="profile53937">

         <dt>
            <a href="http://forum.cineastes.com/membre/Baptiste/"><img src="./images/avatars/gallery/2.jpg" width="100" height="100" alt="Avatar de l’utilisateur" /></a><br />
            <a href="http://forum.cineastes.com/membre/Baptiste/" style="color: #AA0000;" class="username-coloured">Baptiste</a>
         </dt>


en fait ça devrait pas être le répertoire gallery mais upload et un truc du genre 7e225372c20c0dfc4f9d76c9b9873103_2.jpg

EDIT: Je viens de réparer l'inscription en recommançant mes edits dans ucp_register.
Le problème venait que c'est un fichier très moddé car j'ai installé Ajax Registration check qui semble tjs marcher... ce qui est une bonne nouvelle...
Avatar de l’utilisateur
cotp
PR2
PR2
 
Messages: 298
Inscription: Dim Aoû 20, 2006 8:03 pm
Localisation: Paris

Re: Aide au debbugage premod 3.0.6

Messagede cotp » Lun Nov 23, 2009 9:09 pm

Ag je trouve tjs pas pour les avatars... faut que je regarde où cette fois ? Les templates semblent normaux...
Avatar de l’utilisateur
cotp
PR2
PR2
 
Messages: 298
Inscription: Dim Aoû 20, 2006 8:03 pm
Localisation: Paris

Re: Aide au debbugage premod 3.0.6

Messagede dcz » Mar Nov 24, 2009 8:33 am

Effectivement, -http://forum.cineastes.com/images/avatars/gallery/2.jpg n'a pas beaucoup de chance de mener quelque part.

Donc dans l'ordre, vérifies que tu as bien :
Code: Tout sélectionner
            'avatar'         => ($user->optionget('viewavatars')) ? get_user_avatar($row['user_avatar'], $row['user_avatar_type'], $row['user_avatar_width'], $row['user_avatar_height']) : '',

dans viewtopic.php, puis vérifies les code de :
Code: Tout sélectionner
get_user_avatar()

dans includes/functions_display.php et enfin, que tu as bien :
Code: Tout sélectionner
POSTER_AVATAR

dans viewtopic_body.html.
Useful links :
SEO Forum || SEO Directory || SEO phpBB || Search
____________________

Liens Utiles :
Forum référencement || Annuaire référencement || Référencement phpBB || Recherche
dcz
Admin
Admin
 
Messages: 21411
Inscription: Ven Avr 28, 2006 9:03 pm

Re: Aide au debbugage premod 3.0.6

Messagede cotp » Mar Nov 24, 2009 1:18 pm

dcz a écrit:Donc dans l'ordre, vérifies que tu as bien :
Code: Tout sélectionner
            'avatar'         => ($user->optionget('viewavatars')) ? get_user_avatar($row['user_avatar'], $row['user_avatar_type'], $row['user_avatar_width'], $row['user_avatar_height']) : '',

dans viewtopic.php


fais je l'ai bien 2 fois

dcz a écrit:, puis vérifies les code de :
Code: Tout sélectionner
get_user_avatar()

dans includes/functions_display.php


euh ce code tel quel n'est pas dans le code original que tu as fourni (cf package modified files et package complet) :?
mais sinon j'ai bien:
Code: Tout sélectionner
function get_user_avatar($avatar, $avatar_type, $avatar_width, $avatar_height, $alt = 'USER_AVATAR', $ignore_config = false)


dcz a écrit:et enfin, que tu as bien :
Code: Tout sélectionner
POSTER_AVATAR

dans viewtopic_body.html.


c'est bon, enfin j'ai
Code: Tout sélectionner
{postrow.POSTER_AVATAR}
Avatar de l’utilisateur
cotp
PR2
PR2
 
Messages: 298
Inscription: Dim Aoû 20, 2006 8:03 pm
Localisation: Paris

Re: Aide au debbugage premod 3.0.6

Messagede cotp » Mar Nov 24, 2009 1:45 pm

Bon je crois que j'ai trouvé... enfin j'ai ptet cassé autre chose en réparant

J'avais commenté la ligne

Code: Tout sélectionner
   /* original :
   return '<img src="' . (str_replace(' ', '%20', $avatar_img)) . '" width="' . $avatar_width . '" height="' . $avatar_height . '" alt="' . ((!empty($user->lang[$alt])) ? $user->lang[$alt] : $alt) . '" />';
}
   */


ça venait je crois d'un mod qui s'appelle ACP Announcement Centre...

Bon pour l'instant je cherche pas à comprendre... ça marche c'est l'essentiel... :P
Avatar de l’utilisateur
cotp
PR2
PR2
 
Messages: 298
Inscription: Dim Aoû 20, 2006 8:03 pm
Localisation: Paris


Retourner vers Premod phpBB SEO

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Bing [Bot] et 8 invités