Problème W3C [résolu]

Le forum de support de la premod phpBB SEO pour phpBB3.
La premod inclus les trois solution de réécriture d'URL de phpBB SEO ainsi que différents mods d'optimisation du référencement pré-installés.

Modérateur: Modérateurs

Problème W3C [résolu]

Messagede landry » Lun Juil 05, 2010 10:09 am

Bonjour,

Je viens de m'apercevoir que je rencontre un problème avec le W3C sur le dernier forum que j'ai créé :
Validation WC3 sur view_topic quand on se trouve sur mon forum Windows 7

Validation W3C sur view_topic quand on se trouve sur mon forum Vista ou n'importe quel autre forum.

Ca vient du script d'impréssion du sujet mais pourquoi uniquement sur ce forum ?

Merci
Dernière édition par landry le Jeu Nov 11, 2010 10:24 am, édité 1 fois.
La cuisine, c'est facile : http://www.ceinfo.fr
Et l'informatique aussi : http://www.micro-astuce.com
landry
PR3
PR3
 
Messages: 323
Inscription: Mer Sep 06, 2006 8:44 am
Localisation: Carcassonne (France)

Publicité

Re: Problème W3C

Messagede R1_Bzh » Mer Juil 07, 2010 7:56 am

Le souci pourrait venir du double && dans le lien.

Code: Tout sélectionner
<a href="http://www.micro-astuce.com/Forum/viewtopic.php?f=37&t=5228&start=0&&view=print" title="Imprimer le sujet" accesskey="p" class="print">


ou alors plutôt que le & n'est pas converti en &amp;
[ Phea ]: Développement PHP/MySQL/Ajax , hébergement de site & services mail et administration de serveur Unix
[ Coda-Cola ]: Solution de gestion de projets (subversion SVN / Redmine)
[ Rechercher ]
R1_Bzh
phpBB SEO Team
phpBB SEO Team
 
Messages: 214
Inscription: Mer Juil 04, 2007 3:29 pm
Localisation: Toulouse

Re: Problème W3C

Messagede landry » Lun Aoû 09, 2010 9:40 am

Bonjour,

Et quoi faire pour régler ça ?
La cuisine, c'est facile : http://www.ceinfo.fr
Et l'informatique aussi : http://www.micro-astuce.com
landry
PR3
PR3
 
Messages: 323
Inscription: Mer Sep 06, 2006 8:44 am
Localisation: Carcassonne (France)

Re: Problème W3C

Messagede gowap » Mar Aoû 17, 2010 12:28 pm

Le forum ou il n'y a "pas d'erreur" c'est parce que le robot du W3C ne reçoit pas le meme code qu'un visiteur normal, il doit avoir des permissions différentes selon les forums.
Dans le valideur, tu as l'option "show source" et en ligne 152 il devrait y avoir le lien "imprimer le sujet" que reçoivent les visiteurs (et le robot W3C dans l'autre forum).

Sinon les erreurs en soi, c'est bien parce qu'il y a double & et que qu'il devrait y avoir des &amp; au lieu de juste &.

Sur une premod normale, dans viewtopic ligne 747 tu as bien :
Code: Tout sélectionner
   // www.phpBB-SEO.com SEO TOOLKIT BEGIN
   'U_PRINT_TOPIC'         => ($auth->acl_get('f_print', $forum_id)) ? append_sid("{$phpbb_root_path}viewtopic.$phpEx", "f=$forum_id&amp;t=$topic_id&amp;start=$start&amp;" . ((strlen($u_sort_param)) ? "&amp;$u_sort_param" : '') . (($highlight_match) ? "&amp;hilit=$highlight" : '') . "&amp;view=print") : '',
   // www.phpBB-SEO.com SEO TOOLKIT END

y a bien des &amp; partout.
Gravure-News : la communauté francophone de la gravure de CD/DVD et son forum d'entraide.
Avatar de l’utilisateur
gowap
phpBB SEO Team
phpBB SEO Team
 
Messages: 1510
Inscription: Dim Mai 07, 2006 10:56 pm

Re: Problème W3C

Messagede landry » Jeu Nov 11, 2010 10:23 am

Merci gowap :D

Je ne reçois pas les réponses de ce forum ce qui explique pourquoi je n'ai pas répondu avant.
J'ai fait ce que tu m'as dit de faire et ça fonctionne.
Merci beaucoup :wink:

Pour info dans viewtopic j'avais ceci :
Code: Tout sélectionner
'U_PRINT_TOPIC'         => ($auth->acl_get('f_print', $forum_id)) ? append_sid("{$phpbb_root_path}viewtopic.$phpEx", "f=$forum_id&t=$topic_id&start=$start&" . ((strlen($u_sort_param)) ? "&$u_sort_param" : '') . (($highlight_match) ? "&hilit=$highlight" : '') . "&view=print") : '',
La cuisine, c'est facile : http://www.ceinfo.fr
Et l'informatique aussi : http://www.micro-astuce.com
landry
PR3
PR3
 
Messages: 323
Inscription: Mer Sep 06, 2006 8:44 am
Localisation: Carcassonne (France)


Retourner vers Premod phpBB SEO

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 2 invités