Probleme sur OVH ? (Résolu)

Le forum de support du mod de réécriture d'URL pour phpBB3 en version Avancée.
Ce mod de réécriture d'url injecte les titres forums et des sujets dans leurs URLs.

Modérateur: Modérateurs

Probleme sur OVH ? (Résolu)

Messagede RVI » Sam Aoû 18, 2007 8:09 pm

Bonjour,

Je sait pas pour quoi Rewrite phpBB3 marche pas sur un domain heberge chez OVH mutualise. J'ai PhpBB 3 RC.4 et je fait tout ce que l'instructions m'ont dit de faire.
Le forum est instale dans un dossier. Voila le .htaccess qui se trouve dans / (racine, au dessus de forum-lep):


Code: Tout sélectionner
<Files "config.php">
Order Allow,Deny
Deny from All
</Files>

<Files "common.php">
Order Allow,Deny
Deny from All
</Files>

# You could need to un-comment the following line
Options +FollowSymlinks
RewriteEngine On
RewriteBase /

#########################################################
# forum-lep SEO REWRITE RULES            #
#########################################################
# AUTHOR : dcz http://www.forum-lep-seo.com/
# STARTED : 01/2006
#####################################################
# FORUMS PAGES
########################
# FORUM INDEX (un-comment if used)
RewriteRule ^forum-lep/index\.html$ /forum-lep/index.php [QSA,L]
# FORUM
# RewriteRule ^forum-lep/[a-z0-9_-]*-f([0-9]+)(-([0-9]+))?/?$ /forum-lep/viewforum.php?f=$1&start=$3 [QSA,L,NC]
# TOPIC
RewriteRule ^forum-lep/[a-z0-9_-]*-f([0-9]+)/[a-z0-9_-]*-t([0-9]+)(-([0-9]+))?\.html$ /forum-lep/viewtopic.php?f=$1&t=$2&start=$4 [QSA,L,NC]
# GLOBAL ANNOUNCES
RewriteRule ^forum-lep/(announces/)?[a-z0-9_-]*-t([0-9]+)(-([0-9]+))?\.html$ /forum-lep/viewtopic.php?t=$2&start=$4 [QSA,L,NC]
# POST
RewriteRule ^forum-lep/post([0-9]+)\.html$ /forum-lep/viewtopic.php?p=$1 [QSA,L]
#PROFILES
RewriteRule ^forum-lep/membre([0-9]+)\.html$ /forum-lep/memberlist.php?mode=viewprofile&u=$1 [QSA,L]
# THE TEAM
RewriteRule ^forum-lep/equipe\.html$ /forum-lep/memberlist.php?mode=leaders [QSA,L,NC]
# END forum-lep PAGES
#####################################################


Je suis presque sur que c'est une problemme du .htaccess, parce que je verifie avec le forum de test d'ici et le nom de sousforums et l'index est bien "forge".J'ai essaye avec " RewriteRule ^/forum-lep [...] " et même resultat.Y'a quelque chose a voir avec le chemin absolu ? (/home.18/e/m/e/utilisateur/www)
Merci de m'aider avec un conseil.
Dernière édition par RVI le Sam Aoû 18, 2007 11:44 pm, édité 1 fois.
RVI
 
Messages: 4
Inscription: Sam Aoû 18, 2007 7:56 pm

Publicité

Résolu !

Messagede RVI » Sam Aoû 18, 2007 11:37 pm

Contrairement a ce que quelqun a dit sur ce forum , le mode url_write est bien actif sur l'ofre mutualise start1g chez OVH .
Ma probleme c'etait dans le façon d'encodage de caracters, a place de UTF-8 un editeur de texte (je donne pas le nom, mais il est tres...utilise) certains caracters ont été mal sauvgardé aprés les modifications.
Conclusion :!: : Si vous voulez un editeur de texte et code, tres bon (gratuit) et sur, prenez PSPad editor, chez http://www.pspad.com/fr/ . Vous ne le regretez pas.Aussi, pour comparer 2 fichieres (text,html,php ou autres) prenez WinMerge , aussi gratuit.C'est comça que j'ai trouve mes erreurs.
Merci dcz pour ton travail, mon forum est presque parfait maintenant. A bientôt et bon courage!



PS: Les fautes en francais....ne tirez pas, je suis pas français ! :)
RVI
 
Messages: 4
Inscription: Sam Aoû 18, 2007 7:56 pm


Retourner vers Réécriture URL Avancée

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 3 invités