Problème: Mon site visible qu'avec et sans "www".

Le forum de support du mod de réécriture d'URL pour phpBB3 en version Intermédiaire. Ce mod de réécriture d'url injecte les titres forums dans leurs URLs en conservant une Réécriture statique pour les sujets.

Modérateur: Modérateurs

Problème: Mon site visible qu'avec et sans "www".

Messagede Pistache13 » Jeu Juin 24, 2010 1:01 pm

Bonjour à tous :)

J'ai besoin d'un petit coup de main.

Nous avons mis en place la prémod seo depuis peu :) grâce a vos précedents conseils.

Cependant on fait face à un problème qu'on arrive pas a solutionner. En effet actuellement notre site est visible avec les "www" et sans les "www", ce qui crée du duplicate sur notre site.

On avait donc utiliser la redirection suivante :

RewriteCond %{HTTP_HOST} !^casinosguide\.net$ [NC]
RewriteRule ^(.*)$ http://www.casinosguide.net/$1 [QSA,L,R=301]

Tout fonctionnait très bien, mais depuis la mise a jour de la premod notre htaccess a changé et il nous est impossible d'utiliser cette commande.

Coup d'oeil sur notre htaccess :

Code: Tout sélectionner
# Lines That should already be in your .htacess
<Files "config.php">
   Order Allow,Deny
   Deny from All
</Files>
<Files "common.php">
   Order Allow,Deny
   Deny from All
</Files>

# You may need to un-comment the following lines
# Options +FollowSymlinks
# To make sure that rewritten dir or file (/|.html) will not load dir.php in case it exist
# Options -MultiViews
# REMEBER YOU ONLY NEED TO STARD MOD REWRITE ONCE
RewriteEngine On
# Uncomment the statement below if you want to make use of
# HTTP authentication and it does not already work.
# This could be required if you are for example using PHP via Apache CGI.
# RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]
# REWRITE BASE
RewriteBase /
# HERE IS A GOOD PLACE TO FORCE CANONICAL DOMAIN
[color=#800000]# RewriteCond %{HTTP_HOST} !^casinosguide\.net$ [NC]
# RewriteRule ^(.*)$ http://www.casinosguide.net/$1 [QSA,L,R=301][/color]

# DO NOT GO FURTHER IF THE REQUESTED FILE / DIR DOES EXISTS
RewriteCond %{REQUEST_FILENAME} -f
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule . - [L]
#####################################################
# PHPBB SEO REWRITE RULES ALL MODES
#####################################################
# AUTHOR : dcz http://www.phpbb-seo.com
# STARTED : 01/2006
#################################
# FORUMS PAGES
###############
# FORUM INDEX REWRITERULE WOULD STAND HERE IF USED. "forum" REQUIRES TO BE SET AS FORUM INDEX
# RewriteRule ^phpBB/forum-casino/forum\.html$ /phpBB/forum-casino/index.php [QSA,L,NC]
# FORUM ALL MODES
RewriteRule ^phpBB/forum-casino/(forum|[a-z0-9_-]*-f)([0-9]+)(-([0-9]+))?\.html$ /phpBB/forum-casino/viewforum.php?f=$2&start=$4 [QSA,L,NC]
# TOPIC WITH VIRTUAL FOLDER ALL MODES
RewriteRule ^phpBB/forum-casino/(forum|[a-z0-9_-]*-f)([0-9]+)/(topic|[a-z0-9_-]*-t)([0-9]+)(-([0-9]+))?\.html$ /phpBB/forum-casino/viewtopic.php?f=$2&t=$4&start=$6 [QSA,L,NC]
# GLOBAL ANNOUNCES WITH VIRTUAL FOLDER ALL MODES
RewriteRule ^phpBB/forum-casino/annonces/(topic|[a-z0-9_-]*-t)([0-9]+)(-([0-9]+))?\.html$ /phpBB/forum-casino/viewtopic.php?t=$2&start=$4 [QSA,L,NC]
# TOPIC WITHOUT FORUM ID & DELIM ALL MODES
RewriteRule ^phpBB/forum-casino/([a-z0-9_-]*)/?(topic|[a-z0-9_-]*-t)([0-9]+)(-([0-9]+))?\.html$ /phpBB/forum-casino/viewtopic.php?forum_uri=$1&t=$3&start=$5 [QSA,L,NC]
# PHPBB FILES ALL MODES
RewriteRule ^phpBB/forum-casino/ressources/[a-z0-9_-]+/(thumb/)?([0-9]+)$ /phpBB/forum-casino/download/file.php?id=$2&t=$1 [QSA,L,NC]
# PROFILES ALL MODES WITH ID
RewriteRule ^phpBB/forum-casino/(membre|[a-z0-9_-]*-u)([0-9]+)\.html$ /phpBB/forum-casino/memberlist.php?mode=viewprofile&u=$2 [QSA,L,NC]
# USER MESSAGES ALL MODES WITH ID
RewriteRule ^phpBB/forum-casino/(membre|[a-z0-9_-]*-u)([0-9]+)-(topics|posts)(-([0-9]+))?\.html$ /phpBB/forum-casino/search.php?author_id=$2&sr=$3&start=$5 [QSA,L,NC]
# GROUPS ALL MODES
RewriteRule ^phpBB/forum-casino/(groupe|[a-z0-9_-]*-g)([0-9]+)(-([0-9]+))?\.html$ /phpBB/forum-casino/memberlist.php?mode=group&g=$2&start=$4 [QSA,L,NC]
# POST
RewriteRule ^phpBB/forum-casino/post([0-9]+)\.html$ /phpBB/forum-casino/viewtopic.php?p=$1 [QSA,L,NC]
# ACTIVE TOPICS
RewriteRule ^phpBB/forum-casino/sujets-actifs(-([0-9]+))?\.html$ /phpBB/forum-casino/search.php?search_id=active_topics&start=$2&sr=topics [QSA,L,NC]
# UNANSWERED TOPICS
RewriteRule ^phpBB/forum-casino/sans-reponses(-([0-9]+))?\.html$ /phpBB/forum-casino/search.php?search_id=unanswered&start=$2&sr=topics [QSA,L,NC]
# NEW POSTS
RewriteRule ^phpBB/forum-casino/nouveaux-messages(-([0-9]+))?\.html$ /phpBB/forum-casino/search.php?search_id=newposts&start=$2&sr=topics [QSA,L,NC]
# UNREAD POSTS
RewriteRule ^phpBB/forum-casino/non-lu(-([0-9]+))?\.html$ /phpBB/forum-casino/search.php?search_id=unreadposts&start=$2 [QSA,L,NC]
# THE TEAM
RewriteRule ^phpBB/forum-casino/equipe\.html$ /phpBB/forum-casino/memberlist.php?mode=leaders [QSA,L,NC]
# HERE IS A GOOD PLACE TO ADD OTHER PHPBB RELATED REWRITERULES

# FORUM WITHOUT ID & DELIM ALL MODES (SAME DELIM)
# THESE FOUR LINES MUST BE LOCATED AT THE END OF YOUR HTACCESS TO WORK PROPERLY
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^phpBB/forum-casino/([a-z0-9_-]+)(-([0-9]+))\.html$ /phpBB/forum-casino/viewforum.php?forum_uri=$1&start=$3 [QSA,L,NC]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^phpBB/forum-casino/([a-z0-9_-]+)\.html$ /phpBB/forum-casino/viewforum.php?forum_uri=$1 [QSA,L,NC]
# FIX RELATIVE PATHS : FILES
RewriteRule ^phpBB/forum-casino/.+/(style\.php|ucp\.php|mcp\.php|faq\.php|download/file.php)$ /phpBB/forum-casino/$1 [QSA,L,NC,R=301]
# FIX RELATIVE PATHS : IMAGES
RewriteRule ^phpBB/forum-casino/.+/(styles/.*|images/.*)/$ /phpBB/forum-casino/$1 [QSA,L,NC,R=301]
# END PHPBB PAGES
#####################################################

RedirectPermanent /nouveaux.htm  http://www.casinosguide.net/casinos-en-ligne-francais-top-10-casinos-guide.htm

[color=#FF0000]En le méttant ici (Position2), la redirection fonctionne très bien pour notre site mais ne fonctionne pas pour notre forum[/color]---------------------------------


On a donc placé cette redirection à l'endroit qui semble le plus propice en "rouge". On vient seulement de rajouter les "#" car quand on les enleve rien ne fonctionne , le site devient limite inacessible.

On a donc essaye de le placer en Position 2 (En rouge), dans ce cas pour le site ca marche mais le forum non. En effet la page d'accueil du forum pas de soucis mais impossible ensuite d'acceder aux autres pages.

Que puis-je faire pour solutionner mon problème ?

Merci d'avance
Pistache13
 
Messages: 12
Inscription: Jeu Mai 20, 2010 3:08 am

Publicité

Re: Problème: Mon site visible qu'avec et sans "www".

Messagede ErnadoO » Jeu Juin 24, 2010 4:07 pm

Essai:
Code: Tout sélectionner
RewriteCond %{HTTP_HOST} !^www\.casinosguide\.net$ [NC]
RewriteRule ^(.*)$ http://www.casinosguide.net/$1 [QSA,L,R=301]
phpBB-Services.com: L'hébergement et l'assistance de votre forum phpBB en toute tranquillité.
ErnadoO
phpBB SEO Team
phpBB SEO Team
 
Messages: 333
Inscription: Ven Sep 15, 2006 4:57 pm
Localisation: Paris

Re: Problème: Mon site visible qu'avec et sans "www".

Messagede Pistache13 » Jeu Juin 24, 2010 4:59 pm

Déjà essayé quand je fais ça le site devient limite indisponible...
Pistache13
 
Messages: 12
Inscription: Jeu Mai 20, 2010 3:08 am

Re: Problème: Mon site visible qu'avec et sans "www".

Messagede ErnadoO » Ven Juin 25, 2010 7:01 am

ça veut dire quoi pour toi "limite indisponible" :?:
phpBB-Services.com: L'hébergement et l'assistance de votre forum phpBB en toute tranquillité.
ErnadoO
phpBB SEO Team
phpBB SEO Team
 
Messages: 333
Inscription: Ven Sep 15, 2006 4:57 pm
Localisation: Paris

Re: Problème: Mon site visible qu'avec et sans "www".

Messagede Pistache13 » Ven Juin 25, 2010 1:24 pm

Tout simplement que le fait que tu n'arrives plus a acceder au site mais ca ne renvoie a aucune erreur.

Par contre lorsque je met cette commande : Autre part (htacess) que l'endroit désigné par le premod, le site se comporte tres bien mais pour le forum ca va pas y'a qu'une seule page a laquelle on peut acceder. (home page du forum)

RewriteCond %{HTTP_HOST} !^www\.casinosguide\.net$ [NC]
RewriteRule ^(.*)$ http://www.casinosguide.net/$1 [QSA,L,R=301]

Bref je comprends pas du tout le problème.
Pistache13
 
Messages: 12
Inscription: Jeu Mai 20, 2010 3:08 am

Re: Problème: Mon site visible qu'avec et sans "www".

Messagede Pistache13 » Ven Juin 25, 2010 3:02 pm

J'ai réglé le soucis :

J'ai remplacé la ligne de code par ça :

Options +FollowSymlinks
RewriteEngine on
RewriteCond %{HTTP_HOST} ^mon_site.com$
RewriteRule ^(.*) http://www.mon_site.com/$1 [QSA,L,R=301]

Et ça fonctionne tres bien sans aucun problème.

En esperant que ca posera pas un problème quelconque.
Pistache13
 
Messages: 12
Inscription: Jeu Mai 20, 2010 3:08 am

Re: Problème: Mon site visible qu'avec et sans "www".

Messagede Pistache13 » Ven Juin 25, 2010 3:16 pm

Par contre j'ai detecté un petit problème sur les titles.

En effet, pour la title de ma page index il la répète deux fois. Je sais pas pourquoi...

http://www.casinosguide.net/phpBB/forum-casino/

La title enregistré a la base c'est : Forum Casinosguide.net - Jeux Gratuits et Jeu Grattagogo.

Le problème c'est que lorsqu'on regarde le code source ca donne ça :

<title>Forum Casinosguide.net - Jeux Gratuits et Jeu Grattagogo. &bull; Forum Casinosguide.net - Jeux Gratuits et Jeu Grattagogo.</title>

Il mle repete deux fois la title et pire encore il a tendance a repeter la title de la page d'accueil sur toutes les pages de notre forum donc pour chaque url il rajoute : "Forum Casinosguide.net - Jeux Gratuits et Jeu Grattagogo" et ensuite les méta donnée propre à la page.

Comment peut-on faire pour que justement il ne repete pas la title de la page d'accxueil sur toutes les pages ? Et comment faire pour que sur la home page il ne repete pas deux fois "Forum Casinosguide.net - Jeux Gratuits et Jeu Grattagogo."

Merci d'avance, sachez que je suis bien conscient de vos efforts pouyr nous aider et je vous en remercie grandement.
Pistache13
 
Messages: 12
Inscription: Jeu Mai 20, 2010 3:08 am

Re: Problème: Mon site visible qu'avec et sans "www".

Messagede Pistache13 » Ven Juin 25, 2010 3:38 pm

Lol ! Encore 1 message :)

En faites Enardo, j'ai essayé avec ta technique et j'avias du mal le faire la 1ere fois mais ca fonctionne.

Le soucis, c'est que par contre les processus d'authenfication au forum etant réglé sans "www" ca pose donc un problème, car il est désormais iimpossible de se connecter au forum. Car pour se connecter à celui-ci faut acceder à une url qui est justement sans le "www"

Comment puis-je régler le soucis ?

Encore merci
Pistache13
 
Messages: 12
Inscription: Jeu Mai 20, 2010 3:08 am

Re: Problème: Mon site visible qu'avec et sans "www".

Messagede Pistache13 » Ven Juin 25, 2010 4:47 pm

C'est bon j'ai réglé le problème tout seul via le panneau de controle.

A la base les requêtes étaient configurées sur ça : http://nom-de-domaine.com

J'ai rajouté les "www" et ca marche parfaitement !!!!

Bref, vraiment content :)

Par contre toujours ce soucis avec les titles :)
Pistache13
 
Messages: 12
Inscription: Jeu Mai 20, 2010 3:08 am

Re: Problème: Mon site visible qu'avec et sans "www".

Messagede ErnadoO » Ven Juin 25, 2010 6:50 pm

Un vrai monologue dis donc.


parcontee mon pseudo c'est ErnadoO, pas Ernado ;)
phpBB-Services.com: L'hébergement et l'assistance de votre forum phpBB en toute tranquillité.
ErnadoO
phpBB SEO Team
phpBB SEO Team
 
Messages: 333
Inscription: Ven Sep 15, 2006 4:57 pm
Localisation: Paris

Re: Problème: Mon site visible qu'avec et sans "www".

Messagede Pistache13 » Ven Juin 25, 2010 7:04 pm

Oui je sais je me suis pris au jeu. Je me suis parlé à moi même.

Bon pour Enardo, c'est ptet du a fait que je vis en Espagne. Tu me le pardonnera.

Par contre Ernardo0, j'ai un soucis sur les titles... et ca je comprends pas d'ou vient le problème.

T'a une idée ?

En effet, pour la title de ma page index il la répète deux fois. Je sais pas pourquoi...

http://www.casinosguide.net/phpBB/forum-casino/

La title enregistré a la base c'est : Forum Casinosguide.net - Jeux Gratuits et Jeu Grattagogo.

Le problème c'est que lorsqu'on regarde le code source ca donne ça :

<title>Forum Casinosguide.net - Jeux Gratuits et Jeu Grattagogo. &bull; Forum Casinosguide.net - Jeux Gratuits et Jeu Grattagogo.</title>

Il mle repete deux fois la title et pire encore il a tendance a repeter la title de la page d'accueil sur toutes les pages de notre forum donc pour chaque url il rajoute : "Forum Casinosguide.net - Jeux Gratuits et Jeu Grattagogo" et ensuite les méta donnée propre à la page.

Comment peut-on faire pour que justement il ne repete pas la title de la page d'accxueil sur toutes les pages ? Et comment faire pour que sur la home page il ne repete pas deux fois "Forum Casinosguide.net - Jeux Gratuits et Jeu Grattagogo."
Pistache13
 
Messages: 12
Inscription: Jeu Mai 20, 2010 3:08 am

Re: Problème: Mon site visible qu'avec et sans "www".

Messagede grattag » Sam Mar 10, 2012 1:19 pm

Bonjour,

Dans ce post, il est cité notre marque "Grattagogo" déposée à l'Inpi.

Nous vous demandons de bien vouloir supprimer ce post positionné en 1ère page dans les serps
lorsque que l'on saisi notre marque.

Le préjudice que subi notre marque "Grattagogo" est avéré dans ce post.

Nous vous remercions d'effectuer le nécessaire rapidement.

Donc, dans l'attente de vous lire rapidement à ce sujet.

Bien à vous et cordialement.

Philippe
grattag
 
Messages: 3
Inscription: Sam Mar 10, 2012 1:09 pm

Re: Problème: Mon site visible qu'avec et sans "www".

Messagede grattag » Mar Mar 13, 2012 6:48 pm

Bonjour,

Un petit up pour ma demande :mrgreen:

Toujours pas de réponses ? Les modérateurs peuvent-ils me répondre.

Par avance, merci et c'est urgent.
grattag
 
Messages: 3
Inscription: Sam Mar 10, 2012 1:09 pm

Re: Problème: Mon site visible qu'avec et sans "www".

Messagede Cab » Mer Mar 14, 2012 2:49 pm

Je ne suis pas modérateur, mais à mon humble avis votre demande est surprenante, dans la mesure où :
- votre site est bel et bien 1er sur la requête en question
- ce forum ne tente visiblement pas d'exploitation commerciale de cette requête, puisque ça n'a rien à voir.
Où est le "préjudice avéré" ?
Mais bon ce n'est qu'un avis et je ne suis pas une spécialiste des marques...
Cab
 
Messages: 11
Inscription: Ven Mar 02, 2012 10:47 pm
Localisation: France

Re: Problème: Mon site visible qu'avec et sans "www".

Messagede grattag » Mer Mar 14, 2012 3:11 pm

Bonjour !

Enfin une réponse :mrgreen:

Le post initial n'a pas été créé par nous mais par une personne qui a travaillé pour notre société.
Cependant, nous lui avons jamais demandé de citer notre marque, qui d'ailleurs ne concernait pas
son travail initial de surcroît.

Le site Grattagogo doit être relancé courant du mois et ce post est toujours dans les serps.
Ce post donc nous porte préjudice pour diverses raisons.

Bref, nous avons le droit, en tant que propriétaire d'une marque déposée européenne, d'effectuer une demande
de rectification afin de nettoyer les serps concernant notre marque.

A priori, les admins et modos de ce site semblent sourds !

Bref, je leur laisse quelque jours. Ensuite, dossier remis à notre avocat
et à un site de nettoyage. (frais à leur charge...).

Merci de nous avoir répondu en tous les cas.
grattag
 
Messages: 3
Inscription: Sam Mar 10, 2012 1:09 pm

Suivante

Retourner vers Réécriture URL Intermédiaire

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 11 invités


 
cron